Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » TCL Interpreter minimum version ?
TCL Interpreter minimum version ? [message #520721] Sun, 14 March 2010 17:42 Go to next message
madum  is currently offline madum
Messages: 3
Registered: March 2010
Junior Member
Hi All,

I'm pretty new with DLTK Tcl and I have an issue using Galileo (Eclipse 3.5) with dltk-tcl-S-2.0M5 and also tried with Ganymede (Eclipse 3.4) with dltk-tcl-R-0.95.1.
When I search for Tcl interpreters, there are two versions found : 8.3.15 and 8.4.19. Eclipse recognize the 8.4 version and propose as interpreter name "Tcl 8.4.19", but gives the name "tclsh.exe" for the 8.3 version. This is the one I need to use.
So when I edit this last entry, I get the message "No interpreter executables found" at the bottom of the window.

I call my friend google to help me finding any information about this, but nothing in wiki's or newsgroups.

Is there any minimal Tcl interpreter version to be used with DLTK Tcl ?
Thanks a lot

regards,
Re: TCL Interpreter minimum version ? [message #520740 is a reply to message #520721] Sun, 14 March 2010 23:57 Go to previous messageGo to next message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Hi,

DLTK uses the following script to validate the interpreter

puts "#DLTK INTERPRETER TEST:[expr {2 + 3}]"
puts "#DLTK INTERPRETER VERSION:$tcl_version"
parray env


Probably this script doesn't work in 8.3, but I couldn't find 8.3 binary distribution to test (it was released long ago - in 2002). Could you please test if it works for you? Or probably provide some adjustments to make it working.

Regards,
Alex
Re: TCL Interpreter minimum version ? [message #520770 is a reply to message #520740] Mon, 15 March 2010 05:45 Go to previous messageGo to next message
madum  is currently offline madum
Messages: 3
Registered: March 2010
Junior Member
Thanks for your help,
I tried your test and got : #DLTK INTERPRETER TEST : 5 for first test and #DLTK INTERPRETER VERSION : 8.3 for second. "parray env" also worked well.
But this interpreter is still not recognized in Preferences / Tc l / Interpreters / Interpreter executable : still have "No interpreter executables found" at the bottom of the windows.

Regards,
Martial
Re: TCL Interpreter minimum version ? [message #526817 is a reply to message #520721] Tue, 13 April 2010 02:31 Go to previous messageGo to next message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Hi Martial,

It turns out I missed the latest change: now DLTK uses
org.eclipse.dltk.tcl.core/scripts/dltk.tcl with the "get-pkgs" argument
to validate the interpreter.

Could you please test how it works with your version of the interpreter?

Regards,
Alex
Re: TCL Interpreter minimum version ? [message #542366 is a reply to message #526817] Thu, 24 June 2010 11:57 Go to previous message
madum  is currently offline madum
Messages: 3
Registered: March 2010
Junior Member
Hi Alex,

Sorry, I just read your answer today (I worked with 8.4.19 since march)
So I tried your test and got the following error :
couldn't open "C:/TCL_8_3_5": permission denied
while executing
"open $fname w"
(procedure "print-pkg-info" line 130)
invoked from within
"print-pkg-info $output"
(procedure "main" line 89)
invoked from within
"main $argv"
(file "C:\dltk.tcl" line 729)

So, after investigation I found that the get-canonical-path proc does not return empty string when path parameter is empty for tcl_version less than 8.4.

I changed at line 179

} elseif {[string equal [file pathtype $path] "relative"]} {
set retVal [file join [pwd] $path]
} ;# End of if stmt

by

} elseif {[string equal [file pathtype $path] "relative"]} {
if { $path != "" } {
set retVal [file join [pwd] $path]
}
} ;# End of if stmt

because [file join [pwd] $path] returns the current path rather than nothing.

I have tested it in org.eclipse.dltk.tcl.core_2.0.0.v20091103-1812.jar and now tcl 8.3.5 is well detected through preference/Tcl/Interpreters/Search.

If it could help for old tcl versions usage ...

Thanks for your support

regards,
Martial
Previous Topic:How do I use the DLTK JavaScript debugger?
Next Topic:Final Version
Goto Forum:
  


Current Time: Mon Jul 28 18:46:12 EDT 2014

Powered by FUDForum. Page generated in 0.22247 seconds