Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » launch error and Validate plugins prior to launching: usefull defaults ?
launch error and Validate plugins prior to launching: usefull defaults ? [message #520310] Thu, 11 March 2010 21:34 Go to next message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
Hi

just a short question when reading
http://www.vogella.de/articles/EclipseE4/article.html

why dont we make "Validate plugins prior to launching" as default, means
enable this by default ?

it is a bit frustrating for a user if he gets an application launch
error always in the first place ;-)

BTW. why it is necessary at all ?

thanks,
Berni.
Re: launch error and Validate plugins prior to launching: usefull defaults ? [message #520348 is a reply to message #520310] Thu, 11 March 2010 23:14 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Hi Bernhard,

for "Validate" please see bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=272076

Validate is a good setting in case you change your dependencies and
forget to adjust the launch configuration.

Best regards, Lars

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 11.03.2010 13:34, Bernhard Merkle wrote:
> Hi
>
> just a short question when reading
> http://www.vogella.de/articles/EclipseE4/article.html
>
> why dont we make "Validate plugins prior to launching" as default, means
> enable this by default ?
>
> it is a bit frustrating for a user if he gets an application launch
> error always in the first place ;-)
>
> BTW. why it is necessary at all ?
>
> thanks,
> Berni.
Re: launch error and Validate plugins prior to launching: usefull defaults ? [message #520374 is a reply to message #520348] Fri, 12 March 2010 07:17 Go to previous message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
Lars, thanks for the hint. I commented in bugzilla
Re: launch error and Validate plugins prior to launching: usefull defaults ? [message #569949 is a reply to message #520310] Fri, 12 March 2010 04:04 Go to previous message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Hi Bernhard,

for "Validate" please see bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=272076

Validate is a good setting in case you change your dependencies and
forget to adjust the launch configuration.

Best regards, Lars

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


On 11.03.2010 13:34, Bernhard Merkle wrote:
> Hi
>
> just a short question when reading
> http://www.vogella.de/articles/EclipseE4/article.html
>
> why dont we make "Validate plugins prior to launching" as default, means
> enable this by default ?
>
> it is a bit frustrating for a user if he gets an application launch
> error always in the first place ;-)
>
> BTW. why it is necessary at all ?
>
> thanks,
> Berni.
Re: launch error and Validate plugins prior to launching: usefull defaults ? [message #569998 is a reply to message #569949] Fri, 12 March 2010 07:17 Go to previous message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
Lars, thanks for the hint. I commented in bugzilla
Previous Topic:IXWTLoader DISBALE_STYLES_PROPERTY = "XWT.DisabledStyles";
Next Topic:sample applications does not contain mnemonic underliners for menu
Goto Forum:
  


Current Time: Tue Dec 23 02:33:46 GMT 2014

Powered by FUDForum. Page generated in 0.01800 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software