Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Application Server + Eclipse = Page cannot be found. (Application Server 10.1.3.10 )
Application Server + Eclipse = Page cannot be found. [message #517941] Tue, 02 March 2010 15:10
Alarm  is currently offline Alarm Friend
Messages: 1
Registered: March 2010
Junior Member
Hello, i am running the application Server 10.1.3.10 and use Eclipse as an IDE.
Creating projects through Eclipse and publish them on Tomcat works fine.
Things start to go wrong when Eclipse is combined with Oracle AS to publish even a simple jsp page.

After creating a dynamic web project and trying to run a jsp page on the Oracle server i get following warning in the logs.


10/03/02 13:42:29 log4j:WARN No appenders could be found for logger (wsif).
10/03/02 13:42:29 log4j:WARN Please initialize the log4j system properly.
_10/03/02 13:42:29 Warning: Unable to set up connection factory for a resource adapter in esb-dt: Error creating a ResourceAdapter implementation class. Error creating a JavaBean of class 'oracle.tip.esb.server.bootstrap.DesignTimeResourceAdapter: javax.resource.spi.ResourceAdapterInternalException: java.lang.RuntimeException: failed to get ESB_HOME: java.lang.NullPointerException_
_10/03/02 13:42:29 Warning: Unable to set up connection factory for a resource adapter in esb-rt: Error creating a ResourceAdapter implementation class. Error creating a JavaBean of class 'oracle.tip.esb.server.bootstrap.RuntimeResourceAdapter: javax.resource.spi.ResourceAdapterInternalException: java.lang.RuntimeException: failed to get ESB_HOME: java.lang.NullPointerException_
10/03/02 13:42:35 Confluent Config: Loading configuration file config.xml
10/03/02 13:42:35 Confluent Config: "${config.path}" is resolved to "config.properties"
10/03/02 13:42:35 Confluent Config: "${gateway.default.config.path}" is resolved to " gateway-config-installer.properties;gateway-config-common.pr operties "
10/03/02 13:42:35 Confluent Config: Loading property file config.properties
10/03/02 13:42:35 Confluent Config: Loading property file gateway-config-installer.properties
10/03/02 13:42:35 Confluent Config: Loading property file gateway-config-common.properties
10/03/02 13:42:35 Confluent Config: Loading configuration file config.xml
10/03/02 13:42:35 Confluent Config: "${config.path}" is resolved to "config.properties"
10/03/02 13:42:35 Confluent Config: "${gateway.default.config.path}" is resolved to " gateway-config-installer.properties;gateway-config-common.pr operties "
10/03/02 13:42:35 Confluent Config: Loading property file config.properties
10/03/02 13:42:35 Confluent Config: Loading property file gateway-config-installer.properties
10/03/02 13:42:35 Confluent Config: Loading property file gateway-config-common.properties
10/03/02 13:42:35
ConnectionPoolManager gateway.foundationservice intialized with url=jdbc:polite4@localhost:1531:orawsm driver=oracle.lite.poljdbc.POLJDBCDriver user=system maxConn=5
10/03/02 13:42:35 Gateway component started
10/03/02 13:42:36 Confluent Config: Loading configuration file config.xml
10/03/02 13:42:36 Confluent Config: "${config.path}" is resolved to "config.properties"
10/03/02 13:42:36 Confluent Config: "${policymanager.default.config.path}" is resolved to " policymanager-config-installer.properties;policymanager-conf ig-common.properties "
10/03/02 13:42:36 Confluent Config: Loading property file config.properties
10/03/02 13:42:36 Confluent Config: Loading property file policymanager-config-installer.properties
10/03/02 13:42:36 Confluent Config: Loading property file policymanager-config-common.properties
10/03/02 13:42:36
ConnectionPoolManager PolicyRepository intialized with url=jdbc:polite4@localhost:1531:orawsm driver=oracle.lite.poljdbc.POLJDBCDriver user=system maxConn=5
10/03/02 13:42:36
ConnectionPoolManager ComponentRepository intialized with url=jdbc:polite4@localhost:1531:orawsm driver=oracle.lite.poljdbc.POLJDBCDriver user=system maxConn=5
10/03/02 13:42:36 Policy Manager component started
10/03/02 13:42:36 Confluent Config: Loading configuration file config.xml
10/03/02 13:42:36 Confluent Config: "${config.path}" is resolved to "config.properties"
10/03/02 13:42:36 Confluent Config: "${ui.default.config.path}" is resolved to "ui-config installer.properties;ui-config-common.properties"
10/03/02 13:42:36 Confluent Config: Loading property file config.properties
10/03/02 13:42:36 Confluent Config: Loading property file ui-config-installer.properties
10/03/02 13:42:36 Confluent Config: Loading property file ui-config-common.properties
10/03/02 13:42:36 Authentication Provider is:com.cfluent.accessprovider.sampledb.LocalDBAuthProvider
10/03/02 13:42:36
ConnectionPoolManager Component Repository Pool intialized with url=jdbc:polite4@localhost:1531:orawsm driver=oracle.lite.poljdbc.POLJDBCDriver user=system maxConn=5
10/03/02 13:42:36
ConnectionPoolManager UI Pool intialized with url=jdbc:polite4@localhost:1531:orawsm driver=oracle.lite.poljdbc.POLJDBCDriver user=system maxConn=5
10/03/02 13:42:36 Confluent UI component started
10/03/02 13:42:36 Corda Servlet Environment Initialized
10/03/02 13:42:39

Corda Server (PopChart) Version 6.0.597
PopChart: Valid Key.
OptiMap: No key entered, or key invalid.
Highwire: No key entered, or key invalid.
Cluster: No key entered, or key invalid.

10/03/02 13:42:39 Copyright 1997 - 2004, Corda Technologies, Inc. (www.corda.com) Protected by U.S. Patent 5,933,830. Other patents pending.
10/03/02 13:42:39
10/03/02 13:42:39 server_root: C:/oracle/Application_Server/owsm/lib/corda
10/03/02 13:42:39 chart_root: chart_root
10/03/02 13:42:39 Password is Enabled, Required for Save
10/03/02 13:42:39 Maximum Threads: 64
10/03/02 13:42:39 Default Image Type is: Flash
10/03/02 13:42:39 Auto Detect PNG Support. Compression Mode: DEFAULT
10/03/02 13:42:39
10/03/02 13:42:41 Confluent Config: Loading configuration file config.xml
10/03/02 13:42:41 Confluent Config: "${config.path}" is resolved to "config.properties"
10/03/02 13:42:41 Confluent Config: "${monitor.default.config.path}" is resolved to " monitor-config-installer.properties;monitor-config-common.pr operties "
10/03/02 13:42:41 Confluent Config: Loading property file config.properties
10/03/02 13:42:41 Confluent Config: Loading property file monitor-config-installer.properties
10/03/02 13:42:41 Confluent Config: Loading property file monitor-config-common.properties
10/03/02 13:42:44 Rmi Registry is started on port 3118
10/03/02 13:42:44 Confluent Monitor component started
10/03/02 13:42:44 Oracle Containers for J2EE 10g (10.1.3.1.0) initialized


I have looked for those warnings and found that those warnings can be ignored. Then i get a confirmation
that "Build was successful"

Buildfile: C:\Program Files\Eclipse\eclipse\plugins\org.eclipse.jst.server.generic .oc4j_1.5.206.v20090812\buildfiles\oracle.10.1.3.xml
check.skip.web.deploy:
deploy.j2ee.web:
BUILD SUCCESSFUL
Total time: 625 milliseconds

The point is that on my IDE (Eclipse the page is not being displayed getting an error "The webpage cannot be found" .

The only way i could publish the jsp is to copy it to the APPLICATIONSERVER_HOME\j2ee\home\default-web-app

and access it through http://localhost:8888/projectname/foo.jsp

What could be wrong?
Previous Topic:web project in eclipse doesn't find tomcat
Next Topic:need WTP plugin for eclpse 3.4.1
Goto Forum:
  


Current Time: Fri Dec 19 11:02:46 GMT 2014

Powered by FUDForum. Page generated in 0.02490 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software