Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » [wikitext-to-xslfo] Empty feature results in error
[wikitext-to-xslfo] Empty feature results in error [message #516075] Mon, 22 February 2010 12:05 Go to next message
Nicolas Guyomar is currently offline Nicolas Guyomar
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi everyone

I'm getting an error while using wikitext-to-xslfo.

Each of my generated XSL-FO files contain an empty "static-content" feature.
modisco.fo:1:392: Error(1/392): fo:static-content is missing child elements. 
      [fop] Required Content Model: (%block;)+


If I add a simple <block/> inside of this first feature, everything works fine to generate the PDF

My mediawiki file seems to be fine because it works with "wikitext-to-eclipse-help" to generate Eclipse HEllp Content

<wikitext-to-xslfo 
				markupLanguage="org.eclipse.mylyn.wikitext.mediawiki.core.MediaWikiLanguage"
			 	pageBreakOnHeading1="false">											
				<fileset dir="${tmpFolder}" includes="**/*.mediawiki"/>							
			</wikitext-to-xslfo>



Regards
Nicolas


[Updated on: Tue, 23 February 2010 08:57]

Report message to a moderator

Re: [wikitext-to-xslfo] Empty [message #516758 is a reply to message #516075] Wed, 24 February 2010 19:36 Go to previous message
David Green is currently offline David Green
Messages: 135
Registered: July 2009
Senior Member
If you file a bug ( https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Mylyn&am p;component=WikiText) and attach your
mediawiki source I'll take a look.

Thanks,

David

On 22/02/10 9:05 AM, Nicolas Guyomar wrote:
> Hi everyone
>
> I'm getting an error while using wikitext-to-xslfo.
>
> Each of my generated XSL-FO files contain an empty "static-content"
> feature.
> modisco.fo:1:392: Error(1/392): fo:static-content is missing child
> elements. [fop] Required Content Model: (%block;)+
>
> If I had a simple <block/> inside of this first feature, everything
> works fine to generate the PDF
>
> My mediawiki file seems to be fine because it works with
> "wikitext-to-eclipse-help" to generate Eclipse HEllp Content
>
> <wikitext-to-xslfo
> markupLanguage="org.eclipse.mylyn.wikitext.mediawiki.core.MediaWikiLanguage "
>
> pageBreakOnHeading1="false">
> <fileset dir="${tmpFolder}" includes="**/*.mediawiki"/>
> </wikitext-to-xslfo>
>
>
> Regards
> Nicolas
Previous Topic:[WikiText] Is there any HTML to WikiText translator in java?
Next Topic:[wikitext-to-xslfo] Empty
Goto Forum:
  


Current Time: Fri Aug 29 12:22:29 EDT 2014

Powered by FUDForum. Page generated in 0.02818 seconds