Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Headless PDE build: incorrect compile*.xml script
Headless PDE build: incorrect compile*.xml script [message #515971] Mon, 22 February 2010 06:00 Go to next message
Stefan Jurack is currently offline Stefan Jurack
Messages: 24
Registered: February 2010
Junior Member
Hi,

I identified some strange behavior in headless PDE (Eclipse 3.5) build,
building one feature with 9 plugins bundled:
1) Starting the build process three times each leads to a different
compile*.xml script with:
a) different plugins even *missing* and
b) a compile order which is inappropriate regarding plugin-dependecies
i.e. some plugins are tried to be compiled before other plugins they
depend on.
2) Furthermore, although I set flag "parallelCompilation=false" in the
build.properties, the generated compile-script defines thread groups.



Please find the following files:
* Whole project structure:
http://dev.eclipse.org/svnroot/modeling/org.eclipse.emft.hen shin/
* in particular, build.properties:
http://dev.eclipse.org/svnroot/modeling/org.eclipse.emft.hen shin/releng/build.properties

* Tree different compile-scripts generated out of the same source, with
each missing different plugins.
http://www.mathematik.uni-marburg.de/~sjurack/tmp/1_compile. org.eclipse.emf.henshin.runtime.xml
http://www.mathematik.uni-marburg.de/~sjurack/tmp/2_compile. org.eclipse.emf.henshin.runtime.xml
http://www.mathematik.uni-marburg.de/~sjurack/tmp/3_compile. org.eclipse.emf.henshin.runtime.xml

Help is highly appreciated!

Thanx in advance,
Stefan
Re: Headless PDE build: incorrect compile*.xml script [message #516051 is a reply to message #515971] Mon, 22 February 2010 10:38 Go to previous message
Stefan Jurack is currently offline Stefan Jurack
Messages: 24
Registered: February 2010
Junior Member
Sorry, I didn't know, that forum and newsgroup are connected. Please ignore this post and reply to the later one with equal topic:

http://www.eclipse.org/forums/index.php?t=msg&th=163092& amp;start=0&
Previous Topic:Checking validity of content of an Editor?
Next Topic:Disable save for launchConfiguration.launch?
Goto Forum:
  


Current Time: Fri Aug 22 00:13:34 EDT 2014

Powered by FUDForum. Page generated in 0.01600 seconds