Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Problem with SVN auth from headless buckminster
Problem with SVN auth from headless buckminster [message #513921] Thu, 11 February 2010 16:34 Go to next message
Chicherin Andrey is currently offline Chicherin AndreyFriend
Messages: 2
Registered: February 2010
Junior Member
Hi,

I`m trying to set up the buckminster to work with a svn repository which
requires an authentication.

At my rmap i`ve tried to use the scheme like this:

<uri format="svn://user:password@host/..

but it didn`t work.

I`m using Subclipse headless adapter
(org.eclipse.buckminster.subclipse.headless 1.0.0.r10759)

After some debugging, I see that m_clientAdapter (in
org.eclipse.buckminster.subclipse.internal.SvnSession) isn`t initialized
by username and password from initial svn repo url.

Is it a bug?
or where am I wrong?

Thanks in advance.
Re: Problem with SVN auth from headless buckminster [message #514046 is a reply to message #513921] Fri, 12 February 2010 09:42 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
Hi Andrey,
One way of doing this is to create a template workspace where you have added the repository location with credentials. I.e.

1. Start your IDE on a new workspace.
2. Add the repository location with credentials in the SVN repository view
3. Exit your IDE.
4. Create a zip of the workspace.
5. Use the zip as template workspace (i.e. -T <zip file>) when you import.

Buckminster will match the location found in the RMAP against any existing repository locations and thus, make use of
the credentials that you have added.

HTH,
Thomas Hallgren


On 02/11/2010 05:34 PM, Chicherin Andrey wrote:
> Hi,
>
> I`m trying to set up the buckminster to work with a svn repository which
> requires an authentication.
>
> At my rmap i`ve tried to use the scheme like this:
>
> <uri format="svn://user:password@host/..
>
> but it didn`t work.
>
> I`m using Subclipse headless adapter
> (org.eclipse.buckminster.subclipse.headless 1.0.0.r10759)
>
> After some debugging, I see that m_clientAdapter (in
> org.eclipse.buckminster.subclipse.internal.SvnSession) isn`t initialized
> by username and password from initial svn repo url.
>
> Is it a bug?
> or where am I wrong?
>
> Thanks in advance.
Re: Problem with SVN auth from headless buckminster [message #514053 is a reply to message #514046] Fri, 12 February 2010 05:20 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
One thing that I forgot to add. You must use Subclipse with SVNKit in your IDE since SVNKit is used by the headless
environment. SVNKit and JavaHL will not store the credentials in the same place.

- thomas

On 02/12/2010 10:42 AM, Thomas Hallgren wrote:
> Hi Andrey,
> One way of doing this is to create a template workspace where you have
> added the repository location with credentials. I.e.
>
> 1. Start your IDE on a new workspace.
> 2. Add the repository location with credentials in the SVN repository view
> 3. Exit your IDE.
> 4. Create a zip of the workspace.
> 5. Use the zip as template workspace (i.e. -T <zip file>) when you import.
>
> Buckminster will match the location found in the RMAP against any
> existing repository locations and thus, make use of the credentials that
> you have added.
>
> HTH,
> Thomas Hallgren
>
>
> On 02/11/2010 05:34 PM, Chicherin Andrey wrote:
>> Hi,
>>
>> I`m trying to set up the buckminster to work with a svn repository which
>> requires an authentication.
>>
>> At my rmap i`ve tried to use the scheme like this:
>>
>> <uri format="svn://user:password@host/..
>>
>> but it didn`t work.
>>
>> I`m using Subclipse headless adapter
>> (org.eclipse.buckminster.subclipse.headless 1.0.0.r10759)
>>
>> After some debugging, I see that m_clientAdapter (in
>> org.eclipse.buckminster.subclipse.internal.SvnSession) isn`t initialized
>> by username and password from initial svn repo url.
>>
>> Is it a bug?
>> or where am I wrong?
>>
>> Thanks in advance.
>
Re: Problem with SVN auth from headless buckminster [message #514446 is a reply to message #514053] Mon, 15 February 2010 11:44 Go to previous messageGo to next message
Chicherin Andrey is currently offline Chicherin AndreyFriend
Messages: 2
Registered: February 2010
Junior Member
Thank you Thomas.
But this solution is not suitable for me.
I'm trying to make a general build script for several similar projects.
I think that specifying SVN user credentials by using properties when
calling the script (via the command-line) will be more convenient.

On 12.02.2010 13:17, Thomas Hallgren wrote:
> One thing that I forgot to add. You must use Subclipse with SVNKit in
> your IDE since SVNKit is used by the headless environment. SVNKit and
> JavaHL will not store the credentials in the same place.
>
> - thomas
>
> On 02/12/2010 10:42 AM, Thomas Hallgren wrote:
>> Hi Andrey,
>> One way of doing this is to create a template workspace where you have
>> added the repository location with credentials. I.e.
>>
>> 1. Start your IDE on a new workspace.
>> 2. Add the repository location with credentials in the SVN repository
>> view
>> 3. Exit your IDE.
>> 4. Create a zip of the workspace.
>> 5. Use the zip as template workspace (i.e. -T <zip file>) when you
>> import.
>>
>> Buckminster will match the location found in the RMAP against any
>> existing repository locations and thus, make use of the credentials that
>> you have added.
>>
>> HTH,
>> Thomas Hallgren
>>
>>
>> On 02/11/2010 05:34 PM, Chicherin Andrey wrote:
>>> Hi,
>>>
>>> I`m trying to set up the buckminster to work with a svn repository which
>>> requires an authentication.
>>>
>>> At my rmap i`ve tried to use the scheme like this:
>>>
>>> <uri format="svn://user:password@host/..
>>>
>>> but it didn`t work.
>>>
>>> I`m using Subclipse headless adapter
>>> (org.eclipse.buckminster.subclipse.headless 1.0.0.r10759)
>>>
>>> After some debugging, I see that m_clientAdapter (in
>>> org.eclipse.buckminster.subclipse.internal.SvnSession) isn`t initialized
>>> by username and password from initial svn repo url.
>>>
>>> Is it a bug?
>>> or where am I wrong?
>>>
>>> Thanks in advance.
>>
>
Re: Problem with SVN auth from headless buckminster [message #533196 is a reply to message #514053] Wed, 12 May 2010 14:22 Go to previous messageGo to next message
Sam Jones is currently offline Sam JonesFriend
Messages: 8
Registered: May 2010
Junior Member
Thomas,

I am having the same problem as the OP. I tried your solution of pre-populating a workspace with credentials, but it doesn't appear to have had any effect. Are there any other options? Is this a Subclipse bug, or intended behavior?
Re: Problem with SVN auth from headless buckminster [message #533210 is a reply to message #513921] Wed, 12 May 2010 14:47 Go to previous messageGo to next message
Henrik Lindberg is currently offline Henrik LindbergFriend
Messages: 2500
Registered: July 2009
Senior Member
Hi,
Using username and password in the repository URL is one way of defining
the credentials, but there is a much better way that both works and is
more secure.

Switch to using svn+ssh access scheme, and configure ssh access to the
machine with the repository. This way, the public key for the user-id
that is executing the process will be used. No userid or password needs
to be stored in clear text anywhere.

Regards
- henrik


On 2/11/10 5:34 PM, Chicherin Andrey wrote:
> Hi,
>
> I`m trying to set up the buckminster to work with a svn repository which
> requires an authentication.
>
> At my rmap i`ve tried to use the scheme like this:
>
> <uri format="svn://user:password@host/..
>
> but it didn`t work.
>
> I`m using Subclipse headless adapter
> (org.eclipse.buckminster.subclipse.headless 1.0.0.r10759)
>
> After some debugging, I see that m_clientAdapter (in
> org.eclipse.buckminster.subclipse.internal.SvnSession) isn`t initialized
> by username and password from initial svn repo url.
>
> Is it a bug?
> or where am I wrong?
>
> Thanks in advance.
Re: Problem with SVN auth from headless buckminster [message #533233 is a reply to message #533210] Wed, 12 May 2010 16:03 Go to previous messageGo to next message
Sam Jones is currently offline Sam JonesFriend
Messages: 8
Registered: May 2010
Junior Member
For mine, our team is currently just using anonymous/anonymous, so security isn't a huge problem. I will see if I can get SSH access set up any time soon (we're not in charge of the repo), but basic https access would be much simpler. Is it known and accepted that https doesn't work in a headless environment?
Re: Problem with SVN auth from headless buckminster [message #533238 is a reply to message #533233] Wed, 12 May 2010 16:25 Go to previous messageGo to next message
Henrik Lindberg is currently offline Henrik LindbergFriend
Messages: 2500
Registered: July 2009
Senior Member
afaik, it should work (deferring to Thomas here...)

- the advice is simply to use svn+ssh if possible as it is more secure
and does not require advanced property gymnastics trying to hide
user/password in clear text in properties files.

Regards
- henrik

On 5/12/10 6:03 PM, Sam Jones wrote:
> For mine, our team is currently just using anonymous/anonymous, so
> security isn't a huge problem. I will see if I can get SSH access set up
> any time soon (we're not in charge of the repo), but basic https access
> would be much simpler. Is it known and accepted that https doesn't work
> in a headless environment?
Re: Problem with SVN auth from headless buckminster [message #533241 is a reply to message #533238] Wed, 12 May 2010 16:43 Go to previous messageGo to next message
Sam Jones is currently offline Sam JonesFriend
Messages: 8
Registered: May 2010
Junior Member
Ok - good to know I'm not going down a path that doesn't work, at least Smile
Re: Problem with SVN auth from headless buckminster [message #533250 is a reply to message #533238] Wed, 12 May 2010 17:06 Go to previous message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
https works, but you might need to use it from a browser or wget first to accept a certificate exception.

- thomas

On 05/12/2010 06:25 PM, Henrik Lindberg wrote:
> afaik, it should work (deferring to Thomas here...)
>
> - the advice is simply to use svn+ssh if possible as it is more secure
> and does not require advanced property gymnastics trying to hide
> user/password in clear text in properties files.
>
> Regards
> - henrik
>
> On 5/12/10 6:03 PM, Sam Jones wrote:
>> For mine, our team is currently just using anonymous/anonymous, so
>> security isn't a huge problem. I will see if I can get SSH access set up
>> any time soon (we're not in charge of the repo), but basic https access
>> would be much simpler. Is it known and accepted that https doesn't work
>> in a headless environment?
>
Previous Topic:building buckminster from source
Next Topic:failing to create target definition against aggregated site
Goto Forum:
  


Current Time: Thu Nov 27 18:51:47 GMT 2014

Powered by FUDForum. Page generated in 0.02547 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software