Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » UML Profile and UML Version 3.0.0(M2T Workflow ist not able to load models and profile from UML 3.0.0)
UML Profile and UML Version 3.0.0 [message #513478] Wed, 10 February 2010 11:05 Go to next message
Missing name Mising name is currently offline Missing name Mising name
Messages: 12
Registered: February 2010
Junior Member
Hi everybody,

I am using Topcased to create UML Models and then create Java code...

Topcased and the latest Eclipse UML Plugin use the namespace 3.0.0 for uml and if I try to read an UML Model or Profile workflow complains about it. If I change the namespaces to 2.0.0 manually then everything works fine...

I am using the 0.72 version of the M2T components, I see that now 0.8M5 availbile, does anybody knows that version is compatible with Version 3.0.0 of Eclipse UML Plugin...

One additional point, is 0.8M5 available in any Maven Repository, I couldn't find it fornax repository....

Thx for the answers....
Re: UML Profile and UML Version 3.0.0 [message #513497 is a reply to message #513478] Wed, 10 February 2010 12:04 Go to previous messageGo to next message
Richard Wood is currently offline Richard Wood
Messages: 29
Registered: January 2010
Junior Member
Hello

Check this thread. The last post contains the code to register UML with the 2.X.X namespace

http://www.eclipse.org/forums/index.php?t=msg&th=161585& amp;start=0&

Regards
Richard

Re: UML Profile and UML Version 3.0.0 [message #513500 is a reply to message #513478] Wed, 10 February 2010 12:12 Go to previous messageGo to next message
Missing name Mising name is currently offline Missing name Mising name
Messages: 12
Registered: February 2010
Junior Member
If I understand correctly, you mean this...

>Thanks for the config snippet Dieter. I tried to include the UML metamodel before without any effect. It should not be necessary to add it as the UML profile already references the UML metamodel.

>Actually the problem is similar to the one when reading exported Eclipse UML2 models. The UML version 2.X.X is not recognized by MWE.

>There is a simple fix besides changing the namespace references in the models which was mentioned in another thread.

>Can you add the following code to your class RSASetup?

>public void setInit(boolean b) {
> ...
> org.eclipse.emf.ecore.EPackage.Registry.INSTANCE.put(UML212U MLResource.UML_METAMODEL_NS_URI, UMLPackage.eINSTANCE);
> ...
>}



>Regards
>Richard

I guess I am to much of a newby to understand which Java Code I have to include this Smile

[Updated on: Wed, 10 February 2010 12:14]

Report message to a moderator

Re: UML Profile and UML Version 3.0.0 [message #513518 is a reply to message #513500] Wed, 10 February 2010 13:15 Go to previous messageGo to next message
Richard Wood is currently offline Richard Wood
Messages: 29
Registered: January 2010
Junior Member
You need to create a new class which extends from org.eclipse.xtend.typesystem.uml2.Setup
with the contents of that posting.

In your workflow replace the reference to org.eclipse.xtend.typesystem.uml2.Setup with your class.
Re: UML Profile and UML Version 3.0.0 [message #513527 is a reply to message #513518] Wed, 10 February 2010 13:45 Go to previous message
Missing name Mising name is currently offline Missing name Mising name
Messages: 12
Registered: February 2010
Junior Member
Thx...

It works....
Previous Topic:equals-operation on custom datatypes
Next Topic:Problem with XPand2 and UML Profiles
Goto Forum:
  


Current Time: Wed Oct 22 21:59:42 GMT 2014

Powered by FUDForum. Page generated in 0.01743 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software