Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Unable to find plug-in: org.eclipse.equinox.launcher(Delta pack installed, but cannot export a product)
Unable to find plug-in: org.eclipse.equinox.launcher [message #513168] Tue, 09 February 2010 02:47 Go to next message
Luca Ferrari is currently offline Luca Ferrari
Messages: 159
Registered: November 2009
Senior Member
Hi all,
I've installed the delta packge for Eclipse 3.5, and I can see the equinox launcher installed among all plugins, but when I try to build a product (for any target platform) I got the following error message:

Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.



Now if I enter in the eclipse/plugins directory of my installation I can see the following laucnhers:

$ ls plugins/*launcher* -ld
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.carbon.macosx_1.0.200.v20090520-1835
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.cocoa.macosx_1.0.0.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.0.0.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.linux.ppc_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.linux.s390_1.0.100.v20090426-1530
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.linux.s390x_1.0.100.v20090426-1530
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.solaris.sparc_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.gtk.solaris.x86_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.motif.aix.ppc_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.motif.hpux.ia64_32_1.0.100.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.motif.hpux.PA_RISC_1.0.100.v20090306-1900
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.motif.linux.x86_1.0.200.v20090520
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.motif.solaris.sparc_1.0.200.HEAD
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.0.200.v20090519
drwxrwxr-x 3 luca luca 4096 2009-06-12 00:29 plugins/org.eclipse.equinox.launcher.wpf.win32.x86_1.0.200.v20090519



I've also tried editing the active target configruation as explained here http:// aniefer.blogspot.com/2009/06/using-deltapack-in-eclipse-35.h tml either checking or uncheking the current target platform. Even if I can see, in the export dialog, the "Generate for multiple platforms" and I can select the multiple platform each time I got the above error about the launcher that cannot be found. Any idea?
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #513178 is a reply to message #513168] Tue, 09 February 2010 04:25 Go to previous messageGo to next message
Luca Ferrari is currently offline Luca Ferrari
Messages: 159
Registered: November 2009
Senior Member
I've tried to download and install the launcher jar manually, but the same error persists. I'm quite frustrated!
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #515298 is a reply to message #513178] Thu, 18 February 2010 07:11 Go to previous messageGo to next message
Mats-Ola Persson is currently offline Mats-Ola Persson
Messages: 2
Registered: February 2010
Junior Member
I had a similar problem, what version of eclipse are you running? 3.5.1?

If so try http://www.eclipse.org/downloads/download.php?file=/eclipse/ downloads/drops/R-3.5-200906111540/eclipse-3.5-delta-pack.zi p
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #522822 is a reply to message #515298] Tue, 23 March 2010 23:16 Go to previous messageGo to next message
Dennis Merritt is currently offline Dennis Merritt
Messages: 4
Registered: March 2010
Junior Member
I have the same problem, has anyone found a solution yet?
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #540047 is a reply to message #522822] Mon, 14 June 2010 12:55 Go to previous messageGo to next message
Wim Jongman is currently offline Wim Jongman
Messages: 276
Registered: July 2009
Senior Member

Hi,

You have the wrong delta-pack. The delta pack must exactly match the eclipse release.

The best thing to do for product builds and headless builds is to create a separate eclipse target directory. Then find the matching delta-pack and unpack that in that target.

Then go the the preferences and create a new target environment that points to that target.

Delta packs are hard to find on the eclipse download pages. What I do is to go to this link:

http://download.eclipse.org/eclipse/downloads/

and then click on the release of my liking, e.g. 3.5.2 This will bring me to another page where I can find a link to that specific delta-pack. Scroll down or click it in the side menu.

Regards,

Wim Jongman
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #540073 is a reply to message #540047] Mon, 14 June 2010 15:16 Go to previous messageGo to next message
Dennis Merritt is currently offline Dennis Merritt
Messages: 4
Registered: March 2010
Junior Member
Thanks, I'm up and running now. I keep thinking of Alan Kay's comment that software is a misleading term, it should be called brittleware.

FYI, this is for a Prolog plug-in of which the most fun part is the source code debugger that tracks Prolog's bidirectional execution path as it jumps from rule to rule.

Dennis
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #540078 is a reply to message #540073] Mon, 14 June 2010 15:25 Go to previous messageGo to next message
Wim Jongman is currently offline Wim Jongman
Messages: 276
Registered: July 2009
Senior Member

Hi Dennis,

I figured it might be too late. But for all others that stumble upon the same questions. FWIW your question comes out high in google.

Regards,

Wim
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #650078 is a reply to message #513168] Fri, 21 January 2011 11:14 Go to previous messageGo to next message
Alexandra Niculai is currently offline Alexandra Niculai
Messages: 84
Registered: July 2009
Member
I know this is an old post, but since it comes as first in google search, I'll add a bit of information.
If you did all the above but you still get the same error, try restarting Eclipse.
I didn't have the corresponding delta pack when I got the error, then I read this post, replaced the delta pack with the good one and when trying to export the product, same problem. Then I just restarted Eclipse and tried again and it worked.

Greetings
Alexandra.
Re: Unable to find plug-in: org.eclipse.equinox.launcher [message #1264880 is a reply to message #513168] Wed, 05 March 2014 10:21 Go to previous message
Kevin Mills is currently offline Kevin Mills
Messages: 2
Registered: July 2011
Junior Member
Just wanted to add a little more information for anyone else that runs into this problem (as I did this morning using Kepler 4.3.1). In my case:

1. I had the correct delta-pack installed (into the eclipse/features and eclipse/plugins directory of my running platform.
2. Exporting win32,x86 from my x86 development environment worked fine.
3. Exporting win32,x86_64 from my x86_64 development environment worked fine.
4. Exporting x86 from the x86_64, or x86_64 from x86 did not.
5. Exporting any flavor of linux did not work

My root problem turned out to be the active "Target Platform" definition. It was set to the default (Running Platform) which excludes the non-native launcher plugins (even though the delta-pack was installed in the same place).

Just create a new Target Platform (Preferences -> Plug-in Devel -> Target Platform) and add a "Directory" source that points to the 'eclipse' directory of the installation. This will pick up all the non-native plugins.

-Kevin
Previous Topic:Help opening writing log in Application console
Next Topic:Reuse the existing IWorkbenchActionDelegate instance
Goto Forum:
  


Current Time: Fri Aug 22 17:42:52 EDT 2014

Powered by FUDForum. Page generated in 0.02342 seconds