Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » XSLT: no stylesheet instruction?(Problems running XSLT using Eclipse XSL Developer Tools 1.0.2)
XSLT: no stylesheet instruction? [message #513127] Tue, 09 February 2010 00:00 Go to next message
Gilbert Pilz is currently offline Gilbert Pilz
Messages: 2
Registered: February 2010
Junior Member
I'm using:
* Eclipse XSL Developer tools 1.0.2
* Eclipse Ganymede JEE
* "standard" JRE6 (C:\Program Files\Java\...)
* Windows XP

I've set up an XSLT to use the "JRE Default" processor to transform the WS-I Basic Profile 1.2 source XML into its human-readable HTML. The first few lines of the source file (BasicProfile-1.2.xml) look like this:

<?xml version="1.0" encoding="UTF-8"?>
<!-- $Revision: 1.90 $ $Date: 2010/02/08 23:25:53 $ -->
<?xml-stylesheet type="text/xsl" href="ProfileDocToHtml-2.0.xsl"?>

when I run the transform I get this:

15:20:19,984 INFO [main] Main - javax.xml.transform.TransformerFactory=null
15:20:19,984 INFO [main] Main - java.endorsed.dirs=C:\Program Files\Java\jre6\lib\endorsed
15:20:19,984 INFO [main] Main - launchFile: C:\Documents and Settings\gpilz\My Documents\WS-I\.metadata\.plugins\org.eclipse.wst.xsl.jaxp.l aunching\launch\launch.xml
15:20:20,546 FATAL [main] Main - No embedded stylesheet instruction for file: file:/C:/Documents and Settings/gpilz/My Documents/WS-I/profiles/src/BasicProfile-1.2.xml
org.eclipse.wst.xsl.jaxp.debug.invoker.TransformationExcepti on: No embedded stylesheet instruction for file: file:/C:/Documents and Settings/gpilz/My Documents/WS-I/profiles/src/BasicProfile-1.2.xml
at org.eclipse.wst.xsl.jaxp.debug.invoker.internal.JAXPSAXProce ssorInvoker.transform(JAXPSAXProcessorInvoker.java:225)
at org.eclipse.wst.xsl.jaxp.debug.invoker.internal.JAXPSAXProce ssorInvoker.transform(JAXPSAXProcessorInvoker.java:186)
at org.eclipse.wst.xsl.jaxp.debug.invoker.internal.Main.main(Ma in.java:73)
Caused by: org.eclipse.wst.xsl.jaxp.debug.invoker.TransformationExcepti on: No embedded stylesheet instruction for file: file:/C:/Documents and Settings/gpilz/My Documents/WS-I/profiles/src/BasicProfile-1.2.xml
at org.eclipse.wst.xsl.jaxp.debug.invoker.internal.JAXPSAXProce ssorInvoker.transform(JAXPSAXProcessorInvoker.java:214)
... 2 more

The "No embedded stylesheet instruction" message confuses me because there is obviously a <?xml-stylesheet> directive.

FWIW XMLSpy 2008 (which I would dearly love to break away from) handles this transform without any problems.

- gp

Re: XSLT: no stylesheet instruction? [message #514763 is a reply to message #513127] Tue, 16 February 2010 15:07 Go to previous message
David Carver is currently offline David Carver
Messages: 174
Registered: July 2009
Senior Member
Try setting it to use the Xalan processor directly instead of the default JRE implementation. The hacked up version of Xalan that is included with the JRE, is known to have various issues.

Also make sure that you Stylesheet is in the same directory as your XML file as if they aren't it's not going to find it because you are using a relative location instead of an absolute location.

If it still doesn't work, then please open a bug with a sample XML and stylesheet that can be used to reproduce the problem.
Previous Topic:Can't get Tomcat started on Eclipse 3.5
Next Topic:WTP OutOfMemory
Goto Forum:
  


Current Time: Tue Sep 02 21:15:35 GMT 2014

Powered by FUDForum. Page generated in 0.01915 seconds