Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Can't install VE 1.4 on Galileo 3.5
Can't install VE 1.4 on Galileo 3.5 [message #512740] Sun, 07 February 2010 00:03 Go to next message
Bud Curtis is currently offline Bud Curtis
Messages: 40
Registered: July 2009
Member
There are so many conflicts with a fresh install of Eclipse 3.5 Galileo
that I think I have to reconsider using VE. I tried both the online and
offline instructions with the same issues:

Cannot complete the install because of a conflicting dependency.
Software being installed: Java EMF Model
1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
(org.eclipse.jem.feature.group 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
Software currently installed: Eclipse IDE for Java EE Developers
1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
Only one of the following can be installed at once:
Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
2.0.300.v200901272200)
Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
2.0.300.R3_1_maintenance)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
(epp.package.jee 1.2.1.20090918-0703)
To: org.eclipse.epp.package.jee.feature.feature.group
[1.2.1.20090918-0703]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.2.1.20090918-0703
(org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
(org.eclipse.jem.feature.group 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
To: org.eclipse.jem [2.0.300.R3_1_maintenance]
Cannot satisfy dependency:
From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
(org.eclipse.jst.web_core.feature.feature.group
3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
To: org.eclipse.jem [2.0.300.v200901272200]
Cannot satisfy dependency:
From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
(org.eclipse.jst.web_ui.feature.feature.group
3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
To: org.eclipse.jst.web_core.feature.feature.group
[3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]

Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #512794 is a reply to message #512740] Sun, 07 February 2010 18:33 Go to previous messageGo to next message
Rick Strong is currently offline Rick Strong
Messages: 14
Registered: July 2009
Junior Member
Hi,

I wish I had an answer, instead I have the same question with slightly
different errors. I tried to use the update site with the latest Eclipse
(WindowBuilder Pro already installed) and got the following:

> Cannot complete the install because of a conflicting dependency.
> Software being installed: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> Software currently installed: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> Only one of the following can be installed at once:
> Java EMF Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy 2.0.201.v200908101600)
> org.eclipse.jem.proxy 1.2.0.v20060918_M
> Cannot satisfy dependency:
> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> To: org.eclipse.epp.package.jee.feature.feature.group [1.2.1.20090918-0703]
> Cannot satisfy dependency:
> From: Java EE IDE Feature 1.2.1.20090918-0703 (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> To: org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group 0.0.0
> Cannot satisfy dependency:
> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
> Cannot satisfy dependency:
> From: Apache MyFaces Trinidad Tag Support (Optional) 2.2.0.v20090517-20-7w311A1636 (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group 2.2.0.v20090517-20-7w311A1636)
> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: JavaServer Faces Tools - Core 1.2.2.v20090903 (org.eclipse.jst.jsf.core 1.2.2.v20090903)
> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)

Rick

Bud Curtis wrote:
> There are so many conflicts with a fresh install of Eclipse 3.5 Galileo
> that I think I have to reconsider using VE. I tried both the online and
> offline instructions with the same issues:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Java EMF Model
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> Software currently installed: Eclipse IDE for Java EE Developers
> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> Only one of the following can be installed at once:
> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
> 2.0.300.v200901272200)
> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
> 2.0.300.R3_1_maintenance)
> Cannot satisfy dependency:
> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> (epp.package.jee 1.2.1.20090918-0703)
> To: org.eclipse.epp.package.jee.feature.feature.group
> [1.2.1.20090918-0703]
> Cannot satisfy dependency:
> From: Java EE IDE Feature 1.2.1.20090918-0703
> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
> Cannot satisfy dependency:
> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
> Cannot satisfy dependency:
> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
> (org.eclipse.jst.web_core.feature.feature.group
> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
> To: org.eclipse.jem [2.0.300.v200901272200]
> Cannot satisfy dependency:
> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
> (org.eclipse.jst.web_ui.feature.feature.group
> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
> To: org.eclipse.jst.web_core.feature.feature.group
> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>
> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #512823 is a reply to message #512794] Mon, 08 February 2010 05:54 Go to previous messageGo to next message
Bud Curtis is currently offline Bud Curtis
Messages: 40
Registered: July 2009
Member
Does anybody know of a version of Eclipse that the VE will install on?
I'm about ready to give up and go back to NetBeans. This is getting
very aggravating.

Rick Strong wrote:
> Hi,
>
> I wish I had an answer, instead I have the same question with slightly
> different errors. I tried to use the update site with the latest Eclipse
> (WindowBuilder Pro already installed) and got the following:
>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Java EMF Model
>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>> Software currently installed: Eclipse IDE for Java EE Developers
>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>> Only one of the following can be installed at once: Java EMF
>> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>> 2.0.201.v200908101600)
>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>> Cannot satisfy dependency:
>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>> (epp.package.jee 1.2.1.20090918-0703)
>> To: org.eclipse.epp.package.jee.feature.feature.group
>> [1.2.1.20090918-0703]
>> Cannot satisfy dependency:
>> From: Java EE IDE Feature 1.2.1.20090918-0703
>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>> To:
>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>> 0.0.0
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>> Cannot satisfy dependency:
>> From: Apache MyFaces Trinidad Tag Support (Optional)
>> 2.2.0.v20090517-20-7w311A1636
>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>> 2.2.0.v20090517-20-7w311A1636)
>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>> Cannot satisfy dependency:
>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>
> Rick
>
> Bud Curtis wrote:
>> There are so many conflicts with a fresh install of Eclipse 3.5
>> Galileo that I think I have to reconsider using VE. I tried both the
>> online and offline instructions with the same issues:
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Java EMF Model
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> Software currently installed: Eclipse IDE for Java EE Developers
>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>> Only one of the following can be installed at once:
>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>> 2.0.300.v200901272200)
>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>> 2.0.300.R3_1_maintenance)
>> Cannot satisfy dependency:
>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>> (epp.package.jee 1.2.1.20090918-0703)
>> To: org.eclipse.epp.package.jee.feature.feature.group
>> [1.2.1.20090918-0703]
>> Cannot satisfy dependency:
>> From: Java EE IDE Feature 1.2.1.20090918-0703
>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>> Cannot satisfy dependency:
>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>> (org.eclipse.jst.web_core.feature.feature.group
>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>> To: org.eclipse.jem [2.0.300.v200901272200]
>> Cannot satisfy dependency:
>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>> (org.eclipse.jst.web_ui.feature.feature.group
>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>> To: org.eclipse.jst.web_core.feature.feature.group
>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>
>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #513060 is a reply to message #512823] Mon, 08 February 2010 17:02 Go to previous messageGo to next message
Rick Strong is currently offline Rick Strong
Messages: 14
Registered: July 2009
Junior Member
I do have it running on 3.4, I was just trying to see if I could update
Eclipse and take all my extras with me...

Bud Curtis wrote:
> Does anybody know of a version of Eclipse that the VE will install on?
> I'm about ready to give up and go back to NetBeans. This is getting
> very aggravating.
>
> Rick Strong wrote:
>> Hi,
>>
>> I wish I had an answer, instead I have the same question with slightly
>> different errors. I tried to use the update site with the latest
>> Eclipse (WindowBuilder Pro already installed) and got the following:
>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once: Java EMF
>>> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>>> 2.0.201.v200908101600)
>>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To:
>>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>>> 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>>> Cannot satisfy dependency:
>>> From: Apache MyFaces Trinidad Tag Support (Optional)
>>> 2.2.0.v20090517-20-7w311A1636
>>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>>> 2.2.0.v20090517-20-7w311A1636)
>>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>>> Cannot satisfy dependency:
>>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>>
>> Rick
>>
>> Bud Curtis wrote:
>>> There are so many conflicts with a fresh install of Eclipse 3.5
>>> Galileo that I think I have to reconsider using VE. I tried both the
>>> online and offline instructions with the same issues:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once:
>>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>>> 2.0.300.v200901272200)
>>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>>> 2.0.300.R3_1_maintenance)
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>>> Cannot satisfy dependency:
>>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>>> (org.eclipse.jst.web_core.feature.feature.group
>>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>>> To: org.eclipse.jem [2.0.300.v200901272200]
>>> Cannot satisfy dependency:
>>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>>> (org.eclipse.jst.web_ui.feature.feature.group
>>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>>> To: org.eclipse.jst.web_core.feature.feature.group
>>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>>
>>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #513124 is a reply to message #512823] Mon, 08 February 2010 23:50 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
I have no problem to install VE with the option VE SDK.

Regards
yves yang
"Bud Curtis" <bud.curtis@gmail.com> wrote in message
news:hko8u5$5s5$1@build.eclipse.org...
> Does anybody know of a version of Eclipse that the VE will install on? I'm
> about ready to give up and go back to NetBeans. This is getting very
> aggravating.
>
> Rick Strong wrote:
>> Hi,
>>
>> I wish I had an answer, instead I have the same question with slightly
>> different errors. I tried to use the update site with the latest Eclipse
>> (WindowBuilder Pro already installed) and got the following:
>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once: Java EMF Model
>>> Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>>> 2.0.201.v200908101600)
>>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To:
>>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>>> 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>>> Cannot satisfy dependency:
>>> From: Apache MyFaces Trinidad Tag Support (Optional)
>>> 2.2.0.v20090517-20-7w311A1636
>>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>>> 2.2.0.v20090517-20-7w311A1636)
>>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>>> Cannot satisfy dependency:
>>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>>
>> Rick
>>
>> Bud Curtis wrote:
>>> There are so many conflicts with a fresh install of Eclipse 3.5 Galileo
>>> that I think I have to reconsider using VE. I tried both the online and
>>> offline instructions with the same issues:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once:
>>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>>> 2.0.300.v200901272200)
>>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>>> 2.0.300.R3_1_maintenance)
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>>> Cannot satisfy dependency:
>>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>>> (org.eclipse.jst.web_core.feature.feature.group
>>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>>> To: org.eclipse.jem [2.0.300.v200901272200]
>>> Cannot satisfy dependency:
>>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>>> (org.eclipse.jst.web_ui.feature.feature.group
>>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>>> To: org.eclipse.jst.web_core.feature.feature.group
>>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>>
>>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #513267 is a reply to message #512823] Tue, 09 February 2010 10:16 Go to previous messageGo to next message
David Kerber is currently offline David Kerber
Messages: 100
Registered: July 2009
Senior Member
In article <hko8u5$5s5$1@build.eclipse.org>, bud.curtis@gmail.com
says...
>
> Does anybody know of a version of Eclipse that the VE will install on?
> I'm about ready to give up and go back to NetBeans. This is getting
> very aggravating.

I have ve running on Eclipse Galileo, but I had to use a 32-bit jvm to
do it; it wouldn't work with the 64-bit JVM on Win7 x64.

D


>
> Rick Strong wrote:
> > Hi,
> >
> > I wish I had an answer, instead I have the same question with slightly
> > different errors. I tried to use the update site with the latest Eclipse
> > (WindowBuilder Pro already installed) and got the following:
> >
> >> Cannot complete the install because of a conflicting dependency.
> >> Software being installed: Java EMF Model
> >> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
> >> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> >> Software currently installed: Eclipse IDE for Java EE Developers
> >> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> >> Only one of the following can be installed at once: Java EMF
> >> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
> >> 2.0.201.v200908101600)
> >> org.eclipse.jem.proxy 1.2.0.v20060918_M
> >> Cannot satisfy dependency:
> >> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> >> (epp.package.jee 1.2.1.20090918-0703)
> >> To: org.eclipse.epp.package.jee.feature.feature.group
> >> [1.2.1.20090918-0703]
> >> Cannot satisfy dependency:
> >> From: Java EE IDE Feature 1.2.1.20090918-0703
> >> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> >> To:
> >> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
> >> 0.0.0
> >> Cannot satisfy dependency:
> >> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
> >> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> >> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
> >> Cannot satisfy dependency:
> >> From: Apache MyFaces Trinidad Tag Support (Optional)
> >> 2.2.0.v20090517-20-7w311A1636
> >> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
> >> 2.2.0.v20090517-20-7w311A1636)
> >> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
> >> Cannot satisfy dependency:
> >> From: JavaServer Faces Tools - Core 1.2.2.v20090903
> >> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
> >> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
> >
> > Rick
> >
> > Bud Curtis wrote:
> >> There are so many conflicts with a fresh install of Eclipse 3.5
> >> Galileo that I think I have to reconsider using VE. I tried both the
> >> online and offline instructions with the same issues:
> >>
> >> Cannot complete the install because of a conflicting dependency.
> >> Software being installed: Java EMF Model
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> >> (org.eclipse.jem.feature.group
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> >> Software currently installed: Eclipse IDE for Java EE Developers
> >> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> >> Only one of the following can be installed at once:
> >> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
> >> 2.0.300.v200901272200)
> >> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
> >> 2.0.300.R3_1_maintenance)
> >> Cannot satisfy dependency:
> >> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> >> (epp.package.jee 1.2.1.20090918-0703)
> >> To: org.eclipse.epp.package.jee.feature.feature.group
> >> [1.2.1.20090918-0703]
> >> Cannot satisfy dependency:
> >> From: Java EE IDE Feature 1.2.1.20090918-0703
> >> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> >> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
> >> Cannot satisfy dependency:
> >> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> >> (org.eclipse.jem.feature.group
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> >> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
> >> Cannot satisfy dependency:
> >> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
> >> (org.eclipse.jst.web_core.feature.feature.group
> >> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
> >> To: org.eclipse.jem [2.0.300.v200901272200]
> >> Cannot satisfy dependency:
> >> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
> >> (org.eclipse.jst.web_ui.feature.feature.group
> >> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
> >> To: org.eclipse.jst.web_core.feature.feature.group
> >> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
> >>
> >> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #525984 is a reply to message #513267] Thu, 08 April 2010 13:20 Go to previous messageGo to next message
Eric Bresie is currently offline Eric Bresie
Messages: 44
Registered: July 2009
Member
See https://bugs.eclipse.org/bugs/show_bug.cgi?id=301766

I think the short answer is there is an EMF dependency conflict. if you use certain distribution then install VE it supposely installs properly.
Re: Can't install VE 1.4 on Galileo 3.5 [message #527446 is a reply to message #512740] Thu, 15 April 2010 10:07 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Hi @everyone,

Very n00b Java developer here. I was about to upgrade to Eclipse Galileo, but since I plan to use VE I saw on VE's wiki the warning about Bug 301766 that VE won't install on Eclipse IDE for Java Developers.

Actually, it DOES on my system, or at least appears to. I'm currently working on Kubuntu Hardy (a bit old, I know, planning to upgrade that as well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit), unpacked it to a test directory, and then proceed to add VE with the http://download.eclipse.org/tools/ve/updates/1.4/ site.

In the "Available Software" window, after entering the update site, I just selected the "Visual Editor" under the "VE 1.4.0 R200909301124" branch (no source code, no SDK, neither Java EMF Model). It installs with all its dependencies, and appears to work to me: I'm able to create a visual class and add Swing gadgets to it, and changes are reflected in the source code.

I noticed then that on the Bugzilla bug's page the platform is set to "Macintosh Mac OS X", but I see on this thread that there are people with issues on Windows, too (like David). And Yves Yang says he can install it with the SDK option (that I didn't select, btw).

Can someone help to pinpoint the bug more precisely? If VE installs on Galileo for Java Developers under certain scenarios, maybe the Platform field on Bugzilla and the Wiki page have to be updated and the bug is more specific. Am I missing something? Does VE really work on my setup or just appears to? Shall I stick to using Ganymede and wait for this bug to be solved?

Btw, sorry for the n00bish question, what am I missing if I don't install "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It doesn't get installed as a dependency.

Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #527468 is a reply to message #527446] Thu, 15 April 2010 10:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
PSK,

I think the problem is that it doesn't install with the JEE package
because WTP installs a version of EMF and JEM that VE itself declares as
outside of the acceptable range of dependencies. I have to wonder
though whether it really doesn't work with these versions and if not why
that hasn't been addressed....


PSK wrote:
> Hi @everyone,
>
> Very n00b Java developer here. I was about to upgrade to Eclipse
> Galileo, but since I plan to use VE I saw on VE's wiki the warning
> about Bug 301766 that VE won't install on Eclipse IDE for Java
> Developers.
>
> Actually, it DOES on my system, or at least appears to. I'm currently
> working on Kubuntu Hardy (a bit old, I know, planning to upgrade that
> as well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I
> downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit),
> unpacked it to a test directory, and then proceed to add VE with the
> http://download.eclipse.org/tools/ve/updates/1.4/ site.
>
> In the "Available Software" window, after entering the update site, I
> just selected the "Visual Editor" under the "VE 1.4.0 R200909301124"
> branch (no source code, no SDK, neither Java EMF Model). It installs
> with all its dependencies, and appears to work to me: I'm able to
> create a visual class and add Swing gadgets to it, and changes are
> reflected in the source code.
>
> I noticed then that on the Bugzilla bug's page the platform is set to
> "Macintosh Mac OS X", but I see on this thread that there are people
> with issues on Windows, too (like David). And Yves Yang says he can
> install it with the SDK option (that I didn't select, btw).
>
> Can someone help to pinpoint the bug more precisely? If VE installs on
> Galileo for Java Developers under certain scenarios, maybe the
> Platform field on Bugzilla and the Wiki page have to be updated and
> the bug is more specific. Am I missing something? Does VE really work
> on my setup or just appears to? Shall I stick to using Ganymede and
> wait for this bug to be solved?
>
> Btw, sorry for the n00bish question, what am I missing if I don't
> install "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It
> doesn't get installed as a dependency.
>
> Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #527483 is a reply to message #527468] Thu, 15 April 2010 12:27 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Ed,

So I must assume that since I'm using J2SE only then everything's fine? VE's wiki page already says "DO NOT USE "Eclipse IDE for Java EE Developers"" actually. But still it says that VE shouldn't get installed on my setup (and apparently it DOES get installed, as I said). I'm a little confused about what's working and what's not at this point... maybe the wiki should be updated?
Re: Can't install VE 1.4 on Galileo 3.5 [message #527653 is a reply to message #527446] Thu, 15 April 2010 23:13 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
When you install VE 1.4 with JEE, you should not check Java EMF Model since
there is already one in eclipse bundled by WTP project. For example, if you
select VE SDK, it works fine.

Best regards
Yves YANG
"PSK" <peppinielloscamorza@gmail.com> wrote in message
news:hq6oh7$ul8$1@build.eclipse.org...
> Hi @everyone,
>
> Very n00b Java developer here. I was about to upgrade to Eclipse Galileo,
> but since I plan to use VE I saw on VE's wiki the warning about Bug 301766
> that VE won't install on Eclipse IDE for Java Developers.
>
> Actually, it DOES on my system, or at least appears to. I'm currently
> working on Kubuntu Hardy (a bit old, I know, planning to upgrade that as
> well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I
> downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit),
> unpacked it to a test directory, and then proceed to add VE with the
> http://download.eclipse.org/tools/ve/updates/1.4/ site.
>
> In the "Available Software" window, after entering the update site, I just
> selected the "Visual Editor" under the "VE 1.4.0 R200909301124" branch (no
> source code, no SDK, neither Java EMF Model). It installs with all its
> dependencies, and appears to work to me: I'm able to create a visual class
> and add Swing gadgets to it, and changes are reflected in the source code.
>
> I noticed then that on the Bugzilla bug's page the platform is set to
> "Macintosh Mac OS X", but I see on this thread that there are people with
> issues on Windows, too (like David). And Yves Yang says he can install it
> with the SDK option (that I didn't select, btw).
>
> Can someone help to pinpoint the bug more precisely? If VE installs on
> Galileo for Java Developers under certain scenarios, maybe the Platform
> field on Bugzilla and the Wiki page have to be updated and the bug is more
> specific. Am I missing something? Does VE really work on my setup or just
> appears to? Shall I stick to using Ganymede and wait for this bug to be
> solved?
>
> Btw, sorry for the n00bish question, what am I missing if I don't install
> "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It doesn't get
> installed as a dependency.
>
> Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #527876 is a reply to message #527653] Fri, 16 April 2010 18:17 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Quote:
When you install VE 1.4 with JEE, you should not check Java EMF Model since
there is already one in eclipse bundled by WTP project. For example, if you
select VE SDK, it works fine.



Thanks for pointing that out Yves.

I just saw that I can edit the wiki myself with my account (sorry, I'm new here). Just to do things right, let me make a summary of what I'm planning to write and let me know if that's ok:


  1. As Yves just said, VE CAN be installed with JEE, but you mustn't select Java EMF model. The wiki page mentions the Java EMF conflict on JEE, but it doesn't say Java EMF installation is optional (and error-prone) when installing VE. I'd write that currently selecting Java EMF is broken.
  2. If you use "Eclipse IDE for Java Developers" VE installs and works. At least on my Linux setup with Java SE and by selecting just VE as I mentioned. Shall I change or remove the "(not currently working see Bug 301766)" note into, say, something like "works if you select VE only"?


If anyone's able to edit the VE wiki's install page more precisely than I can do, just tell me.
Re: Can't install VE 1.4 on Galileo 3.5 [message #527933 is a reply to message #527876] Sat, 17 April 2010 03:45 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
It is done.

yves
"PSK" <peppinielloscamorza@gmail.com> wrote in message
news:hqa9k3$2mo$1@build.eclipse.org...
> Quote:
>> When you install VE 1.4 with JEE, you should not check Java EMF Model
>> since
>> there is already one in eclipse bundled by WTP project. For example, if
>> you
>> select VE SDK, it works fine.
>
>
> Thanks for pointing that out Yves.
>
> I just saw that I can edit the wiki myself with my account (sorry, I'm new
> here). Just to do things right, let me make a summary of what I'm planning
> to write and let me know if that's ok:
>
>
> As Yves just said, VE CAN be installed with JEE, but you mustn't select
> Java EMF model. The wiki page mentions the Java EMF conflict on JEE, but
> it doesn't say Java EMF installation is optional (and error-prone) when
> installing VE. I'd write that currently selecting Java EMF is broken.
> If you use "Eclipse IDE for Java Developers" VE installs and works. At
> least on my Linux setup with Java SE and by selecting just VE as I
> mentioned. Shall I change or remove the "(not currently working see Bug
> 301766)" note into, say, something like "works if you select VE only"?
>
>
> If anyone's able to edit the VE wiki's install page more precisely than I
> can do, just tell me.
Re: Can't install VE 1.4 on Galileo 3.5 [message #527948 is a reply to message #527933] Sat, 17 April 2010 08:34 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Thank you very much! I'm off to upgrading my production Eclipse installation to Galileo right away!
Re: Can't install VE 1.4 on Galileo 3.5 [message #536691 is a reply to message #512740] Sat, 29 May 2010 23:39 Go to previous messageGo to next message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
Hi all,
VE is a strategic tool for us and our customers, so we are continuosly testing it against every Eclipse release.
Here are our experiences and questions.
We install it with success both with Galileo (3.5) and with Helios (3.6). However we always start from a plain SDK package (no JEE, nor RCP, nor Modeling or others) and install VE 1.4 as the first thing.
This is valid for example with latest Galileo version (3.5.2 aka SR) as well as with previous 3.5.1 (SR1).

However with Helios (3.6) we were able to do this only up to the M4 version (included). From M5 to the latest RC3 we were no more able to install VE 1.4.
We read here
http://www.eclipse.org/projects/project-plan.php?projectid=t ools.ve
of a 1.5 version of VE, but we cannot find any information about where to find it (even at an early stage).
Can someone spread some light into this problem?
Thank you

Vincenzo Caselli
RCP Vision
Re: Can't install VE 1.4 on Galileo 3.5 [message #538218 is a reply to message #512740] Sun, 06 June 2010 16:53 Go to previous messageGo to next message
Vincent  is currently offline Vincent
Messages: 6
Registered: June 2010
Junior Member
Sorry, im new here.. I've been trying to install ve on eclipse 3.5 j2ee, i didn't included emf in installation, but I've always got dependency conflict. I tried installing in eclipse 3.5 for java dev, same thing happened.

i'm using ubuntu lucid 64bit. Is this because i'm running 64bit jvm? is it possible to run 32bit jvm on 64 bit linux? Thanks
Re: Can't install VE 1.4 on Galileo 3.5 [message #538310 is a reply to message #538218] Mon, 07 June 2010 10:04 Go to previous messageGo to next message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
Hi Vincent,
try to intall VE on a plain 3.5.2 SDK ( http://download.eclipse.org/eclipse/downloads/drops/R-3.5.2- 201002111343/index.php)

According to my past trials, both JEE and JAVA packages are not right for VE.
Let us know.

Vincenzo Caselli
RCP Vision
Re: Can't install VE 1.4 on Galileo 3.5 [message #538619 is a reply to message #538310] Tue, 08 June 2010 08:39 Go to previous messageGo to next message
Vincent  is currently offline Vincent
Messages: 6
Registered: June 2010
Junior Member
Hi Vincenzo,

So what is exactly eclipse sdk you are referring?
Is it eclipse with all features? because I noticed the size is larger than regular eclipse java.
I haven't downloaded it yet as my internet is still shaped (australian isps do this when overquota). I will later.
Thanks..
Re: Can't install VE 1.4 on Galileo 3.5 [message #538653 is a reply to message #538619] Tue, 08 June 2010 10:50 Go to previous messageGo to next message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
Vincent,
the SDK bundle is a.k.a. "Eclipse Classic", it is the last bundle on the page
http://www.eclipse.org/downloads/
it includes PDE, sources and documentation.
Regards

Vincenzo Caselli
RCP Vision
Re: Can't install VE 1.4 on Galileo 3.5 [message #538758 is a reply to message #512740] Tue, 08 June 2010 14:59 Go to previous messageGo to next message
Marco is currently offline Marco
Messages: 15
Registered: July 2009
Junior Member
I tried to install ve-sdk on eclipse 3.5rc2 j2ee but without success.
If I try to open following simple class:

import java.awt.GridBagLayout;
import javax.swing.JPanel;

public class TestSwing extends JPanel {

private static final long serialVersionUID = 1L;

public TestSwing() {
super();
initialize();
}

private void initialize() {
this.setSize(300, 200);
this.setLayout(new GridBagLayout());
}
}


I get following error:
org.eclipse.core.runtime.CoreException: Failed to get the root status handler.
at org.eclipse.debug.internal.ui.sourcelookup.Prompter.handleSt atus(Prompter.java:54)
at org.eclipse.debug.core.model.LaunchConfigurationDelegate.sav eBeforeLaunch(LaunchConfigurationDelegate.java:256)
at org.eclipse.debug.core.model.LaunchConfigurationDelegate.pre LaunchCheck(LaunchConfigurationDelegate.java:208)
at org.eclipse.jdt.launching.AbstractJavaLaunchConfigurationDel egate.preLaunchCheck(AbstractJavaLaunchConfigurationDelegate .java:921)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:808)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:703)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:696)
at org.eclipse.jem.internal.proxy.core.ProxyLaunchSupport.start Implementation(ProxyLaunchSupport.java:463)
at org.eclipse.jem.internal.proxy.core.ProxyLaunchSupport.start Implementation(ProxyLaunchSupport.java:330)
at org.eclipse.jem.internal.proxy.core.ProxyLaunchSupport.start Implementation(ProxyLaunchSupport.java:262)
at org.eclipse.ve.internal.java.codegen.editorpart.JavaVisualEd itorVMController$CreateRegistry.run(JavaVisualEditorVMContro ller.java:188)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Any help is very appreciated.
Re: Can't install VE 1.4 on Galileo 3.5 [message #538759 is a reply to message #538758] Tue, 08 June 2010 15:03 Go to previous messageGo to next message
Vincent  is currently offline Vincent
Messages: 6
Registered: June 2010
Junior Member
vincenzo said u should use the eclipse classic one, i havent tried it myself, cus i'm still downloading it. How did you even manage to install the thing?
Re: Can't install VE 1.4 on Galileo 3.5 [message #538768 is a reply to message #512740] Tue, 08 June 2010 15:18 Go to previous messageGo to next message
Marco is currently offline Marco
Messages: 15
Registered: July 2009
Junior Member
i used following eclipse:
eclipse-jee-galileo-SR2-win32.zip

Help->Install New Software
http://download.eclipse.org/tools/ve/updates/1.4/
->Select: Visual Editor SDK

Thats all, nothing more!

Now it's also working for me and I don't get the above error anymore.
Solution:
Restart Eclipse. Embarrassed

[Updated on: Wed, 09 June 2010 13:50]

Report message to a moderator

Re: Can't install VE 1.4 on Galileo 3.5 [message #539041 is a reply to message #538768] Wed, 09 June 2010 12:17 Go to previous messageGo to next message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
More references about VE 1.4 can be found here:

http://www.eclipse.org/vep/

[Updated on: Wed, 09 June 2010 15:46]

Report message to a moderator

Re: Can't install VE 1.4 on Galileo 3.5 [message #539053 is a reply to message #512740] Wed, 09 June 2010 13:49 Go to previous messageGo to next message
Marco is currently offline Marco
Messages: 15
Registered: July 2009
Junior Member
ohh... you are right.
it's an additional plugin. don't use that.

I also used :
http://download.eclipse.org/tools/ve/updates/1.4/
Re: Can't install VE 1.4 on Galileo 3.5 [message #618362 is a reply to message #512740] Sun, 07 February 2010 18:33 Go to previous messageGo to next message
Rick Strong is currently offline Rick Strong
Messages: 14
Registered: July 2009
Junior Member
Hi,

I wish I had an answer, instead I have the same question with slightly
different errors. I tried to use the update site with the latest Eclipse
(WindowBuilder Pro already installed) and got the following:

> Cannot complete the install because of a conflicting dependency.
> Software being installed: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> Software currently installed: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> Only one of the following can be installed at once:
> Java EMF Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy 2.0.201.v200908101600)
> org.eclipse.jem.proxy 1.2.0.v20060918_M
> Cannot satisfy dependency:
> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> To: org.eclipse.epp.package.jee.feature.feature.group [1.2.1.20090918-0703]
> Cannot satisfy dependency:
> From: Java EE IDE Feature 1.2.1.20090918-0703 (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> To: org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group 0.0.0
> Cannot satisfy dependency:
> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
> Cannot satisfy dependency:
> From: Apache MyFaces Trinidad Tag Support (Optional) 2.2.0.v20090517-20-7w311A1636 (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group 2.2.0.v20090517-20-7w311A1636)
> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: JavaServer Faces Tools - Core 1.2.2.v20090903 (org.eclipse.jst.jsf.core 1.2.2.v20090903)
> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)

Rick

Bud Curtis wrote:
> There are so many conflicts with a fresh install of Eclipse 3.5 Galileo
> that I think I have to reconsider using VE. I tried both the online and
> offline instructions with the same issues:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Java EMF Model
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> Software currently installed: Eclipse IDE for Java EE Developers
> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> Only one of the following can be installed at once:
> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
> 2.0.300.v200901272200)
> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
> 2.0.300.R3_1_maintenance)
> Cannot satisfy dependency:
> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> (epp.package.jee 1.2.1.20090918-0703)
> To: org.eclipse.epp.package.jee.feature.feature.group
> [1.2.1.20090918-0703]
> Cannot satisfy dependency:
> From: Java EE IDE Feature 1.2.1.20090918-0703
> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
> Cannot satisfy dependency:
> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
> Cannot satisfy dependency:
> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
> (org.eclipse.jst.web_core.feature.feature.group
> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
> To: org.eclipse.jem [2.0.300.v200901272200]
> Cannot satisfy dependency:
> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
> (org.eclipse.jst.web_ui.feature.feature.group
> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
> To: org.eclipse.jst.web_core.feature.feature.group
> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>
> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618363 is a reply to message #512794] Mon, 08 February 2010 05:54 Go to previous messageGo to next message
Harrison Curtis is currently offline Harrison Curtis
Messages: 6
Registered: August 2010
Junior Member
Does anybody know of a version of Eclipse that the VE will install on?
I'm about ready to give up and go back to NetBeans. This is getting
very aggravating.

Rick Strong wrote:
> Hi,
>
> I wish I had an answer, instead I have the same question with slightly
> different errors. I tried to use the update site with the latest Eclipse
> (WindowBuilder Pro already installed) and got the following:
>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Java EMF Model
>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>> Software currently installed: Eclipse IDE for Java EE Developers
>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>> Only one of the following can be installed at once: Java EMF
>> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>> 2.0.201.v200908101600)
>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>> Cannot satisfy dependency:
>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>> (epp.package.jee 1.2.1.20090918-0703)
>> To: org.eclipse.epp.package.jee.feature.feature.group
>> [1.2.1.20090918-0703]
>> Cannot satisfy dependency:
>> From: Java EE IDE Feature 1.2.1.20090918-0703
>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>> To:
>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>> 0.0.0
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>> Cannot satisfy dependency:
>> From: Apache MyFaces Trinidad Tag Support (Optional)
>> 2.2.0.v20090517-20-7w311A1636
>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>> 2.2.0.v20090517-20-7w311A1636)
>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>> Cannot satisfy dependency:
>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>
> Rick
>
> Bud Curtis wrote:
>> There are so many conflicts with a fresh install of Eclipse 3.5
>> Galileo that I think I have to reconsider using VE. I tried both the
>> online and offline instructions with the same issues:
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Java EMF Model
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> Software currently installed: Eclipse IDE for Java EE Developers
>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>> Only one of the following can be installed at once:
>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>> 2.0.300.v200901272200)
>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>> 2.0.300.R3_1_maintenance)
>> Cannot satisfy dependency:
>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>> (epp.package.jee 1.2.1.20090918-0703)
>> To: org.eclipse.epp.package.jee.feature.feature.group
>> [1.2.1.20090918-0703]
>> Cannot satisfy dependency:
>> From: Java EE IDE Feature 1.2.1.20090918-0703
>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>> Cannot satisfy dependency:
>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>> (org.eclipse.jst.web_core.feature.feature.group
>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>> To: org.eclipse.jem [2.0.300.v200901272200]
>> Cannot satisfy dependency:
>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>> (org.eclipse.jst.web_ui.feature.feature.group
>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>> To: org.eclipse.jst.web_core.feature.feature.group
>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>
>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618364 is a reply to message #512823] Mon, 08 February 2010 17:02 Go to previous messageGo to next message
Rick Strong is currently offline Rick Strong
Messages: 14
Registered: July 2009
Junior Member
I do have it running on 3.4, I was just trying to see if I could update
Eclipse and take all my extras with me...

Bud Curtis wrote:
> Does anybody know of a version of Eclipse that the VE will install on?
> I'm about ready to give up and go back to NetBeans. This is getting
> very aggravating.
>
> Rick Strong wrote:
>> Hi,
>>
>> I wish I had an answer, instead I have the same question with slightly
>> different errors. I tried to use the update site with the latest
>> Eclipse (WindowBuilder Pro already installed) and got the following:
>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once: Java EMF
>>> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>>> 2.0.201.v200908101600)
>>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To:
>>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>>> 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>>> Cannot satisfy dependency:
>>> From: Apache MyFaces Trinidad Tag Support (Optional)
>>> 2.2.0.v20090517-20-7w311A1636
>>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>>> 2.2.0.v20090517-20-7w311A1636)
>>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>>> Cannot satisfy dependency:
>>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>>
>> Rick
>>
>> Bud Curtis wrote:
>>> There are so many conflicts with a fresh install of Eclipse 3.5
>>> Galileo that I think I have to reconsider using VE. I tried both the
>>> online and offline instructions with the same issues:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once:
>>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>>> 2.0.300.v200901272200)
>>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>>> 2.0.300.R3_1_maintenance)
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>>> Cannot satisfy dependency:
>>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>>> (org.eclipse.jst.web_core.feature.feature.group
>>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>>> To: org.eclipse.jem [2.0.300.v200901272200]
>>> Cannot satisfy dependency:
>>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>>> (org.eclipse.jst.web_ui.feature.feature.group
>>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>>> To: org.eclipse.jst.web_core.feature.feature.group
>>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>>
>>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618365 is a reply to message #512823] Mon, 08 February 2010 23:50 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
I have no problem to install VE with the option VE SDK.

Regards
yves yang
"Bud Curtis" <bud.curtis@gmail.com> wrote in message
news:hko8u5$5s5$1@build.eclipse.org...
> Does anybody know of a version of Eclipse that the VE will install on? I'm
> about ready to give up and go back to NetBeans. This is getting very
> aggravating.
>
> Rick Strong wrote:
>> Hi,
>>
>> I wish I had an answer, instead I have the same question with slightly
>> different errors. I tried to use the update site with the latest Eclipse
>> (WindowBuilder Pro already installed) and got the following:
>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
>>> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once: Java EMF Model
>>> Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
>>> 2.0.201.v200908101600)
>>> org.eclipse.jem.proxy 1.2.0.v20060918_M
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To:
>>> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
>>> 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
>>> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
>>> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
>>> Cannot satisfy dependency:
>>> From: Apache MyFaces Trinidad Tag Support (Optional)
>>> 2.2.0.v20090517-20-7w311A1636
>>> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
>>> 2.2.0.v20090517-20-7w311A1636)
>>> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
>>> Cannot satisfy dependency:
>>> From: JavaServer Faces Tools - Core 1.2.2.v20090903
>>> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
>>> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
>>
>> Rick
>>
>> Bud Curtis wrote:
>>> There are so many conflicts with a fresh install of Eclipse 3.5 Galileo
>>> that I think I have to reconsider using VE. I tried both the online and
>>> offline instructions with the same issues:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Java EMF Model
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> Software currently installed: Eclipse IDE for Java EE Developers
>>> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
>>> Only one of the following can be installed at once:
>>> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
>>> 2.0.300.v200901272200)
>>> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
>>> 2.0.300.R3_1_maintenance)
>>> Cannot satisfy dependency:
>>> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
>>> (epp.package.jee 1.2.1.20090918-0703)
>>> To: org.eclipse.epp.package.jee.feature.feature.group
>>> [1.2.1.20090918-0703]
>>> Cannot satisfy dependency:
>>> From: Java EE IDE Feature 1.2.1.20090918-0703
>>> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
>>> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
>>> Cannot satisfy dependency:
>>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>>> (org.eclipse.jem.feature.group
>>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>>> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
>>> Cannot satisfy dependency:
>>> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
>>> (org.eclipse.jst.web_core.feature.feature.group
>>> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
>>> To: org.eclipse.jem [2.0.300.v200901272200]
>>> Cannot satisfy dependency:
>>> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
>>> (org.eclipse.jst.web_ui.feature.feature.group
>>> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
>>> To: org.eclipse.jst.web_core.feature.feature.group
>>> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
>>>
>>> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618366 is a reply to message #512823] Tue, 09 February 2010 15:09 Go to previous messageGo to next message
David Kerber is currently offline David Kerber
Messages: 100
Registered: July 2009
Senior Member
In article <hko8u5$5s5$1@build.eclipse.org>, bud.curtis@gmail.com
says...
>
> Does anybody know of a version of Eclipse that the VE will install on?
> I'm about ready to give up and go back to NetBeans. This is getting
> very aggravating.

I have ve running on Eclipse Galileo, but I had to use a 32-bit jvm to
do it; it wouldn't work with the 64-bit JVM on Win7 x64.

D


>
> Rick Strong wrote:
> > Hi,
> >
> > I wish I had an answer, instead I have the same question with slightly
> > different errors. I tried to use the update site with the latest Eclipse
> > (WindowBuilder Pro already installed) and got the following:
> >
> >> Cannot complete the install because of a conflicting dependency.
> >> Software being installed: Java EMF Model
> >> 1.2.3.v20070130_R----6zXJK-L2U8VZ (org.eclipse.jem.feature.group
> >> 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> >> Software currently installed: Eclipse IDE for Java EE Developers
> >> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> >> Only one of the following can be installed at once: Java EMF
> >> Model Proxy Support 2.0.201.v200908101600 (org.eclipse.jem.proxy
> >> 2.0.201.v200908101600)
> >> org.eclipse.jem.proxy 1.2.0.v20060918_M
> >> Cannot satisfy dependency:
> >> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> >> (epp.package.jee 1.2.1.20090918-0703)
> >> To: org.eclipse.epp.package.jee.feature.feature.group
> >> [1.2.1.20090918-0703]
> >> Cannot satisfy dependency:
> >> From: Java EE IDE Feature 1.2.1.20090918-0703
> >> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> >> To:
> >> org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.featu re.group
> >> 0.0.0
> >> Cannot satisfy dependency:
> >> From: Java EMF Model 1.2.3.v20070130_R----6zXJK-L2U8VZ
> >> (org.eclipse.jem.feature.group 1.2.3.v20070130_R----6zXJK-L2U8VZ)
> >> To: org.eclipse.jem.proxy [1.2.0.v20060918_M]
> >> Cannot satisfy dependency:
> >> From: Apache MyFaces Trinidad Tag Support (Optional)
> >> 2.2.0.v20090517-20-7w311A1636
> >> (org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feat ure.group
> >> 2.2.0.v20090517-20-7w311A1636)
> >> To: org.eclipse.jst.jsf.core [1.1.0,2.0.0)
> >> Cannot satisfy dependency:
> >> From: JavaServer Faces Tools - Core 1.2.2.v20090903
> >> (org.eclipse.jst.jsf.core 1.2.2.v20090903)
> >> To: bundle org.eclipse.jem.proxy [2.0.0,3.0.0)
> >
> > Rick
> >
> > Bud Curtis wrote:
> >> There are so many conflicts with a fresh install of Eclipse 3.5
> >> Galileo that I think I have to reconsider using VE. I tried both the
> >> online and offline instructions with the same issues:
> >>
> >> Cannot complete the install because of a conflicting dependency.
> >> Software being installed: Java EMF Model
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> >> (org.eclipse.jem.feature.group
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> >> Software currently installed: Eclipse IDE for Java EE Developers
> >> 1.2.1.20090918-0703 (epp.package.jee 1.2.1.20090918-0703)
> >> Only one of the following can be installed at once:
> >> Java EMF Model 2.0.300.v200901272200 (org.eclipse.jem
> >> 2.0.300.v200901272200)
> >> Java EMF Model 2.0.300.R3_1_maintenance (org.eclipse.jem
> >> 2.0.300.R3_1_maintenance)
> >> Cannot satisfy dependency:
> >> From: Eclipse IDE for Java EE Developers 1.2.1.20090918-0703
> >> (epp.package.jee 1.2.1.20090918-0703)
> >> To: org.eclipse.epp.package.jee.feature.feature.group
> >> [1.2.1.20090918-0703]
> >> Cannot satisfy dependency:
> >> From: Java EE IDE Feature 1.2.1.20090918-0703
> >> (org.eclipse.epp.package.jee.feature.feature.group 1.2.1.20090918-0703)
> >> To: org.eclipse.jst.web_ui.feature.feature.group 0.0.0
> >> Cannot satisfy dependency:
> >> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> >> (org.eclipse.jem.feature.group
> >> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> >> To: org.eclipse.jem [2.0.300.R3_1_maintenance]
> >> Cannot satisfy dependency:
> >> From: JST Web Core 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m
> >> (org.eclipse.jst.web_core.feature.feature.group
> >> 3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m)
> >> To: org.eclipse.jem [2.0.300.v200901272200]
> >> Cannot satisfy dependency:
> >> From: JST Web UI 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl
> >> (org.eclipse.jst.web_ui.feature.feature.group
> >> 3.1.1.v200908121609-7E77FBfDlwYa_9sdy2q77doi14gl)
> >> To: org.eclipse.jst.web_core.feature.feature.group
> >> [3.1.1.v200908121609-7S7CFyvFIhIehVidwyfk0m]
> >>
> >> Can someone suggest what tactic to take?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618376 is a reply to message #618366] Thu, 08 April 2010 13:20 Go to previous messageGo to next message
Eric Bresie is currently offline Eric Bresie
Messages: 44
Registered: July 2009
Member
See https://bugs.eclipse.org/bugs/show_bug.cgi?id=301766

I think the short answer is there is an EMF dependency conflict. if you use certain distribution then install VE it supposely installs properly.
Re: Can't install VE 1.4 on Galileo 3.5 [message #618378 is a reply to message #512740] Thu, 15 April 2010 10:07 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Hi @everyone,

Very n00b Java developer here. I was about to upgrade to Eclipse Galileo, but since I plan to use VE I saw on VE's wiki the warning about Bug 301766 that VE won't install on Eclipse IDE for Java Developers.

Actually, it DOES on my system, or at least appears to. I'm currently working on Kubuntu Hardy (a bit old, I know, planning to upgrade that as well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit), unpacked it to a test directory, and then proceed to add VE with the http://download.eclipse.org/tools/ve/updates/1.4/ site.

In the "Available Software" window, after entering the update site, I just selected the "Visual Editor" under the "VE 1.4.0 R200909301124" branch (no source code, no SDK, neither Java EMF Model). It installs with all its dependencies, and appears to work to me: I'm able to create a visual class and add Swing gadgets to it, and changes are reflected in the source code.

I noticed then that on the Bugzilla bug's page the platform is set to "Macintosh Mac OS X", but I see on this thread that there are people with issues on Windows, too (like David). And Yves Yang says he can install it with the SDK option (that I didn't select, btw).

Can someone help to pinpoint the bug more precisely? If VE installs on Galileo for Java Developers under certain scenarios, maybe the Platform field on Bugzilla and the Wiki page have to be updated and the bug is more specific. Am I missing something? Does VE really work on my setup or just appears to? Shall I stick to using Ganymede and wait for this bug to be solved?

Btw, sorry for the n00bish question, what am I missing if I don't install "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It doesn't get installed as a dependency.

Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #618379 is a reply to message #527446] Thu, 15 April 2010 10:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26014
Registered: July 2009
Senior Member
PSK,

I think the problem is that it doesn't install with the JEE package
because WTP installs a version of EMF and JEM that VE itself declares as
outside of the acceptable range of dependencies. I have to wonder
though whether it really doesn't work with these versions and if not why
that hasn't been addressed....


PSK wrote:
> Hi @everyone,
>
> Very n00b Java developer here. I was about to upgrade to Eclipse
> Galileo, but since I plan to use VE I saw on VE's wiki the warning
> about Bug 301766 that VE won't install on Eclipse IDE for Java
> Developers.
>
> Actually, it DOES on my system, or at least appears to. I'm currently
> working on Kubuntu Hardy (a bit old, I know, planning to upgrade that
> as well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I
> downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit),
> unpacked it to a test directory, and then proceed to add VE with the
> http://download.eclipse.org/tools/ve/updates/1.4/ site.
>
> In the "Available Software" window, after entering the update site, I
> just selected the "Visual Editor" under the "VE 1.4.0 R200909301124"
> branch (no source code, no SDK, neither Java EMF Model). It installs
> with all its dependencies, and appears to work to me: I'm able to
> create a visual class and add Swing gadgets to it, and changes are
> reflected in the source code.
>
> I noticed then that on the Bugzilla bug's page the platform is set to
> "Macintosh Mac OS X", but I see on this thread that there are people
> with issues on Windows, too (like David). And Yves Yang says he can
> install it with the SDK option (that I didn't select, btw).
>
> Can someone help to pinpoint the bug more precisely? If VE installs on
> Galileo for Java Developers under certain scenarios, maybe the
> Platform field on Bugzilla and the Wiki page have to be updated and
> the bug is more specific. Am I missing something? Does VE really work
> on my setup or just appears to? Shall I stick to using Ganymede and
> wait for this bug to be solved?
>
> Btw, sorry for the n00bish question, what am I missing if I don't
> install "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It
> doesn't get installed as a dependency.
>
> Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #618380 is a reply to message #527468] Thu, 15 April 2010 12:27 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Ed,

So I must assume that since I'm using J2SE only then everything's fine? VE's wiki page already says "DO NOT USE "Eclipse IDE for Java EE Developers"" actually. But still it says that VE shouldn't get installed on my setup (and apparently it DOES get installed, as I said). I'm a little confused about what's working and what's not at this point... maybe the wiki should be updated?
Re: Can't install VE 1.4 on Galileo 3.5 [message #618381 is a reply to message #527446] Thu, 15 April 2010 23:13 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
When you install VE 1.4 with JEE, you should not check Java EMF Model since
there is already one in eclipse bundled by WTP project. For example, if you
select VE SDK, it works fine.

Best regards
Yves YANG
"PSK" <peppinielloscamorza@gmail.com> wrote in message
news:hq6oh7$ul8$1@build.eclipse.org...
> Hi @everyone,
>
> Very n00b Java developer here. I was about to upgrade to Eclipse Galileo,
> but since I plan to use VE I saw on VE's wiki the warning about Bug 301766
> that VE won't install on Eclipse IDE for Java Developers.
>
> Actually, it DOES on my system, or at least appears to. I'm currently
> working on Kubuntu Hardy (a bit old, I know, planning to upgrade that as
> well), with Sun's JRE and JDK 6u17 (the latest on *ubuntu repos). I
> downloaded the SR2 of Eclipse IDE for Java Developers (Linux 32 bit),
> unpacked it to a test directory, and then proceed to add VE with the
> http://download.eclipse.org/tools/ve/updates/1.4/ site.
>
> In the "Available Software" window, after entering the update site, I just
> selected the "Visual Editor" under the "VE 1.4.0 R200909301124" branch (no
> source code, no SDK, neither Java EMF Model). It installs with all its
> dependencies, and appears to work to me: I'm able to create a visual class
> and add Swing gadgets to it, and changes are reflected in the source code.
>
> I noticed then that on the Bugzilla bug's page the platform is set to
> "Macintosh Mac OS X", but I see on this thread that there are people with
> issues on Windows, too (like David). And Yves Yang says he can install it
> with the SDK option (that I didn't select, btw).
>
> Can someone help to pinpoint the bug more precisely? If VE installs on
> Galileo for Java Developers under certain scenarios, maybe the Platform
> field on Bugzilla and the Wiki page have to be updated and the bug is more
> specific. Am I missing something? Does VE really work on my setup or just
> appears to? Shall I stick to using Ganymede and wait for this bug to be
> solved?
>
> Btw, sorry for the n00bish question, what am I missing if I don't install
> "Java EMF model" under the "VE 1.4.0 R200909301124" branch? It doesn't get
> installed as a dependency.
>
> Thank you in advance!
Re: Can't install VE 1.4 on Galileo 3.5 [message #618382 is a reply to message #527653] Fri, 16 April 2010 18:17 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Quote:
> When you install VE 1.4 with JEE, you should not check Java EMF Model since
> there is already one in eclipse bundled by WTP project. For example, if you
> select VE SDK, it works fine.


Thanks for pointing that out Yves.

I just saw that I can edit the wiki myself with my account (sorry, I'm new here). Just to do things right, let me make a summary of what I'm planning to write and let me know if that's ok:


As Yves just said, VE CAN be installed with JEE, but you mustn't select Java EMF model. The wiki page mentions the Java EMF conflict on JEE, but it doesn't say Java EMF installation is optional (and error-prone) when installing VE. I'd write that currently selecting Java EMF is broken.
If you use "Eclipse IDE for Java Developers" VE installs and works. At least on my Linux setup with Java SE and by selecting just VE as I mentioned. Shall I change or remove the "(not currently working see Bug 301766)" note into, say, something like "works if you select VE only"?


If anyone's able to edit the VE wiki's install page more precisely than I can do, just tell me.
Re: Can't install VE 1.4 on Galileo 3.5 [message #618383 is a reply to message #618382] Sat, 17 April 2010 03:45 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
It is done.

yves
"PSK" <peppinielloscamorza@gmail.com> wrote in message
news:hqa9k3$2mo$1@build.eclipse.org...
> Quote:
>> When you install VE 1.4 with JEE, you should not check Java EMF Model
>> since
>> there is already one in eclipse bundled by WTP project. For example, if
>> you
>> select VE SDK, it works fine.
>
>
> Thanks for pointing that out Yves.
>
> I just saw that I can edit the wiki myself with my account (sorry, I'm new
> here). Just to do things right, let me make a summary of what I'm planning
> to write and let me know if that's ok:
>
>
> As Yves just said, VE CAN be installed with JEE, but you mustn't select
> Java EMF model. The wiki page mentions the Java EMF conflict on JEE, but
> it doesn't say Java EMF installation is optional (and error-prone) when
> installing VE. I'd write that currently selecting Java EMF is broken.
> If you use "Eclipse IDE for Java Developers" VE installs and works. At
> least on my Linux setup with Java SE and by selecting just VE as I
> mentioned. Shall I change or remove the "(not currently working see Bug
> 301766)" note into, say, something like "works if you select VE only"?
>
>
> If anyone's able to edit the VE wiki's install page more precisely than I
> can do, just tell me.
Re: Can't install VE 1.4 on Galileo 3.5 [message #618384 is a reply to message #527933] Sat, 17 April 2010 08:34 Go to previous messageGo to next message
PSK  is currently offline PSK
Messages: 8
Registered: April 2010
Junior Member
Thank you very much! I'm off to upgrading my production Eclipse installation to Galileo right away!
Re: Can't install VE 1.4 on Galileo 3.5 [message #618388 is a reply to message #512740] Sat, 29 May 2010 23:40 Go to previous messageGo to next message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
Hi all,
VE is a strategic tool for us and our customers, so we are continuosly testing it against every Eclipse release.
Here are our experiences and questions.
We install it with success both with Galileo (3.5) and with Helios (3.6). However we always start from a plain SDK package (no JEE, nor RCP, nor Modeling or others) and install VE 1.4 as the first thing.
This is valid for example with latest Galileo version (3.5.2 aka SR) as well as with previous 3.5.1 (SR1).

However with Helios (3.6) we were able to do this only up to the M4 version (included). From M5 to the latest RC3 we were no more able to install VE 1.4.
We read here
http://www.eclipse.org/projects/project-plan.php?projectid=t ools.ve
of a 1.5 version of VE, but we cannot find any information about where to find it (even at an early stage).
Can someone spread some light into this problem?
Thank you

Vincenzo Caselli
RCP Vision
Re: Can't install VE 1.4 on Galileo 3.5 [message #618391 is a reply to message #512740] Sun, 06 June 2010 16:53 Go to previous messageGo to next message
Vincent  is currently offline Vincent
Messages: 6
Registered: June 2010
Junior Member
Sorry, im new here.. I've been trying to install ve on eclipse 3.5 j2ee, i didn't included emf in installation, but I've always got dependency conflict. I tried installing in eclipse 3.5 for java dev, same thing happened.

i'm using ubuntu lucid 64bit. Is this because i'm running 64bit jvm? is it possible to run 32bit jvm on 64 bit linux? Thanks
Re: Can't install VE 1.4 on Galileo 3.5 [message #618392 is a reply to message #618391] Mon, 07 June 2010 10:04 Go to previous messageGo to previous message
Vincenzo Caselli is currently offline Vincenzo Caselli
Messages: 51
Registered: July 2009
Member
Hi Vincent,
try to intall VE on a plain 3.5.2 SDK ( http://download.eclipse.org/eclipse/downloads/drops/R-3.5.2- 201002111343/index.php)

According to my past trials, both JEE and JAVA packages are not right for VE.
Let us know.

Vincenzo Caselli
RCP Vision
Previous Topic:Re: Can't install VE 1.4 on Galileo 3.5
Next Topic:Visual Editor Project & Mig Layout
Goto Forum:
  


Current Time: Wed Sep 03 00:05:16 GMT 2014

Powered by FUDForum. Page generated in 0.03846 seconds