Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF3D » 2Dfied editors do not work with ati
2Dfied editors do not work with ati [message #512488] Fri, 05 February 2010 09:55 Go to next message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi,

I always had problems with 3Dfied editors(like the uml examples). The projected figures were not displayed properly: All labels were stretched, looking too big. Furthermore dropping another diagram (activity diagram e.g.) in the Multieditor was not possible. Today I've made an update of the gef3d sources (previous update was like 3 weeks ago). Unfortunately, now the uml-example editors are not working at all. The editor opens, but the 3d-area is just white (the palette is displayed properly). Same for the multieditor. Using my custom 3D-Graph-Editor (not 3dfied), all vertieces are shown, but their labels are not visible. Drag and drop in the multieditor is however not working.

I think that has something to do with the drawing of 2D-objects in a 3D scene. Here is what the console outputs, while opening a uml class diagram in the 3d editor:

05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl <init>
INFO: Graphics3DLwjgl constructor called
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .Handles3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.gef3d.examples.uml2.clazz.edit.parts.PackageEdit Part3D
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .FeedbackHelper3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.uml2.diagram.clazz.edit.parts.Package4EditPart
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .Handles3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.uml2.diagram.clazz.edit.parts.Package4EditPart
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .Handles3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.uml2.diagram.clazz.edit.parts.PackageName2EditPa rt
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .Handles3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.uml2.diagram.clazz.edit.parts.PackageStereo2Edit Part
05.02.2010 09:58:51 org.eclipse.gef3d.gmf.runtime.diagram.ui.services.editpolicy .Handles3DEditPolicyProvider3D createEditPolicies
FEIN: modifying edit policies of org.eclipse.uml2.diagram.clazz.edit.parts.PackageImportsEdit Part
05.02.2010 09:58:51 org.eclipse.gef3d.editpolicies.Handles3DEditPolicy decorateChild
FEIN: Decorated child org.eclipse.uml2.diagram.clazz.edit.parts.Package4EditPart with :Package4EditPart( org.eclipse.gmf.runtime.notation.impl.ShapeImpl@1e5b29 (visible: true, type: 2014, mutable: false) (fontColor: 0, fontName: Segoe UI, fontHeight: 9, bold: false, italic: false, underline: false, strikeThrough: false, description: , fillColor: 16777215, transparency: -1, gradient: null, lineColor: 11579568, lineWidth: -1) ).ResizableEditPolicy3D
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.DisplayListManager createDisplayList
FEIN: creating display list with key 'coordinate_axes'
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.DisplayListManager createDisplayList
FEIN: display list with key 'coordinate_axes' created under id 1
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl begin2DRendering
INFO: activating 2D graphics
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl deactivateGraphics2D
INFO: deactivating 2D graphics
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl begin2DRendering
INFO: activating 2D graphics
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl deactivateGraphics2D
INFO: deactivating 2D graphics
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl begin2DRendering
INFO: activating 2D graphics
05.02.2010 09:58:51 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl deactivateGraphics2D
INFO: deactivating 2D graphics


I' ve observed this behavior on the following configurations:

Windows Vista; ATI Mobility Radeon X1400,
Windows 7, ATI Radeon HD 2400 Pro,
both with catalyst 10.1 drivers, FBO supported

So, is this a known issue, or maybe an ATI-Related problem?

Best regards,

Kamil

Re: 2Dfied editors do not work with ati [message #512549 is a reply to message #512488] Fri, 05 February 2010 13:06 Go to previous messageGo to next message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
Kamil,

the render mechanisms of GEF3D were dramatically changed in the last
weeks. Kristian has implemented a whole new technique for rendering 2D
content (and 2D fonts as well). You may have a look at the GEF3D blog.
Draw3D now heavily uses FBO, and almost no textures are used anymore.

These hardware/OpenGL driver issues are a real pain, especially since
we (Kristian and I) both have the same hardware (MacBook Pro). There is
a page with a list of tested graphics cards
( http://www.fernuni-hagen.de/se/personen/pilgrim/gef3d/requir ements.html
), I have to move that page to the GEF3D wiki one day. There are some
ATI cards listed, but this list is rather old and I do not know if they
are still working with the latest version.

Your console log doesn't show any errors or exceptions... weird. Since
"only" the 2D content isn't working, I assume it has something todo
with FBOs. It seems as if the ATI driver is a little bit problematic.
Hmm... Kristian, do you have any ideas?

Cheers

Jens
Re: 2Dfied editors do not work with ati [message #512565 is a reply to message #512549] Fri, 05 February 2010 14:06 Go to previous messageGo to next message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
I've added a new wiki page with a list of graphics card, feel free to
update this page (also if your system is working):

http://wiki.eclipse.org/GEF3D_List_of_Graphics_Card

Cheers,

Jens
Re: 2Dfied editors do not work with ati [message #512783 is a reply to message #512488] Sun, 07 February 2010 15:32 Go to previous messageGo to next message
Kristian Duske is currently offline Kristian DuskeFriend
Messages: 64
Registered: July 2009
Member
Hi Kamil,

I'd like to try and nail down that problem for you. It may or may not
be related to the latest changes in the 2D renderer. Both of your video
cards should support all features necessary to run GEF3D, but maybe
there is some difference in the way they support the spec. I am using
an NVidia card, but have access to a machine with an ATI card. I'll try
the standard UML examples (which is what you are using?) on that
machine and report the results here.

Best regards
Kristian
Re: 2Dfied editors do not work with ati [message #512788 is a reply to message #512783] Sun, 07 February 2010 17:46 Go to previous messageGo to next message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Kristian,

thank you very much. I have used the UML class and activity diagram editor, creating simple diagrams and then opening them with the corresponding 3D-Editor.

Best regards

Kamil

Re: 2Dfied editors do not work with ati [message #513333 is a reply to message #512488] Tue, 09 February 2010 18:55 Go to previous messageGo to next message
Kristian Duske is currently offline Kristian DuskeFriend
Messages: 64
Registered: July 2009
Member
Hi again,

I see multiple problems in your report:

> I always had problems with 3Dfied editors(like the uml examples). The
> projected figures were not displayed properly: All labels were
> stretched, looking too big.

1. This is odd, but I guess we don't need to adress this further at
this time because now it doesn't work at all for you anymore. So first
things first:

> Furthermore dropping another diagram (activity diagram e.g.) in the
> Multieditor was not possible. Today I've made an update of the gef3d
> sources (previous update was like 3 weeks ago). Unfortunately, now the
> uml-example editors are not working at all. The editor opens, but the
> 3d-area is just white (the palette is displayed properly). Same for the
> multieditor.

2. I have seen this behavior before. Could you please try and move the
camera around (by clicking and dragging while the camera tool is
active) and tell me whether you see flickering (sometimes you see the
diagram, sometimes everything is white).

> Using my custom 3D-Graph-Editor (not 3dfied), all vertieces are shown,
> but their labels are not visible.

May be related to 2., so let's see if fixing that fixes this as well.

> Drag and drop in the multieditor is however not working.

This seems to be an entirely different problem and may be related to
your setup. The multi editor uses the plugin registry to discover which
editors are suitable for a certain diagram type. For this it matches
the file extension against all registered editor extensions (see
org.eclipse.gef3d.ext.multieditor.AbstractMultiEditor#findNe stableEditorClasses(IEditorInput).
If a registered editor matches the file extension and implements the
INestableEditor interface, it is added to the multi editor. Maybe for
some reason this mechanism is broken on your runtime instance, so if
you want to debug, this would be a point to start. It would be really
cool if you could check whether any matching editors are found in this
method and post your results here.

Best regards
Kristian
Re: 2Dfied editors do not work with ati [message #513897 is a reply to message #513333] Thu, 11 February 2010 15:58 Go to previous messageGo to next message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Kristian,

moving the camera around in the uml examples does nothing. The editor area remains white; the framerate goes from 30fps to 20fps.
Moving the camera around in my 3DEditor using 'ALT' to rotate the view causes the behavior you mentioned. The graph is flickering and after a while it disappears completely: Everything is gray.

Regarding the drag&drop problem: org.eclipse.gef3d.ext.multieditor.AbstractMultiEditor#findNe stableEditorClasses(IEditorInput). returns my 3DEditor it is however only called in AbstractMultiEditor.createNestedEditor. The method AbstractMultiEditor.acceptsInput is never called, neither in the gef3d examples, nor in my 3D editor.

Best regards
Kamil
Re: 2Dfied editors do not work with ati [message #548447 is a reply to message #512488] Wed, 21 July 2010 21:18 Go to previous messageGo to next message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi,

i still have have the drag/drop and flickering problems... Maybe a newer version of the lwjgl renderer would help.

The LWJGL 2.3 release fixes some issues with ATI 10.x drivers (See http://www.lwjgl.org/index.php).

However, the update site (http://lwjgl.org/update) offers only version 2.2.1. and a manual installation is not supported...

So when does the update site is going to be updated Smile or should i install the new version of lwjgl manually (how?).

cheers
Kamil
Re: 2Dfied editors do not work with ati [message #548519 is a reply to message #548447] Thu, 22 July 2010 08:53 Go to previous messageGo to next message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
Kamil,

On 21.07.10 23:18, fabisiew@in.tum.de wrote:
> The LWJGL 2.3 release fixes some issues with ATI 10.x drivers (See
> http://www.lwjgl.org/index.php).
> However, the update site (http://lwjgl.org/update) offers only version
> 2.2.1. and a manual installation is not supported...

The LWJGL update site is maintained by the LWJGL guys, I only wrote the
initial plugin code and contributed it, but I have no access to the code
at LWJGL.org. I asked Brian Matzon (one of the LWJGL developers) whether
he could update the plugin to 2.5 (the latest release) as well, see
http://lwjgl.org/forum/index.php/topic,3398.0.html

> So when does the update site is going to be updated :) or should i
> install the new version of lwjgl manually (how?).

It should be possible to simply exchange the JAR and library files in
the LWJGL plugin. As a hack (for testing purposes) you can try to
replace the following files with newer versions (assuming the overall
structure of LWJGL hasn't been changed):

org.lwjgl_2.2.1/jinput.jar
org.lwjgl_2.2.1/lwjgl.jar

Depending on your OS:
Linux:
org.lwjgl_2.2.1/native/linux/*
or Mac OS X
org.lwjgl_2.2.1/native/macosx/*
or Windows, 32 bit
org.lwjgl_2.2.1/native/win32/*
or Windows, 64 bit
org.lwjgl_2.2.1/native/windows/*
etc.

Maybe you could check whether there are different files or if only the
files itself were updated. You will find all these files in the orignal
LWJGL distribution, actually the plugin does only enclose these files
into a bundle. But again: THIS IS ONLY A HACK!

Cheers,

Jens
Re: 2Dfied editors do not work with ati [message #548756 is a reply to message #548519] Thu, 22 July 2010 21:21 Go to previous messageGo to next message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Jens,

Thank you very much for your reply.
It seems that the overall structure of lwjgl hasn't changed. I' ve copied the .jar + dll files in the plugin folder with the following result: The LWJGL-Test View is showing up correctly, but my 3d editor throws an exception:

org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
at org.lwjgl.opengl.Util.checkGLError(Util.java:54)
at org.lwjgl.opengl.GL11.glEnable(GL11.java:1032)
at org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl.glEnable (Graphics3DLwjgl.java:919)
at org.eclipse.draw3d.Draw3DCanvas.setDefaultRenderer(Draw3DCan vas.java:117)
at org.eclipse.draw3d.Draw3DCanvas.<init>(Draw3DCanvas.java:86)
at org.eclipse.draw3d.Draw3DCanvas.createCanvas(Draw3DCanvas.ja va:61)
at org.eclipse.gef3d.ui.parts.GraphicalViewer3DHelper.createCon trol3D(GraphicalViewer3DHelper.java:253)
at org.eclipse.gef3d.ui.parts.GraphicalViewer3DImpl.createContr ol3D(GraphicalViewer3DImpl.java:78)
at org.eclipse.gef3d.ui.parts.GraphicalEditor3DWithPalette.crea teGraphicalViewer(GraphicalEditor3DWithPalette.java:62)
at org.eclipse.gef.ui.parts.GraphicalEditorWithPalette.createPa rtControl(GraphicalEditorWithPalette.java:62)


Here is what the Log says:

08.07.2010 23:03:13 org.eclipse.draw3d.graphics3d.Graphics3DRegistry updateDescriptors
INFO: Extension found: org.eclipse.core.internal.registry.ExtensionHandle@500f, Contributor: org.eclipse.draw3d.lwjgl
08.07.2010 23:03:14 org.eclipse.draw3d.graphics3d.Graphics3DRegistry updateDescriptors
INFO: Extension found: org.eclipse.core.internal.registry.ExtensionHandle@501a, Contributor: org.eclipse.draw3d.x3d
08.07.2010 23:03:15 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl <init>
INFO: Graphics3DLwjgl constructor called
08.07.2010 23:03:17 org.eclipse.draw3d.DeferredUpdateManager3D repairDamage
WARNUNG: repairDamage called, but canvas is null. Hint: call LightweightSystem.setControl(..)


Hmmm, don't know if its an gef3d or graphic card driver issue....but I will not give up Wink

Any Idea is welcome Smile


PS: I' m running my Eclipse-Application under VM-WarePlayer (Windows7 32-Bit)
Re: 2Dfied editors do not work with ati [message #548898 is a reply to message #548756] Fri, 23 July 2010 12:12 Go to previous message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
Hi Kamil,

On 22.07.10 23:21, fabisiew@in.tum.de wrote:
> It seems that the overall structure of lwjgl hasn't changed. I' ve
> copied the .jar + dll files in the plugin folder with the following
> result: The LWJGL-Test View is showing up correctly, but my 3d editor
> throws an exception:
>
> org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
> at org.lwjgl.opengl.Util.checkGLError(Util.java:54)
> at org.lwjgl.opengl.GL11.glEnable(GL11.java:1032)
> at org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl.glEnable (Graphics3DLwjgl.java:919)
> at org.eclipse.draw3d.Draw3DCanvas.setDefaultRenderer(Draw3DCan vas.java:117)
....

It's hard to tell, as I don't dare to install LWJGL 2.5 myself at the
moment ;-) However, I strongly believe it's a GEF3D bug. This is an
example showing the downsides of hacks :-( GEF3D, i.e. Draw3D, uses an
abstraction layer on top of the actual OpenGL library. However, this
layer is rather thin and currently it is only used for decoupling the
LWJGL package from Draw3D. That is, Graphics3DDraw (our abstraction
layer) defines the very same constants and methods as LWJGL/OpenGL does.
We have plans to rewrite this abstraction layer, but we haven't had time
so far, besides we are kind of waiting for JOGL to be IP approved in
order to consider the JOGL API then as well). In Draw3DCanvas.java:117,
glEnable(Graphics3DDraw.GL_MULTISAMPLE) is called. GL_MULTISAMPLE is a
constant defined in Graphics3DDraw, and at the time writing that class,

Graphics3DDraw.Graphics3DDraw==org.lwjgl.opengl.GL13.GL_MULT ISAMPLE

was true. I assume this probably has changed in LWJGL 2.5, did it?
Could you check that?

Instead of using the same value for the constants, we should add
something like enableMultisample(boolean)... I'll see what we can do
about that...


> Hmmm, don't know if its an gef3d or graphic card driver issue....but I
> will not give up ;)

Probably it is not a driver issue.

> PS: I' m running my Eclipse-Application under VM-WarePlayer (Windows7
> 32-Bit)

Yes, well, this doesn't make things easier ;-) Anyway, the error seems
to be more a GEF3D problem...

Cheers,

Jens
Re: 2Dfied editors do not work with ati [message #563932 is a reply to message #512549] Fri, 05 February 2010 14:06 Go to previous message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
I've added a new wiki page with a list of graphics card, feel free to
update this page (also if your system is working):

http://wiki.eclipse.org/GEF3D_List_of_Graphics_Card

Cheers,

Jens
Re: 2Dfied editors do not work with ati [message #563976 is a reply to message #512783] Sun, 07 February 2010 17:46 Go to previous message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Kristian,

thank you very much. I have used the UML class and activity diagram editor, creating simple diagrams and then opening them with the corresponding 3D-Editor.

Best regards

Kamil
Re: 2Dfied editors do not work with ati [message #564012 is a reply to message #513333] Thu, 11 February 2010 15:58 Go to previous message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Kristian,

moving the camera around in the uml examples does nothing. The editor area remains white; the framerate goes from 30fps to 20fps.
Moving the camera around in my 3DEditor using 'ALT' to rotate the view causes the behavior you mentioned. The graph is flickering and after a while it disappears completely: Everything is gray.

Regarding the drag&drop problem: org.eclipse.gef3d.ext.multieditor.AbstractMultiEditor#findNe stableEditorClasses(IEditorInput). returns my 3DEditor it is however only called in AbstractMultiEditor.createNestedEditor. The method AbstractMultiEditor.acceptsInput is never called, neither in the gef3d examples, nor in my 3D editor.

Best regards
Kamil
Re: 2Dfied editors do not work with ati [message #564078 is a reply to message #548519] Thu, 22 July 2010 21:21 Go to previous message
fabisiew is currently offline fabisiewFriend
Messages: 19
Registered: July 2009
Junior Member
Hi Jens,

Thank you very much for your reply.
It seems that the overall structure of lwjgl hasn't changed. I' ve copied the .jar + dll files in the plugin folder with the following result: The LWJGL-Test View is showing up correctly, but my 3d editor throws an exception:

org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
at org.lwjgl.opengl.Util.checkGLError(Util.java:54)
at org.lwjgl.opengl.GL11.glEnable(GL11.java:1032)
at org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl.glEnable (Graphics3DLwjgl.java:919)
at org.eclipse.draw3d.Draw3DCanvas.setDefaultRenderer(Draw3DCan vas.java:117)
at org.eclipse.draw3d.Draw3DCanvas.<init>(Draw3DCanvas.java:86)
at org.eclipse.draw3d.Draw3DCanvas.createCanvas(Draw3DCanvas.ja va:61)
at org.eclipse.gef3d.ui.parts.GraphicalViewer3DHelper.createCon trol3D(GraphicalViewer3DHelper.java:253)
at org.eclipse.gef3d.ui.parts.GraphicalViewer3DImpl.createContr ol3D(GraphicalViewer3DImpl.java:78)
at org.eclipse.gef3d.ui.parts.GraphicalEditor3DWithPalette.crea teGraphicalViewer(GraphicalEditor3DWithPalette.java:62)
at org.eclipse.gef.ui.parts.GraphicalEditorWithPalette.createPa rtControl(GraphicalEditorWithPalette.java:62)


Here is what the Log says:

08.07.2010 23:03:13 org.eclipse.draw3d.graphics3d.Graphics3DRegistry updateDescriptors
INFO: Extension found: mailto:org.eclipse.core.internal.registry.ExtensionHandle@500f, Contributor: org.eclipse.draw3d.lwjgl
08.07.2010 23:03:14 org.eclipse.draw3d.graphics3d.Graphics3DRegistry updateDescriptors
INFO: Extension found: mailto:org.eclipse.core.internal.registry.ExtensionHandle@501a, Contributor: org.eclipse.draw3d.x3d
08.07.2010 23:03:15 org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl <init>
INFO: Graphics3DLwjgl constructor called
08.07.2010 23:03:17 org.eclipse.draw3d.DeferredUpdateManager3D repairDamage
WARNUNG: repairDamage called, but canvas is null. Hint: call LightweightSystem.setControl(..)


Hmmm, don't know if its an gef3d or graphic card driver issue....but I will not give up ;)

Any Idea is welcome :)


PS: I' m running my Eclipse-Application under VM-WarePlayer (Windows7 32-Bit)
Re: 2Dfied editors do not work with ati [message #564100 is a reply to message #564078] Fri, 23 July 2010 12:12 Go to previous message
Jens von Pilgrim is currently offline Jens von PilgrimFriend
Messages: 295
Registered: July 2009
Senior Member
Hi Kamil,

On 22.07.10 23:21, fabisiew@in.tum.de wrote:
> It seems that the overall structure of lwjgl hasn't changed. I' ve
> copied the .jar + dll files in the plugin folder with the following
> result: The LWJGL-Test View is showing up correctly, but my 3d editor
> throws an exception:
>
> org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
> at org.lwjgl.opengl.Util.checkGLError(Util.java:54)
> at org.lwjgl.opengl.GL11.glEnable(GL11.java:1032)
> at org.eclipse.draw3d.graphics3d.lwjgl.Graphics3DLwjgl.glEnable (Graphics3DLwjgl.java:919)
> at org.eclipse.draw3d.Draw3DCanvas.setDefaultRenderer(Draw3DCan vas.java:117)
....

It's hard to tell, as I don't dare to install LWJGL 2.5 myself at the
moment ;-) However, I strongly believe it's a GEF3D bug. This is an
example showing the downsides of hacks :-( GEF3D, i.e. Draw3D, uses an
abstraction layer on top of the actual OpenGL library. However, this
layer is rather thin and currently it is only used for decoupling the
LWJGL package from Draw3D. That is, Graphics3DDraw (our abstraction
layer) defines the very same constants and methods as LWJGL/OpenGL does.
We have plans to rewrite this abstraction layer, but we haven't had time
so far, besides we are kind of waiting for JOGL to be IP approved in
order to consider the JOGL API then as well). In Draw3DCanvas.java:117,
glEnable(Graphics3DDraw.GL_MULTISAMPLE) is called. GL_MULTISAMPLE is a
constant defined in Graphics3DDraw, and at the time writing that class,

Graphics3DDraw.Graphics3DDraw==org.lwjgl.opengl.GL13.GL_MULT ISAMPLE

was true. I assume this probably has changed in LWJGL 2.5, did it?
Could you check that?

Instead of using the same value for the constants, we should add
something like enableMultisample(boolean)... I'll see what we can do
about that...


> Hmmm, don't know if its an gef3d or graphic card driver issue....but I
> will not give up ;)

Probably it is not a driver issue.

> PS: I' m running my Eclipse-Application under VM-WarePlayer (Windows7
> 32-Bit)

Yes, well, this doesn't make things easier ;-) Anyway, the error seems
to be more a GEF3D problem...

Cheers,

Jens
Previous Topic:2Dfied editors do not work with ati
Next Topic:EXCEPTION_ACCESS_VIOLATION is thrown when i opened 3d editor
Goto Forum:
  


Current Time: Sat Dec 20 15:07:12 GMT 2014

Powered by FUDForum. Page generated in 0.02372 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software