Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP + jws multiplatform(running RCP app with jws on multiple platforms)
RCP + jws multiplatform [message #511632] Tue, 02 February 2010 05:55 Go to next message
No real name is currently offline No real name
Messages: 3
Registered: December 2009
Junior Member
Hi,

I am trying to run a RCP app on multiple platforms, but I can't get it working on linux 64 or 32 and on win64. It's working on win32. I'm running eclipse 3.5.1 with deltapack 3.5.1 on linux 64 (ubuntu). I've followed this tutorial to get the app to launch with jws and as I said it only works when I export it to win32. On the other platforms I get an error message something like this:

Java Web Start splash screen process exiting .....
Bad installation. Error invoking Java VM (execv) 
/<javadir>/java/jdk1.6.0_14/jre/bin/java: No such file or directory


I've tried to debug the starting app and It seems that the method

private Class findLocalClassImpl(String classname, ClassLoadingStatsHook[] hooks) throws ClassNotFoundException {
		// must call findLoadedClass here even if it was called earlier,
		// the findLoadedClass and defineClass calls must be atomic
		Class result = classloader.publicFindLoaded(classname);
		if (result != null)
			return result;
		for (int i = 0; i < entries.length; i++) {
			if (entries[i] != null) {
				result = findClassImpl(classname, entries[i], hooks);
				if (result != null)
					return result;
			}
		}
		// look in fragments.
		for (int i = 0; i < fragments.length; i++) {
			ClasspathEntry[] fragEntries = fragments[i].getEntries();
			for (int j = 0; j < fragEntries.length; j++) {
				result = findClassImpl(classname, fragEntries[j], hooks);
				if (result != null)
					return result;
			}
		}
		throw new ClassNotFoundException(classname);
	}


in class org.eclipse.osgi.baseadaptor.loader.ClasspathManager throws CNFE-s. It seems it can't find classes in packages org.eclipse.core.(internal).runtime.* and com.sun.org.apache.xerces.internal.* . It actually throws exceptions on same classes when I run the app on win32, but somehow there the app starts fine. So this might not be the actual cause of the problem. Also, when I export Eclipse Product the app works fine on all platforms.
So I'm interested to know if anyone has experienced the same kind of behavior when exporting RCP applications (deployable features + jws support) to multiple platforms. Also if anyone can suggest where to investigate further it would be much appreciated.

Thanks,
Matt

[Updated on: Tue, 02 February 2010 05:55]

Report message to a moderator

Re: RCP + jws multiplatform [message #511865 is a reply to message #511632] Wed, 03 February 2010 04:55 Go to previous message
No real name is currently offline No real name
Messages: 3
Registered: December 2009
Junior Member
Well if anyone is interested, the problem was that the export didn't include needed files to different platforms (linux pugins included win32 swt plugin fragments but not linux swt plugin fragments). I had to manually include platform specific fragments to my webstart feature.

Matt
Previous Topic:License Management
Next Topic:Creating a parameter controlled ViewerFilter for CommonNavigator
Goto Forum:
  


Current Time: Sun Aug 31 04:29:26 EDT 2014

Powered by FUDForum. Page generated in 0.01583 seconds