Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Objectteams » OTDT 1.4.0M3 released
OTDT 1.4.0M3 released [message #511360] Mon, 01 February 2010 07:52 Go to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
Version 1.4.0 M3 of the Object Teams Development Tooling is on
our "old" server, see http://www.objectteams.org/distrib/otdt.html

This release matches the freshly released Milestone 5 of Eclipse 3.6.

Furthermore, this release is part of the current consolidation of all
content at www.objectteams.org. Unless significant errors are reported,
this milestone shall soon graduate to becoming the final 1.4.0,
which will be the last release before everything is migrated from
org.objectteams to org.eclipse.objectteams.

For this reason it would be great if you actually download and try
this milestone (on top of Eclispe 3.6 M5 that is) - and report back
if you observe any problems.
I'd like to avoid maintenance in this stream beyond 1.4.0, if possible.

Apart from organizational issues the milestone release features a few
improvements in the OTJLD by relaxing some language rules for the
sake of greater flexibility:



Stephan

PS: The new project plan shows details of what steps are scheduled
for the move to eclipse.org. The plan also shows the progress towards
all planed goals.
Re: OTDT 1.4.0M3 released [message #514057 is a reply to message #511360] Fri, 12 February 2010 05:34 Go to previous messageGo to next message
Eugene Hutorny is currently offline Eugene Hutorny
Messages: 109
Registered: January 2010
Senior Member
Hello,

I have run check updates in my Eclipse (v. 3.5.1, Build id: 20090920-1017) and it reported 'there is nothing to update'.

What is the procedure for upgrading to 1.4.0?
Re: OTDT 1.4.0M3 released [message #514231 is a reply to message #514057] Fri, 12 February 2010 17:30 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
The OTDT 1.4.0 Mx requires a corresponding milestone
M(x+2) from the Eclipse 3.6.0 stream. Your message sounds
like you should add this under Available Software Sites:

http://download.eclipse.org/eclipse/updates/3.6milestones

I don't recall the exact experience of upgrading Eclipse
3.5.1 to a 3.6 milestone, though. So if that causes
trouble you may want to fetch a fresh Eclipse SDK M5 from http://download.eclipse.org/eclipse/downloads/drops/S-3.6M5- 201001291300/index.php
first.

Generally information regarding downloads/upgrades is
collect here:
http://www.objectteams.org/distrib/otdt.html

Does any of this help?
Stephan
Re: OTDT 1.4.0M3 released [message #514429 is a reply to message #514231] Mon, 15 February 2010 05:22 Go to previous messageGo to next message
Eugene Hutorny is currently offline Eugene Hutorny
Messages: 109
Registered: January 2010
Senior Member
Stephan Herrmann wrote on Fri, 12 February 2010 17:30
The OTDT 1.4.0 Mx requires a corresponding milestone
M(x+2) from the Eclipse 3.6.0 stream. Your message sounds
like you should add this under Available Software Sites:
[...]
Generally information regarding downloads/upgrades is
collect here:
http://www.objectteams.org/distrib/otdt.html

Does any of this help?
Stephan


Thanks, it has helped.

Eugene
Re: OTDT 1.4.0M3 released [message #568032 is a reply to message #511360] Fri, 12 February 2010 05:34 Go to previous messageGo to next message
Eugene Hutorny is currently offline Eugene Hutorny
Messages: 109
Registered: January 2010
Senior Member
Hello,

I have run check updates in my Eclipse (v. 3.5.1, Build id: 20090920-1017) and it reported 'there is nothing to update'.

What is the procedure for upgrading to 1.4.0?
Re: OTDT 1.4.0M3 released [message #568273 is a reply to message #568032] Fri, 12 February 2010 17:30 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
The OTDT 1.4.0 Mx requires a corresponding milestone
M(x+2) from the Eclipse 3.6.0 stream. Your message sounds
like you should add this under Available Software Sites:

http://download.eclipse.org/eclipse/updates/3.6milestones

I don't recall the exact experience of upgrading Eclipse
3.5.1 to a 3.6 milestone, though. So if that causes
trouble you may want to fetch a fresh Eclipse SDK M5 from http://download.eclipse.org/eclipse/downloads/drops/S-3.6M5- 201001291300/index.php
first.

Generally information regarding downloads/upgrades is
collect here:
http://www.objectteams.org/distrib/otdt.html

Does any of this help?
Stephan
Re: OTDT 1.4.0M3 released [message #568310 is a reply to message #568273] Mon, 15 February 2010 05:22 Go to previous message
Eugene Hutorny is currently offline Eugene Hutorny
Messages: 109
Registered: January 2010
Senior Member
Stephan Herrmann wrote on Fri, 12 February 2010 17:30
> The OTDT 1.4.0 Mx requires a corresponding milestone
> M(x+2) from the Eclipse 3.6.0 stream. Your message sounds
> like you should add this under Available Software Sites:
> [...]
> Generally information regarding downloads/upgrades is
> collect here:
> http://www.objectteams.org/distrib/otdt.html
>
> Does any of this help?
> Stephan


Thanks, it has helped.

Eugene
Previous Topic:A question on design motivation for callout syntax
Next Topic:Multidispatch pattern with OT/J
Goto Forum:
  


Current Time: Fri Aug 29 14:36:16 EDT 2014

Powered by FUDForum. Page generated in 0.01727 seconds