Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » MenuItem doesn't send selection event the 2nd time around
MenuItem doesn't send selection event the 2nd time around [message #511079] Fri, 29 January 2010 18:05 Go to next message
Larvell Jones is currently offline Larvell Jones
Messages: 2
Registered: January 2010
Junior Member
So, the first time I select this menu item it works fine. But then it seems to disable all other menu items because none of them are responsive. There are no errors or messages in the logs..

The menu item in question invokes a FileDialog and the problem occurs only when a file was selected. If the dialog was cancelled, the menu items are ok. After the file is selected my application specific code which sets up all the widgets in the layout, so it's entirely possible that something in my app code is causing this .. but I'm having a tough time tracking it down.

A second side-effect is that the accelerator on the menu items disappear..

Does this ring any bells to anyone? I'll be glad to post code/configuration files if you just let me know which ones to post.

Thanks!
Re: MenuItem doesn't send selection event the 2nd time around [message #511409 is a reply to message #511079] Mon, 01 February 2010 09:52 Go to previous message
Grant Gayed is currently offline Grant Gayed
Messages: 2151
Registered: July 2009
Senior Member
Hi,

I don't know what would cause this, so I think you'll have to provide some
code. At a minimum the code that runs when an item is selected is needed;
more ideal would be a runnable snippet similar to
http://dev.eclipse.org/viewcvs/index.cgi/%7Echeckout%7E/org. eclipse.swt.snippets/src/org/eclipse/swt/snippets/Snippet29. java
that shows the problem happening. Also, which platform do you see this on?

Grant


<larvell.jones@gmail.com> wrote in message
news:hjv820$jih$1@build.eclipse.org...
> So, the first time I select this menu item it works fine. But then it
seems to disable all other menu items because none of them are responsive.
There are no errors or messages in the logs..
>
> The menu item in question invokes a FileDialog and the problem occurs only
when a file was selected. If the dialog was cancelled, the menu items are
ok. After the file is selected my application specific code which sets up
all the widgets in the layout, so it's entirely possible that something in
my app code is causing this .. but I'm having a tough time tracking it down.
>
> A second side-effect is that the accelerator on the menu items disappear..
>
> Does this ring any bells to anyone? I'll be glad to post
code/configuration files if you just let me know which ones to post.
>
> Thanks!
Previous Topic:How to Display UTF-8 Characters in SWT?
Next Topic:ExpandBar how multiline Label layout
Goto Forum:
  


Current Time: Sun Sep 21 02:11:47 GMT 2014

Powered by FUDForum. Page generated in 0.01591 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software