Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » "org.eclipse.test.coretestapplication" could not be found in the registry(Automating Eclipse PDE Unit Tests using Ant)
"org.eclipse.test.coretestapplication" could not be found in the registry [message #510199] Tue, 26 January 2010 16:38 Go to next message
kent gibson is currently offline kent gibson
Messages: 114
Registered: July 2009
Senior Member
I am trying to run PDE unit tests using ant in 3.5, somewhat similiar to this article:

http://www.eclipse.org/articles/printable.php?file=Article-P DEJUnitAntAutomation/index.html

I can build the test client but when I start the client I always get this error:

java.lang.RuntimeException: Application "org.eclipse.test.coretestapplication" could not be found in the registry. The applications available are: ch.sbb.rcsd.client.application.application, org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error, org.eclipse.update.core.standaloneUpdate, org.eclipse.update.core.siteOptimizer.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
at org.eclipse.core.launcher.Main.main(Main.java:34)


To do this I have created a feature based product which has dependencies on org.eclips.test, org.eclipse.rcp and a feature that I have defined.

My test feature basically mimics the application 100%, in other words the same plugins and fragments are listed in the plugins tab.

When I validate the product "almost everything" validates. It has some problems with internal packages from org.eclipse.equinox.internal.*

Does anyone have a clue what I might be doing wrong?

Many thanks in advance.






Re: "org.eclipse.test.coretestapplication" could not be found in the registry [message #510368 is a reply to message #510199] Wed, 27 January 2010 06:28 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Kent,
Unfortunately, you have the wrong news group. I would suggest the
Eclipse PDE news group.

Paul
"kent gibson" <kentgibson@yahoo.com> wrote in message
news:hjn5r2$sc6$1@build.eclipse.org...
>I am trying to run PDE unit tests using ant in 3.5, somewhat similiar to
>this article:
>
> http://www.eclipse.org/articles/printable.php?file=Article-P DEJUnitAntAutomation/index.html
>
> I can build the test client but when I start the client I always get this
> error:
>
> java.lang.RuntimeException: Application
> "org.eclipse.test.coretestapplication" could not be found in the registry.
> The applications available are:
> ch.sbb.rcsd.client.application.application,
> org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error,
> org.eclipse.update.core.standaloneUpdate,
> org.eclipse.update.core.siteOptimizer.
> at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe
> faultApp(EclipseAppContainer.java:242)
> at org.eclipse.equinox.internal.app.MainApplicationLauncher.run
> (MainApplicationLauncher.java:29)
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher
> .runApplication(EclipseAppLauncher.java:110)
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher
> .start(EclipseAppLauncher.java:79)
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS
> tarter.java:368)
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS
> tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce
> ssorImpl.java:39)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe
> thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
> at org.eclipse.core.launcher.Main.main(Main.java:34)
>
>
> To do this I have created a feature based product which has dependencies
> on org.eclips.test, org.eclipse.rcp and a feature that I have defined.
>
> My test feature basically mimics the application 100%, in other words the
> same plugins and fragments are listed in the plugins tab.
>
> When I validate the product "almost everything" validates. It has some
> problems with internal packages from org.eclipse.equinox.internal.*
> Does anyone have a clue what I might be doing wrong?
>
> Many thanks in advance.
>
>
>
>
>
>
>
Re: "org.eclipse.test.coretestapplication" could not be found in the registry [message #510378 is a reply to message #510199] Wed, 27 January 2010 11:57 Go to previous message
kent gibson is currently offline kent gibson
Messages: 114
Registered: July 2009
Senior Member
ok thanks, i cloned it there.
Previous Topic:Access to Variables of testcase in VerificationHooksMethode
Next Topic:TPTP with Websphere 7
Goto Forum:
  


Current Time: Wed Oct 22 06:41:57 GMT 2014

Powered by FUDForum. Page generated in 0.05718 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software