Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » [SOLVED]Error when I create a Dynamic Web Project(Some classes are missing)
[SOLVED]Error when I create a Dynamic Web Project [message #509894] Mon, 25 January 2010 16:50 Go to next message
Batistuta is currently offline Batistuta
Messages: 6
Registered: January 2010
Junior Member
Hello everybody,

I correctly installed the tools to make a Dynamic Web Project :
- Apache tomcat 6
- Axis 2
I followed the inscructions of : http:// www.eclipse.org/webtools/community/tutorials/BottomUpAxis2We bService/bu_tutorial.html

Unfortunetly, when I create a Dynamic Web Project, without doing anything, I have a lot of erros in the directory : WebContent. The problems are located in the files :
- HappyAxis.jsp
- cannot import javax.xml.stream.XMLOutputFactory
- cannot import javax.xml.stream.XMLStreamException
- HttpServletRequest cannot be resolved to a type
- etc
- viewphases.jsp
- Type mismatch: cannot convert from List<Phase> to ArrayList
- etc

If I follow the instructions of the tutorial and if I try to "Degug" the programme, I can see the index of apache but when i want to see the "services", I have this error:
25 janv. 2010 17:46:14 org.apache.catalina.core.ApplicationContext log
GRAVE: StandardWrapper.Throwable
java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
	at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:525)
	at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:443)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
	at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:809)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:852)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	at java.lang.Thread.run(Thread.java:613)
25 janv. 2010 17:46:14 org.apache.catalina.core.StandardWrapperValve invoke
GRAVE: Exception lors de l'allocation pour la servlet AxisServlet
java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
	at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:525)
	at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:443)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
	at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:809)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:852)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	at java.lang.Thread.run(Thread.java:613)



It's exactly the same problem as :http:// dev.eclipse.org/newslists/news.eclipse.webtools/msg16418.htm l

Could you tell me what is wrong with my program or my installation?

Thank you very much

Batistuta

P.S : I use MAC OS 10.5.8

[Updated on: Tue, 26 January 2010 10:23]

Report message to a moderator

Re: Error when I create a Dynamic Web Project [message #510040 is a reply to message #509894] Tue, 26 January 2010 10:22 Go to previous message
Batistuta is currently offline Batistuta
Messages: 6
Registered: January 2010
Junior Member
I solved the problem.
I needed to use java 1.6 and the version 1.4.1 of Axis 3

Thanks
Previous Topic:problem installing wst
Next Topic:Project template
Goto Forum:
  


Current Time: Sat Sep 20 03:59:21 GMT 2014

Powered by FUDForum. Page generated in 0.02213 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software