Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » doesn't find method definition!!!!!(IntegrityException)
doesn't find method definition!!!!! [message #509203] Thu, 21 January 2010 16:37 Go to next message
Carlos Conti is currently offline Carlos Conti
Messages: 26
Registered: January 2010
Junior Member
Hi all,

I am setting up a persistence project with EL. In order to enable mappings OneToMany (double side navigation) I have enabled static weaving, and set weaving.lazy=true.

From that moment on, EL doesn't seem to recognize the method definitions (get/set) in the persistent classes, throwing the following exception, which doesn't make sense at all to me....

Could you please give me any hints?

Thanks in advance.

Exception [EclipseLink-60] (Eclipse Persistence Services - 1.1.2.v20090612-r4475): org.eclipse.persistence.exceptions.DescriptorException
Exception Description: The method [_persistence_setdepartamento_vh] or [_persistence_getdepartamento_vh] is not defined in the object [estructuras.Ubicacion].
Internal Exception: java.lang.NoSuchMethodException: estructuras.Ubicacion._persistence_getdepartamento_vh()
Mapping: org.eclipse.persistence.mappings.OneToManyMapping[departamen to]
Descriptor: RelationalDescriptor(estructuras.Ubicacion --> [DatabaseTable(ubicaciones)])
Re: doesn't find method definition!!!!! [message #509210 is a reply to message #509203] Thu, 21 January 2010 16:56 Go to previous messageGo to next message
James Sutherland is currently offline James Sutherland
Messages: 1939
Registered: July 2009
Location: Ottawa, Canada
Senior Member

What do you mean by "enabled static weaving"? Did you just set it in your persistence.xml, or did you run the static weaver? You must run the EclipseLink static weaver class or ant task on your jar to use static weaving, and use the jar it produces.


James : Wiki : Book : Blog : Twitter
Re: doesn't find method definition!!!!! [message #509217 is a reply to message #509203] Thu, 21 January 2010 17:09 Go to previous message
Carlos Conti is currently offline Carlos Conti
Messages: 26
Registered: January 2010
Junior Member
I mean I added it to persistence.xml...

I just tried to set all fetch types to EAGER and now it works. However I fear this will won't be very efficient when handling large amounts of data.

Thanks for your quick answer.
Previous Topic:@ElementCollection from embeddable object
Next Topic:JOINED-@Inheritance, MappedSuperclass with multiple @Id fields
Goto Forum:
  


Current Time: Thu Oct 23 17:20:58 GMT 2014

Powered by FUDForum. Page generated in 0.01876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software