Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » "required items could not be found" error during ECF install("required items could not be found" error during ECF install on Eclipse 3.5.1)
"required items could not be found" error during ECF install [message #508746] Wed, 20 January 2010 06:55 Go to next message
rose.jared+eclipse is currently offline rose.jared+eclipse
Messages: 6
Registered: January 2010
Junior Member
Hi all,

I followed the instructions on the ECF website for installing this plugin (Help --> Install New Software, etc.), but I get the following error:

Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse Communication Framework SDK 3.1.0.v20091012-1618 (org.eclipse.ecf.core.feature.group 3.1.0.v20091012-1618)
Missing requirement: ECF Discovery UI 3.0.0.v20091012-1618 (org.eclipse.ecf.discovery.ui 3.0.0.v20091012-1618) requires 'bundle org.eclipse.emf.edit.ui [2.2.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Eclipse Communication Framework SDK 3.1.0.v20091012-1618 (org.eclipse.ecf.core.feature.group 3.1.0.v20091012-1618)
To: org.eclipse.ecf.discovery.ui [3.0.0.v20091012-1618]


I'm not really sure how to proceed from here. How can I resolve these dependencies? Are there some steps I need to take before starting the install to get these packages? Any help you can give me would be appreciated.

Here are some additional details that may be helpful:


  • I'm running Eclipse 3.5.1 (with pydev plugin)
  • My OS is Kubuntu 9.10 (Karmic Koala)
Re: "required items could not be found" error during ECF install [message #508989 is a reply to message #508746] Wed, 20 January 2010 21:42 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 971
Registered: July 2009
Senior Member
Hi,

With a fresh copy of Eclipse 3.5.1 I just successfully installed ECF 3.1
using the p2 site given on the download page:

download page: http://www.eclipse.org/ecf/downloads.php
ECF p2 repo given on page: http://download.eclipse.org/rt/ecf/3.1/3.5/repo

....so currently I'm not able to reproduce this problem (at least with
windows...which is the OS that I have access to).

It seems from your error message that the problem lies with an EMF
bundle that the ECF discovery UI depends upon (i.e. emf.edit.ui). this
is strange, because with a fresh 3.5.1 install these EMF bundles are
installed automatically when ECF 3.1 is installed.

Perhaps you either have 1) an old emf version installed (e.g. by
pydev?); or 2) some problem with an emf install? Is this possible?

I'm not saying there isn't some problem with ECF's 3.1's install
(perhaps there is), but I'm trying to understand what is going on with
your install so that I can figure out how we can/could address it.

Thanks,

Scott

rose.jared+eclipse@gmail.com wrote:
> Hi all,
>
> I followed the instructions on the
> http://www.eclipse.org/ecf/downloads.php for installing this plugin
> (Help --> Install New Software, etc.), but I get the following error:
> Quote:
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software being installed: Eclipse Communication Framework SDK
>> 3.1.0.v20091012-1618 (org.eclipse.ecf.core.feature.group
>> 3.1.0.v20091012-1618)
>> Missing requirement: ECF Discovery UI 3.0.0.v20091012-1618
>> (org.eclipse.ecf.discovery.ui 3.0.0.v20091012-1618) requires 'bundle
>> org.eclipse.emf.edit.ui [2.2.0,3.0.0)' but it could not be found
>> Cannot satisfy dependency:
>> From: Eclipse Communication Framework SDK 3.1.0.v20091012-1618
>> (org.eclipse.ecf.core.feature.group 3.1.0.v20091012-1618)
>> To: org.eclipse.ecf.discovery.ui [3.0.0.v20091012-1618]
>
>
> I'm not really sure how to proceed from here. How can I resolve these
> dependencies? Are there some steps I need to take before starting the
> install to get these packages? Any help you can give me would be
> appreciated.
>
> Here are some additional details that may be helpful:
>
> I'm running Eclipse 3.5.1 (with pydev plugin)
> My OS is Kubuntu 9.10 (Karmic Koala)
>
Re: "required items could not be found" error during ECF install [message #510001 is a reply to message #508989] Tue, 26 January 2010 06:29 Go to previous messageGo to next message
rose.jared+eclipse is currently offline rose.jared+eclipse
Messages: 6
Registered: January 2010
Junior Member
Thanks for looking into my problem. If you were able to install from the same location I've been trying to install from, then it does sound like either a conflict with the pydev plugin, or the eclipse package in the Ubuntu Linux repos. I don't seem to be having any other problems with the eclipse package, but I will try removing the pydev plugin and see if that could be the problem.
Re: "required items could not be found" error during ECF install [message #514254 is a reply to message #510001] Sat, 13 February 2010 03:43 Go to previous messageGo to next message
Tom Popovic is currently offline Tom Popovic
Messages: 2
Registered: February 2010
Junior Member
Same error here. I tried a fresh copy of eclipse, and could install the ECF without problems, so it definitely seems to be plugin related.

I have the following plug ins installed:
Toggle Spoiler
Re: "required items could not be found" error during ECF install [message #514302 is a reply to message #508746] Sat, 13 February 2010 20:56 Go to previous message
rose.jared+eclipse is currently offline rose.jared+eclipse
Messages: 6
Registered: January 2010
Junior Member
I've tried the same setup with the same plugins on a windows vista machine and it installed without problems. I've also tried reinstalling everything from scratch on Kubuntu (Karmic) Linux and still having the same problem. I don't know if the plugin only has trouble only on Linux systems or not.
Previous Topic:Need further clarification on Distributed Event Admin
Next Topic:"required items could not be found" error during ECF install
Goto Forum:
  


Current Time: Tue Oct 21 07:16:31 GMT 2014

Powered by FUDForum. Page generated in 0.06170 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software