Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » package versioning troubles(how to make sure right bundle is picked up by my plugin)
package versioning troubles [message #508135] Sat, 16 January 2010 13:40
Ivica Loncar is currently offline Ivica LoncarFriend
Messages: 41
Registered: July 2009
Member
I'm trying to learn more about the reason why SpringIDE doesn't work on IBM RSA/RAD 7.5.

Recently springide switched from using Require-Bundle header to using Import-Packages header and it seems that now it gets wired to the IBM provided bundles.

I would like to learn what is the reason for picking up com.ibm.websphere.v61_6.1.200.v20090109_1429 bundle instead of org.eclipse.wst.xml.core_1.1.310.v20091022144
in the example posted bellow.

Also, what is the proper way to handle this situation? Should one add more constraints to the Import-Package header (like bundle-symbolic-name and bundle-version attributes)?

Thanks!


osgi> packages org.eclipse.wst.xml.core.internal.regions
org.eclipse.wst.xml.core.internal.regions; version="0.0.0"<reference:file:../SDPShared\plugins\org.eclipse.wst.xml.core_1.1.310.v20091022144
6.jar [8316]>
  reference:file:../SDPShared\plugins\com.ibm.ast.ws.jaxws.emitter_1.0.109.v200911201214\ [6017] imports
  reference:file:../SDPShared\plugins\com.ibm.ast.ws.jaxws.emitter.jdk6_1.0.4.v200909080034\ [6018] imports
  reference:file:../SDPShared\plugins\com.ibm.ccl.mapping.codegen.xslt_1.0.211.v20091127_2254.jar [6076] imports
  reference:file:../SDPShared\plugins\com.ibm.ccl.mapping.codegen.xslt.ui_1.0.211.v20090731_0330.jar [6079] imports
  reference:file:../SDPShared\plugins\com.ibm.etools.ejbdeploy.ui.core_6.2.104.v20090922_1754.jar [6551] imports
  reference:file:../SDPShared\plugins\com.ibm.etools.emf.workbench.ui_5.1.200.v20091010_0128.jar [6553] imports
.....
org.eclipse.wst.xml.core.internal.regions; version="0.0.0"<reference:file:../SDPShared\plugins\com.ibm.websphere.v61_6.1.200.v20090109_1429\
 [6971]>
  reference:file:../SDPShared\plugins\plugins\org.springframework.ide.eclipse.beans.ui.editor_2.3.1.201001112109.jar [5967] imports
  reference:file:../SDPShared\plugins\plugins\org.springframework.ide.eclipse.beans.ui.refactoring_2.3.1.201001112109.jar [5969] imports
  reference:file:../SDPShared\plugins\com.ibm.ast.ws.uddi.registry.v61_6.1.105.v200904160937\ [6027] imports
  reference:file:../SDPShared\plugins\com.ibm.ast.ws.was61.policyset.ui_1.0.5.v200910260847.jar [6035] imports
  reference:file:../SDPShared\plugins\com.ibm.websphere.v61.ext_6.1.200.v20080707c\ [6972] imports



osgi> headers 5967
Bundle headers:
 Bundle-ActivationPolicy = lazy
 Bundle-Activator = org.springframework.ide.eclipse.beans.ui.editor.Activator
 Bundle-Localization = plugin
 Bundle-ManifestVersion = 2
 Bundle-Name = Spring IDE Beans Config Editor
 Bundle-RequiredExecutionEnvironment = J2SE-1.5
 Bundle-SymbolicName = org.springframework.ide.eclipse.beans.ui.editor;singleton:=true
 Bundle-Vendor = Spring IDE Developers
 Bundle-Version = 2.3.1.201001112109
 Eclipse-LazyStart = true
 Export-Package = org.springframework.ide.eclipse.beans.ui.editor,org.springframework.ide.eclipse.beans.ui.editor.actions,org.springframewor
k.ide.eclipse.beans.ui.editor.contentassist,org.springframework.ide.eclipse.beans.ui.editor.contentassist.aop,org.springframework.ide.eclips
e.beans.ui.editor.contentassist.bean,org.springframework.ide.eclipse.beans.ui.editor.contentassist.context,org.springframework.ide.eclipse.b
eans.ui.editor.contentassist.jee,org.springframework.ide.eclipse.beans.ui.editor.contentassist.jms,org.springframework.ide.eclipse.beans.ui.
editor.contentassist.lang,org.springframework.ide.eclipse.beans.ui.editor.contentassist.tool,org.springframework.ide.eclipse.beans.ui.editor
.contentassist.tx,org.springframework.ide.eclipse.beans.ui.editor.contentassist.util,org.springframework.ide.eclipse.beans.ui.editor.hover,o
rg.springframework.ide.eclipse.beans.ui.editor.hyperlink,org.springframework.ide.eclipse.beans.ui.editor.hyperlink.aop,org.springframework.i
de.eclipse.beans.ui.editor.hyperlink.bean,org.springframework.ide.eclipse.beans.ui.editor.hyperlink.context,org.springframework.ide.eclipse.
beans.ui.editor.hyperlink.jee,org.springframework.ide.eclipse.beans.ui.editor.hyperlink.jms,org.springframework.ide.eclipse.beans.ui.editor.
hyperlink.lang,org.springframework.ide.eclipse.beans.ui.editor.hyperlink.tool,org.springframework.ide.eclipse.beans.ui.editor.hyperlink.tx,o
rg.springframework.ide.eclipse.beans.ui.editor.hyperlink.util,org.springframework.ide.eclipse.beans.ui.editor.namespaces,org.springframework
.ide.eclipse.beans.ui.editor.namespaces.bean,org.springframework.ide.eclipse.beans.ui.editor.namespaces.tx,org.springframework.ide.eclipse.b
eans.ui.editor.outline,org.springframework.ide.eclipse.beans.ui.editor.outline.aop,org.springframework.ide.eclipse.beans.ui.editor.outline.b
ean,org.springframework.ide.eclipse.beans.ui.editor.outline.context,org.springframework.ide.eclipse.beans.ui.editor.outline.jee,org.springfr
amework.ide.eclipse.beans.ui.editor.outline.jms,org.springframework.ide.eclipse.beans.ui.editor.outline.lang,org.springframework.ide.eclipse
.beans.ui.editor.outline.tx,org.springframework.ide.eclipse.beans.ui.editor.outline.util,org.springframework.ide.eclipse.beans.ui.editor.tem
plates,org.springframework.ide.eclipse.beans.ui.editor.util
 Import-Package = javax.xml.xpath,org.eclipse.core.commands.common,org.eclipse.core.resources;bundle-symbolic-name="org.eclipse.core.resourc
es";bundle-version="[3.4.0,4.0.0)",org.eclipse.core.runtime;bundle-symbolic-name="org.eclipse.core.runtime";bundle-version="[3.4.0,4.0.0)",o
rg.eclipse.core.runtime.jobs;bundle-symbolic-name="org.eclipse.core.jobs";bundle-version="[3.4.0,4.0.0)",org.eclipse.core.runtime.preference
s;bundle-version="[3.4.0,4.0.0)",org.eclipse.emf.common.util;bundle-symbolic-name="org.eclipse.emf.common";bundle-version="[2.4.0,2.6.0)",or
g.eclipse.emf.ecore.impl;bundle-symbolic-name="org.eclipse.emf.ecore";bundle-version="[2.4.0,2.6.0)",org.eclipse.jdt.core,org.eclipse.jdt.co
re.compiler,org.eclipse.jdt.core.search,org.eclipse.jdt.internal.core,org.eclipse.jdt.internal.corext.util,org.eclipse.jdt.internal.ui,org.e
clipse.jdt.internal.ui.text.java,org.eclipse.jdt.internal.ui.viewsupport,org.eclipse.jdt.ui,org.eclipse.jdt.ui.text.java,org.eclipse.jface.a
ction,org.eclipse.jface.dialogs,org.eclipse.jface.fieldassist,org.eclipse.jface.preference,org.eclipse.jface.resource,org.eclipse.jface.text
,org.eclipse.jface.text.contentassist,org.eclipse.jface.text.hyperlink,org.eclipse.jface.text.source,org.eclipse.jface.text.templates,org.ec
lipse.jface.text.templates.persistence,org.eclipse.jface.viewers,org.eclipse.jface.window,org.eclipse.search.ui,org.eclipse.swt.custom,org.e
clipse.swt.graphics,org.eclipse.swt.widgets,org.eclipse.ui,org.eclipse.ui.editors.text,org.eclipse.ui.editors.text.templates,org.eclipse.ui.
internal,org.eclipse.ui.plugin,org.eclipse.ui.texteditor,org.eclipse.ui.texteditor.templates,org.eclipse.wst.sse.core,org.eclipse.wst.sse.co
re.internal.document,org.eclipse.wst.sse.core.internal.format,org.eclipse.wst.sse.core.internal.ltk.modelhandler,org.eclipse.wst.sse.core.in
ternal.model,org.eclipse.wst.sse.core.internal.provisional,org.eclipse.wst.sse.core.internal.provisional.text,org.eclipse.wst.sse.core.inter
nal.util,org.eclipse.wst.sse.core.text,org.eclipse.wst.sse.ui,org.eclipse.wst.sse.ui.internal,org.eclipse.wst.sse.ui.internal.contentassist,
org.eclipse.wst.sse.ui.internal.contentoutline,org.eclipse.wst.sse.ui.internal.provisional.registry,org.eclipse.wst.sse.ui.views.contentoutl
ine,org.eclipse.wst.xml.core.internal.contentmodel,org.eclipse.wst.xml.core.internal.contentmodel.modelquery,org.eclipse.wst.xml.core.intern
al.contentmodel.util,org.eclipse.wst.xml.core.internal.document,org.eclipse.wst.xml.core.internal.encoding,org.eclipse.wst.xml.core.internal
.modelhandler,org.eclipse.wst.xml.core.internal.modelquery,org.eclipse.wst.xml.core.internal.provisional.document,org.eclipse.wst.xml.core.i
nternal.provisional.format,org.eclipse.wst.xml.core.internal.regions,org.eclipse.wst.xml.core.text,org.eclipse.wst.xml.ui,org.eclipse.wst.xm
l.ui.internal,org.eclipse.wst.xml.ui.internal.contentassist,org.eclipse.wst.xml.ui.internal.contentoutline,org.eclipse.wst.xml.ui.internal.p
references,org.eclipse.wst.xml.ui.internal.registry,org.eclipse.wst.xml.ui.internal.taginfo,org.eclipse.wst.xml.ui.views.contentoutline,org.
eclipse.wst.xsd.contentmodel.internal,org.eclipse.xsd,org.osgi.framework,org.springframework.beans;version="[3.0.0.RELEASE,3.1.0)",org.sprin
gframework.beans.factory;version="[3.0.0.RELEASE,3.1.0)",org.springframework.ide.eclipse.beans.core,org.springframework.ide.eclipse.beans.co
re.internal.model,org.springframework.ide.eclipse.beans.core.model,org.springframework.ide.eclipse.beans.core.namespaces,org.springframework
.ide.eclipse.beans.ui,org.springframework.ide.eclipse.beans.ui.actions,org.springframework.ide.eclipse.beans.ui.model,org.springframework.id
e.eclipse.beans.ui.namespaces,org.springframework.ide.eclipse.beans.ui.search.internal,org.springframework.ide.eclipse.beans.ui.search.inter
nal.queries,org.springframework.ide.eclipse.core,org.springframework.ide.eclipse.core.io,org.springframework.ide.eclipse.core.java,org.sprin
gframework.ide.eclipse.core.model,org.springframework.ide.eclipse.ui,org.springframework.ide.eclipse.ui.editors,org.springframework.util;ver
sion="[3.0.0.RELEASE,3.1.0)",org.w3c.dom
 Manifest-Version = 1.0


Previous Topic:create p2 repository based on features of another p2 repository
Next Topic:Context Web Application Framework
Goto Forum:
  


Current Time: Tue Dec 23 02:32:49 GMT 2014

Powered by FUDForum. Page generated in 0.02022 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software