Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Re: installation problem on 3.3.1.1
Re: installation problem on 3.3.1.1 [message #51333] Thu, 28 February 2008 05:41 Go to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

It's best to ask on the OCL newsgroup, which I've added to the "to" list
of this reply.

If you run eclipse.exe -clean -debug and look at the
<workspace>/.metadata/.log or the Error Log view, it will describe in
detail why plugins are failing to resolve, i.e, what dependencies they
have that aren't being met.

If I look at their downloads page I can see that 1.0.x is for the
Eclipse 3.2 stream. So I think you need 1.1.x.


zongheng wrote:
> whenever I try to get emft with update manager, EMFT OCL SDK 1.0.1 is
> installed as "not configured properly" and with all 3 following
> features disabled :
> - EMFT OCL source
> - EMFT OCL 1.0.1
> - EMFT OCL documentation
>
> anyone get this problem already ?
>
Re: installation problem on 3.3.1.1 [message #51873 is a reply to message #51333] Sun, 02 March 2008 11:19 Go to previous messageGo to next message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
Thanks for replying but I installed version 3.3.2 from scratch and this time
I encouter another problem :

When updating and selecting only "EMFT Update site" , the search results
dialog box lists no site no feature to install and says : " 0 of 15
selected" ! Option "Show the latest version of a version only" is selected.
When I deselect this option , the EMFT update site appears but not
expandable, still with the " 0 of 15 selected" message, I can't see nor
select any feature.


"Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
news:fq634v$57k$1@build.eclipse.org...
> It's best to ask on the OCL newsgroup, which I've added to the "to" list
> of this reply.
>
> If you run eclipse.exe -clean -debug and look at the
> <workspace>/.metadata/.log or the Error Log view, it will describe in
> detail why plugins are failing to resolve, i.e, what dependencies they
> have that aren't being met.
>
> If I look at their downloads page I can see that 1.0.x is for the Eclipse
> 3.2 stream. So I think you need 1.1.x.
>
>
> zongheng wrote:
>> whenever I try to get emft with update manager, EMFT OCL SDK 1.0.1 is
>> installed as "not configured properly" and with all 3 following features
>> disabled :
>> - EMFT OCL source
>> - EMFT OCL 1.0.1
>> - EMFT OCL documentation
>>
>> anyone get this problem already ?
>>
>
Re: installation problem on 3.3.1.1 [message #51900 is a reply to message #51873] Sun, 02 March 2008 12:48 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

I think OCL should be on the MDT update site, not the EMFT one these days..


zongheng wrote:
> Thanks for replying but I installed version 3.3.2 from scratch and
> this time
> I encouter another problem :
>
> When updating and selecting only "EMFT Update site" , the search results
> dialog box lists no site no feature to install and says : " 0 of 15
> selected" ! Option "Show the latest version of a version only" is
> selected.
> When I deselect this option , the EMFT update site appears but not
> expandable, still with the " 0 of 15 selected" message, I can't see nor
> select any feature.
>
>
> "Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
> news:fq634v$57k$1@build.eclipse.org...
>> It's best to ask on the OCL newsgroup, which I've added to the "to"
>> list of this reply.
>>
>> If you run eclipse.exe -clean -debug and look at the
>> <workspace>/.metadata/.log or the Error Log view, it will describe in
>> detail why plugins are failing to resolve, i.e, what dependencies
>> they have that aren't being met.
>>
>> If I look at their downloads page I can see that 1.0.x is for the
>> Eclipse 3.2 stream. So I think you need 1.1.x.
>>
>>
>> zongheng wrote:
>>> whenever I try to get emft with update manager, EMFT OCL SDK 1.0.1
>>> is installed as "not configured properly" and with all 3 following
>>> features disabled :
>>> - EMFT OCL source
>>> - EMFT OCL 1.0.1
>>> - EMFT OCL documentation
>>>
>>> anyone get this problem already ?
>>>
>>
>
Re: installation problem on 3.3.1.1 [message #52262 is a reply to message #51900] Wed, 05 March 2008 08:54 Go to previous messageGo to next message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
I tried. Received an error message from the update site : "An exception
occured while downloading feature from
" http://download.eclipse.org/modeling/mdt/updates/features/or g.eclipse.ocl.uml.source_1.1.1.v200707131415-1007w3118182425 26.jar".

oh well...

"Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
news:fqep8s$7us$1@build.eclipse.org...
>I think OCL should be on the MDT update site, not the EMFT one these days..
>
>
> zongheng wrote:
>> Thanks for replying but I installed version 3.3.2 from scratch and this
>> time
>> I encouter another problem :
>>
>> When updating and selecting only "EMFT Update site" , the search results
>> dialog box lists no site no feature to install and says : " 0 of 15
>> selected" ! Option "Show the latest version of a version only" is
>> selected.
>> When I deselect this option , the EMFT update site appears but not
>> expandable, still with the " 0 of 15 selected" message, I can't see nor
>> select any feature.
>>
>>
>> "Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
>> news:fq634v$57k$1@build.eclipse.org...
>>> It's best to ask on the OCL newsgroup, which I've added to the "to" list
>>> of this reply.
>>>
>>> If you run eclipse.exe -clean -debug and look at the
>>> <workspace>/.metadata/.log or the Error Log view, it will describe in
>>> detail why plugins are failing to resolve, i.e, what dependencies they
>>> have that aren't being met.
>>>
>>> If I look at their downloads page I can see that 1.0.x is for the
>>> Eclipse 3.2 stream. So I think you need 1.1.x.
>>>
>>>
>>> zongheng wrote:
>>>> whenever I try to get emft with update manager, EMFT OCL SDK 1.0.1 is
>>>> installed as "not configured properly" and with all 3 following
>>>> features disabled :
>>>> - EMFT OCL source
>>>> - EMFT OCL 1.0.1
>>>> - EMFT OCL documentation
>>>>
>>>> anyone get this problem already ?
>>>>
>>>
>>
>
Re: installation problem on 3.3.1.1 [message #52312 is a reply to message #52262] Wed, 05 March 2008 11:17 Go to previous messageGo to next message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
Finally, I managed to update from a MDT update mirror site, to no avail :

as before :

EMFT OCL SDK 1.0.1 is installed as "not configured properly" and with all 3
following
features disabled :
- EMFT OCL source
- EMFT OCL 1.0.1
- EMFT OCL documentation

plus :

OCL 2.0 Extender SDK 1.1.1 disabled with sub-features
- OCL end-user feature 1.1.1 disabled
- OCL 2.0 Source 1.1.1 disabled
other are enabled

UML2 Tools disabled : all sub-features disabled

Error log follows :

Date / Time Target Action Status
5 mars 2008 16:57:38
org.eclipse.ocl.all.sdk_1.1.2.v200711262212-655_-JBYPSbnPexY US8mkoIokBkC
feature-install success
5 mars 2008 17:02:26 org.eclipse.ocl_1.1.2.v200711262212-3219oA55P6H8I9HDE
feature-enable success
5 mars 2008 17:02:26
org.eclipse.ocl.all_1.1.2.v200711262212-3237_76ThLBBkCeGUHbQ W
feature-enable success
5 mars 2008 17:02:26
org.eclipse.ocl.source_1.1.2.v200711262212-3219oA55P6H8I9HDE feature-enable
success
5 mars 2008 17:02:26
org.eclipse.ocl.all.sdk_1.1.2.v200711262212-655_-JBYPSbnPexY US8mkoIokBkC
feature-enable success
5 mars 2008 17:02:26
org.eclipse.ocl.all.sdk_1.1.1.v200707131415-653_-JAYPRgmMdz- YXRDlgnKonBk
feature-disable success
5 mars 2008 17:02:27
org.eclipse.ocl.all_1.1.1.v200707131415-3227_75ThLBBkBkFRGdQ Z
feature-disable success
5 mars 2008 17:02:27 org.eclipse.ocl_1.1.1.v200707131415-3209oA55P5N7F8JDH
feature-disable success
5 mars 2008 17:02:29
org.eclipse.ocl.source_1.1.1.v200707131415-3209oA55P5N7F8JDH
feature-disable success
5 mars 2008 17:02:29
org.eclipse.ocl.all_1.1.2.v200711262212-3237_76ThLBBkCeGUHbQ W
feature-install success
5 mars 2008 17:02:30
org.eclipse.ocl.source_1.1.2.v200711262212-3219oA55P6H8I9HDE
feature-install success
5 mars 2008 17:02:31 org.eclipse.ocl_1.1.2.v200711262212-3219oA55P6H8I9HDE
feature-install success
5 mars 2008 17:02:33
org.eclipse.emf.ocl.examples.source_1.1.0.v200706071450 feature-install
success
5 mars 2008 17:02:35
org.eclipse.emf.ocl.examples.source_1.1.0.v200706071450 feature-enable
success
5 mars 2008 17:02:35
org.eclipse.emf.ocl.examples_1.1.0.v200706071450-32-9oA55P5M 5P8GJ5
feature-install success
5 mars 2008 17:02:36
org.eclipse.emf.ocl.examples_1.1.0.v200706071450-32-9oA55P5M 5P8GJ5
feature-enable success
5 mars 2008 17:02:36 org.eclipse.uml2.diagram.source_0.7.101.v200802260712
feature-install success
5 mars 2008 17:02:39 org.eclipse.uml2.diagram.source_0.7.101.v200802260712
feature-enable success
5 mars 2008 17:02:39 org.eclipse.uml2.diagram.source_0.7.1.v200710010534
feature-disable success
5 mars 2008 17:02:39 org.eclipse.uml2.diagram_0.7.101.v200802260712
feature-install success
5 mars 2008 17:02:47 org.eclipse.uml2.diagram_0.7.101.v200802260712
feature-enable success
5 mars 2008 17:02:47 org.eclipse.uml2.diagram_0.7.1.v200710010534
feature-disable success
5 mars 2008 17:02:47 org.eclipse.uml2tools.doc_0.7.0.v200802260712
feature-install success
5 mars 2008 17:02:49 org.eclipse.uml2tools.doc_0.7.0.v200802260712
feature-enable success
5 mars 2008 17:02:49 org.eclipse.uml2tools.doc_0.7.0.v200710010534
feature-disable success
5 mars 2008 17:02:49 org.eclipse.uml2tools.sdk_0.7.1.v200802260712
feature-install success
5 mars 2008 17:02:50 org.eclipse.uml2tools_0.7.101.v200802260712
feature-enable success
5 mars 2008 17:02:50 org.eclipse.uml2tools.sdk_0.7.1.v200802260712
feature-enable success
5 mars 2008 17:02:50 org.eclipse.uml2tools.sdk_0.7.1.v200710010534
feature-disable success
5 mars 2008 17:02:51 org.eclipse.uml2tools_0.7.1.v200710010534
feature-disable success
5 mars 2008 17:02:52 org.eclipse.uml2tools_0.7.101.v200802260712
feature-install success
5 mars 2008 17:02:54 org.eclipse.uml2tools.examples_0.7.101.v200802260712
feature-install success
5 mars 2008 17:02:57 org.eclipse.uml2tools.examples_0.7.101.v200802260712
feature-enable success
5 mars 2008 17:02:57 org.eclipse.emf.ocl.sdk_1.0.1.v200611161546
feature-install success
5 mars 2008 17:03:00 org.eclipse.emf.ocl_1.0.1.v200611161546
feature-enable success
5 mars 2008 17:03:00 org.eclipse.emf.ocl.doc_1.0.1.v200611161546
feature-enable success
5 mars 2008 17:03:00 org.eclipse.emf.ocl.source_1.0.1.v200611161546
feature-enable success
5 mars 2008 17:03:00 org.eclipse.emf.ocl.sdk_1.0.1.v200611161546
feature-enable success


"zongheng" <zongheng@free.fr> a écrit dans le message de
news:fqm8n9$n9m$1@build.eclipse.org...
>I tried. Received an error message from the update site : "An exception
>occured while downloading feature from
>" http://download.eclipse.org/modeling/mdt/updates/features/or g.eclipse.ocl.uml.source_1.1.1.v200707131415-1007w3118182425 26.jar".
>
> oh well...
>
> "Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
> news:fqep8s$7us$1@build.eclipse.org...
>>I think OCL should be on the MDT update site, not the EMFT one these
>>days..
>>
>>
>> zongheng wrote:
>>> Thanks for replying but I installed version 3.3.2 from scratch and this
>>> time
>>> I encouter another problem :
>>>
>>> When updating and selecting only "EMFT Update site" , the search results
>>> dialog box lists no site no feature to install and says : " 0 of 15
>>> selected" ! Option "Show the latest version of a version only" is
>>> selected.
>>> When I deselect this option , the EMFT update site appears but not
>>> expandable, still with the " 0 of 15 selected" message, I can't see nor
>>> select any feature.
>>>
>>>
>>> "Ed Merks" <merks@ca.ibm.com> a écrit dans le message de
>>> news:fq634v$57k$1@build.eclipse.org...
>>>> It's best to ask on the OCL newsgroup, which I've added to the "to"
>>>> list of this reply.
>>>>
>>>> If you run eclipse.exe -clean -debug and look at the
>>>> <workspace>/.metadata/.log or the Error Log view, it will describe in
>>>> detail why plugins are failing to resolve, i.e, what dependencies they
>>>> have that aren't being met.
>>>>
>>>> If I look at their downloads page I can see that 1.0.x is for the
>>>> Eclipse 3.2 stream. So I think you need 1.1.x.
>>>>
>>>>
>>>> zongheng wrote:
>>>>> whenever I try to get emft with update manager, EMFT OCL SDK 1.0.1 is
>>>>> installed as "not configured properly" and with all 3 following
>>>>> features disabled :
>>>>> - EMFT OCL source
>>>>> - EMFT OCL 1.0.1
>>>>> - EMFT OCL documentation
>>>>>
>>>>> anyone get this problem already ?
>>>>>
>>>>
>>>
>>
>
>
Re: installation problem on 3.3.1.1 [message #52335 is a reply to message #52312] Wed, 05 March 2008 11:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: cdamus.ca.ibm.com

Hi, zongheng,

The error log that you quoted seems to indicate 100% success in installing
these new features. Odd. I don't understand the Update Manager.

Note that multiple versions of the OCL SDK cannot coexist. If you install
1.0.x and 1.1.x, then you will end up with only the 1.1.x version active in
your configuration.

For features that are disabled, you should be able to select them in the
Manage Configuration Dialog and follow the "Status" link in the panel on
the right side. What does this report?

Does launching eclipse again with the -clean argument help to clear up any
of these problems?

HTH,

Christian


zongheng wrote:

> Finally, I managed to update from a MDT update mirror site, to no avail :
>
> as before :
>
> EMFT OCL SDK 1.0.1 is installed as "not configured properly" and with all
> 3 following
> features disabled :
> - EMFT OCL source
> - EMFT OCL 1.0.1
> - EMFT OCL documentation
>
> plus :
>
> OCL 2.0 Extender SDK 1.1.1 disabled with sub-features
> - OCL end-user feature 1.1.1 disabled
> - OCL 2.0 Source 1.1.1 disabled
> other are enabled
>
> UML2 Tools disabled : all sub-features disabled
>
> Error log follows :
>

-----8<-----
Re: installation problem on 3.3.1.1-3.3.2 [message #52388 is a reply to message #52335] Thu, 06 March 2008 09:14 Go to previous messageGo to next message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
Thanks for replying.
After -cleanup :
I have only
* EMFT OCL SDK 1.0.1 installed (and "not configured properly" as in the
status information box, with all sub-features disabled), as before,
* OCL 2.0 Extender SDK 1.1.1 disabled with some sub-features disabled, as
before,
* * UML2 : 2 versions (did I miss this last time ?), one enabled, the other
disabled
- same feature version : 0.7.1
- sub-features in feature disabled is 0.7.1
- some sub-features in feature enabled is 0.7.101

..log in .metadata folder follows :

!SESSION 2008-03-05
18:27:07.927 -----------------------------------------------
eclipse.buildId=M20080221-1800
java.version=1.6.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86 -clean -debug

!ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.459
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
!MESSAGE Bundle
update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar was not
resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
!MESSAGE Bundle
update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar was not
resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.461
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.467
!MESSAGE The following is a complete list of bundles which are not resolved,
see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
!MESSAGE Bundle
update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar [230] was not
resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
[231] was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
[232] was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.ui_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.gdb_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
[233] was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
!MESSAGE Bundle
update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar [234] was not
resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
!MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
[235] was not resolved.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
!SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
!MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
!MESSAGE Bundle
update@plugins/org.eclipse.emf.ocl.doc_1.0.1.v200611161546.jar [352] was not
resolved.
!SUBENTRY 2 org.eclipse.emf.ocl.doc 2 0 2008-03-05 18:27:52.469
!MESSAGE Another singleton version selected:
org.eclipse.emf.ocl.doc_1.1.0.v200706071450
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
!MESSAGE Bundle
update@plugins/org.eclipse.emf.ocl.examples_1.0.1.v200611161546.jar [356]
was not resolved.
!SUBENTRY 2 org.eclipse.emf.ocl.examples 2 0 2008-03-05 18:27:52.469
!MESSAGE Another singleton version selected:
org.eclipse.emf.ocl.examples_1.1.0.v200706071450
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
!MESSAGE Bundle
update@plugins/org.eclipse.emf.ocl.source_1.0.1.v200611161546/ [358] was not
resolved.
!SUBENTRY 2 org.eclipse.emf.ocl.source 2 0 2008-03-05 18:27:52.470
!MESSAGE Another singleton version selected:
org.eclipse.emf.ocl.source_1.1.1.v200709121956-1007w31181_23 2_67
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.470
!MESSAGE Bundle update@plugins/org.eclipse.emf.ocl_1.0.1.v200611161546.jar
[360] was not resolved.
!SUBENTRY 2 org.eclipse.emf.ocl 2 0 2008-03-05 18:27:52.470
!MESSAGE Another singleton version selected:
org.eclipse.emf.ocl_1.1.1.v200709121956

!ENTRY org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMenu/org.e clipse.eclipsemonkey.action4':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.eclipsemon key.emFileContextMenu/org.eclipse.eclipsemonkey.action4,
handler=ActionDelegateHandlerProxy(null,org.eclipse.eclipsem onkey.actions.PublishScriptForWiki),expression=WorkbenchWind owExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action4,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForWiki),expre ssion=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action5':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action5,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc ript),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action5,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScript),expression=W orkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action2':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action2,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForBlogger),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action2,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForBlogger),ex pression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action6':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action6,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForEmail),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action6,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForEmail),expr ession=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!ENTRY org.eclipse.osgi 2 0 2008-03-0518:28:10.541!MESSAGE While loadingclass" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re ",thread"Thread[main,6,main]" timed out waiting (5000ms) forthread"Thread[Worker-0,5,main]" to finish startingbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar[633]".To avoid deadlock, thread "Thread[main,6,main]" is proceedingbut" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re " may notbefully initialized.!STACK 0org.osgi.framework.BundleException: State changein progress forbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar"bythread "Worker-0" .atorg.eclipse.osgi.framework.internal.core.AbstractBundle.b eginStateChange(AbstractBundle.java:1141)atorg.eclipse.osgi. framework.internal.core.AbstractBundle.start(AbstractBundle. java:258)atorg.eclipse.osgi.framework.util.SecureAction$21.r un(SecureAction.java:406)at java.security.AccessController.doPrivileged(Native Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83) at java.lang.ClassLoader.loadClass(Unknown Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659) atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296) atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389) atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3) atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219) atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) atjava.lang.reflect.Method.invoke(Unknown Source) atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508) atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447) atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)Cause dby:org.eclipse.osgi.framework.internal.core.AbstractBundle$ BundleStatusException ... 53 moreRootexception:org.eclipse.osgi.framework.internal.core.A bstractBundle$BundleStatusExceptionatorg.eclipse.osgi.framew ork.internal.core.AbstractBundle.beginStateChange(AbstractBu ndle.java:1141)atorg.eclipse.osgi.framework.internal.core.Ab stractBundle.start(AbstractBundle.java:258)atorg.eclipse.osg i.framework.util.SecureAction$21.run(SecureAction.java:406)a t java.security.AccessController.doPrivileged(Native Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83) at java.lang.ClassLoader.loadClass(Unknown Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659) atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296) atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389) atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3) atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219) atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) atjava.lang.reflect.Method.invoke(Unknown Source) atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508) atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447) atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)"Christian W. Damus" <cdamus@ca.ibm.com> a écrit dans le message denews:fqmj1l$em8$1@build.eclipse.org...> Hi, zongheng,>> The error log that you quoted seems to indicate 100% success in installing> these new features. Odd. I don't understand the Update Manager.>> Note that multiple versions of the OCL SDK cannot coexist. If you install> 1.0.x and 1.1.x, then you will end up with only the 1.1.x version activein> your configuration.>> For features that are disabled, you should be able to select them in the> Manage Configuration Dialog and follow the "Status" link in the panel on> the right side. What does this report?>> Does launching eclipse again with the -clean argument help to clear up any> of these problems?>> HTH,>> Christian>>> zongheng wrote:>>> Finally, I managed to update from a MDT update mirror site, to no avail :>>>> as before :>>>> EMFT OCL SDK 1.0.1 is installed as "not configured properly" and withall>> 3 following>> features disabled :>> - EMFT OCL source>> - EMFT OCL 1.0.1>> - EMFT OCL documentation>>>> plus :>>>> OCL 2.0 Extender SDK 1.1.1 disabled with sub-features>> - OCL end-user feature 1.1.1 disabled>> - OCL 2.0 Source 1.1.1 disabled>> other are enabled>>>> UML2 Tools disabled : all sub-features disabled>>>> Error log follows :>>>> -----8<----->
Re: installation problem on 3.3.1.1-3.3.2 [message #53269 is a reply to message #52388] Tue, 25 March 2008 12:39 Go to previous messageGo to next message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
Can anyone reproduce this problem ?

configuration management tool still lists this :

Eclipse Modeling Framework Technology OCL SDK version "1.0.1.v200611161546"
: The feature is not configured properly.
Reason :
Included feature "Eclipse Modeling Framework Technology OCL" version
"1.0.1.v200611161546" is disabled.

Included feature "Eclipse Modeling Framework Technology OCL Documentation"
version "1.0.1.v200611161546" is disabled.

Included feature "Eclipse Modeling Framework Technology (EMFT) OCL Source"
version "1.0.1.v200611161546" is disabled.

"zongheng" <zongheng@free.fr> a écrit dans le message de
news:fqou7n$rn$1@build.eclipse.org...
> Thanks for replying.
> After -cleanup :
> I have only
> * EMFT OCL SDK 1.0.1 installed (and "not configured properly" as in the
> status information box, with all sub-features disabled), as before,
> * OCL 2.0 Extender SDK 1.1.1 disabled with some sub-features disabled, as
> before,
> * * UML2 : 2 versions (did I miss this last time ?), one enabled, the
> other
> disabled
> - same feature version : 0.7.1
> - sub-features in feature disabled is 0.7.1
> - some sub-features in feature enabled is 0.7.101
>
> .log in .metadata folder follows :
>
> !SESSION 2008-03-05
> 18:27:07.927 -----------------------------------------------
> eclipse.buildId=M20080221-1800
> java.version=1.6.0_04
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
> Command-line arguments: -os win32 -ws win32 -arch x86 -clean -debug
>
> !ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.459
> !MESSAGE One or more bundles are not resolved because the following root
> constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar was not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar was not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
>
> !ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.467
> !MESSAGE The following is a complete list of bundles which are not
> resolved,
> see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar [230] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
> [231] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
> [232] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.ui_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.gdb_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
> [233] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar [234] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
> [235] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.doc_1.0.1.v200611161546.jar [352] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.doc 2 0 2008-03-05 18:27:52.469
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.doc_1.1.0.v200706071450
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.examples_1.0.1.v200611161546.jar [356]
> was not resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.examples 2 0 2008-03-05 18:27:52.469
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.examples_1.1.0.v200706071450
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.source_1.0.1.v200611161546/ [358] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.source 2 0 2008-03-05 18:27:52.470
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.source_1.1.1.v200709121956-1007w31181_23 2_67
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.470
> !MESSAGE Bundle update@plugins/org.eclipse.emf.ocl_1.0.1.v200611161546.jar
> [360] was not resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl 2 0 2008-03-05 18:27:52.470
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl_1.1.1.v200709121956
>
> !ENTRY org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMenu/org.e clipse.eclipsemonkey.action4':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.eclipsemon key.emFileContextMenu/org.eclipse.eclipsemonkey.action4,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.eclipsem onkey.actions.PublishScriptForWiki),expression=WorkbenchWind owExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action4,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForWiki),expre ssion=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action5':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action5,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc ript),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action5,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScript),expression=W orkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action2':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action2,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForBlogger),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action2,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForBlogger),ex pression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action6':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action6,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForEmail),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action6,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForEmail),expr ession=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!ENTRY
> org.eclipse.osgi 2 0 2008-03-0518:28:10.541!MESSAGE While
> loadingclass" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re ",thread"Thread[main,6,main]"
> timed out waiting (5000ms) forthread"Thread[Worker-0,5,main]" to finish
> startingbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar[633]".To
> avoid deadlock, thread "Thread[main,6,main]" is
> proceedingbut" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re "
> may notbefully initialized.!STACK 0org.osgi.framework.BundleException:
> State changein progress
> forbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar"bythread
> "Worker-0" .atorg.eclipse.osgi.framework.internal.core.AbstractBundle.b eginStateChange(AbstractBundle.java:1141)atorg.eclipse.osgi. framework.internal.core.AbstractBundle.start(AbstractBundle. java:258)atorg.eclipse.osgi.framework.util.SecureAction$21.r un(SecureAction.java:406)at
> java.security.AccessController.doPrivileged(Native
> Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83)
> at java.lang.ClassLoader.loadClass(Unknown
> Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
> at
> org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129)
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
> atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296)
> atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389)
> atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3)
> atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219)
> atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> atjava.lang.reflect.Method.invoke(Unknown Source)
> atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508)
> atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)Cause dby:org.eclipse.osgi.framework.internal.core.AbstractBundle$ BundleStatusException
> ... 53
> moreRootexception:org.eclipse.osgi.framework.internal.core.A bstractBundle$BundleStatusExceptionatorg.eclipse.osgi.framew ork.internal.core.AbstractBundle.beginStateChange(AbstractBu ndle.java:1141)atorg.eclipse.osgi.framework.internal.core.Ab stractBundle.start(AbstractBundle.java:258)atorg.eclipse.osg i.framework.util.SecureAction$21.run(SecureAction.java:406)a t
> java.security.AccessController.doPrivileged(Native
> Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83)
> at java.lang.ClassLoader.loadClass(Unknown
> Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
> at
> org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129)
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
> atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296)
> atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389)
> atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3)
> atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219)
> atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> atjava.lang.reflect.Method.invoke(Unknown Source)
> atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508)
> atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)"Christian W.
> Damus" <cdamus@ca.ibm.com> a écrit dans le message
> denews:fqmj1l$em8$1@build.eclipse.org...> Hi, zongheng,>> The error log
> that you quoted seems to indicate 100% success in installing> these new
> features. Odd. I don't understand the Update Manager.>> Note that
> multiple versions of the OCL SDK cannot coexist. If you install> 1.0.x
> and 1.1.x, then you will end up with only the 1.1.x version activein> your
> configuration.>> For features that are disabled, you should be able to
> select them in the> Manage Configuration Dialog and follow the "Status"
> link in the panel on> the right side. What does this report?>> Does
> launching eclipse again with the -clean argument help to clear up any> of
> these problems?>> HTH,>> Christian>>> zongheng wrote:>>> Finally, I
> managed to update from a MDT update mirror site, to no avail :>>>> as
> before :>>>> EMFT OCL SDK 1.0.1 is installed as "not configured properly"
> and withall>> 3 following>> features disabled :>> - EMFT OCL source>> -
> EMFT OCL 1.0.1>> - EMFT OCL documentation>>>> plus :>>>> OCL 2.0 Extender
> SDK 1.1.1 disabled with sub-features>> - OCL end-user feature 1.1.1
> disabled>> - OCL 2.0 Source 1.1.1 disabled>> other are enabled>>>> UML2
> Tools disabled : all sub-features disabled>>>> Error log follows
> :>>>> -----8<----->
Re: installation problem on 3.3.1.1-3.3.2 [message #53297 is a reply to message #52388] Tue, 25 March 2008 12:40 Go to previous message
Zongheng is currently offline Zongheng
Messages: 27
Registered: July 2009
Junior Member
Can anyone reproduce this problem ?

configuration management tool still lists this :

Eclipse Modeling Framework Technology OCL SDK version "1.0.1.v200611161546"
: The feature is not configured properly.
Reason :
Included feature "Eclipse Modeling Framework Technology OCL" version
"1.0.1.v200611161546" is disabled.

Included feature "Eclipse Modeling Framework Technology OCL Documentation"
version "1.0.1.v200611161546" is disabled.

Included feature "Eclipse Modeling Framework Technology (EMFT) OCL Source"
version "1.0.1.v200611161546" is disabled.

"zongheng" <zongheng@free.fr> a écrit dans le message de
news:fqou7n$rn$1@build.eclipse.org...
> Thanks for replying.
> After -cleanup :
> I have only
> * EMFT OCL SDK 1.0.1 installed (and "not configured properly" as in the
> status information box, with all sub-features disabled), as before,
> * OCL 2.0 Extender SDK 1.1.1 disabled with some sub-features disabled, as
> before,
> * * UML2 : 2 versions (did I miss this last time ?), one enabled, the
> other
> disabled
> - same feature version : 0.7.1
> - sub-features in feature disabled is 0.7.1
> - some sub-features in feature enabled is 0.7.101
>
> .log in .metadata folder follows :
>
> !SESSION 2008-03-05
> 18:27:07.927 -----------------------------------------------
> eclipse.buildId=M20080221-1800
> java.version=1.6.0_04
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
> Command-line arguments: -os win32 -ws win32 -arch x86 -clean -debug
>
> !ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.459
> !MESSAGE One or more bundles are not resolved because the following root
> constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.460
> !MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.460
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar was not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar was not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.461
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.461
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
>
> !ENTRY org.eclipse.osgi 2 0 2008-03-05 18:27:52.467
> !MESSAGE The following is a complete list of bundles which are not
> resolved,
> see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug.ui_0.9.0.v20070615.jar [230] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.debug_0.9.0.v20070615.jar
> [231] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.debug 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.gdb.ui_0.9.0.v20070615.jar
> [232] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.ui_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb.ui 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.gdb_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.468
> !MESSAGE Bundle update@plugins/org.eclipse.dd.dsf.gdb_0.9.0.v20070615.jar
> [233] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.468
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.gdb 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.mi.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.core_0.9.0.v20070615.jar [234] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.core 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.dd.dsf.mi.ui_0.9.0.v20070615.jar
> [235] was not resolved.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.mi.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.launch_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.cdt.debug.core_0.0.0.
> !SUBENTRY 2 org.eclipse.dd.dsf.mi.ui 2 0 2008-03-05 18:27:52.469
> !MESSAGE Missing required bundle org.eclipse.dd.dsf.debug.ui_0.0.0.
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.doc_1.0.1.v200611161546.jar [352] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.doc 2 0 2008-03-05 18:27:52.469
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.doc_1.1.0.v200706071450
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.examples_1.0.1.v200611161546.jar [356]
> was not resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.examples 2 0 2008-03-05 18:27:52.469
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.examples_1.1.0.v200706071450
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.469
> !MESSAGE Bundle
> update@plugins/org.eclipse.emf.ocl.source_1.0.1.v200611161546/ [358] was
> not
> resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl.source 2 0 2008-03-05 18:27:52.470
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl.source_1.1.1.v200709121956-1007w31181_23 2_67
> !SUBENTRY 1 org.eclipse.osgi 2 0 2008-03-05 18:27:52.470
> !MESSAGE Bundle update@plugins/org.eclipse.emf.ocl_1.0.1.v200611161546.jar
> [360] was not resolved.
> !SUBENTRY 2 org.eclipse.emf.ocl 2 0 2008-03-05 18:27:52.470
> !MESSAGE Another singleton version selected:
> org.eclipse.emf.ocl_1.1.1.v200709121956
>
> !ENTRY org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2008-03-05 18:28:03.458
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMenu/org.e clipse.eclipsemonkey.action4':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.eclipsemon key.emFileContextMenu/org.eclipse.eclipsemonkey.action4,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.eclipsem onkey.actions.PublishScriptForWiki),expression=WorkbenchWind owExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action4,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForWiki),expre ssion=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action5':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action5,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc ript),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action5,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScript),expression=W orkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action2':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action2,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForBlogger),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action2,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForBlogger),ex pression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!SUBENTRY
> 1 org.eclipse.ui.workbench 2 02008-03-05 18:28:03.458!MESSAGE
> Conflictfor'AUTOGEN:::org.eclipse.eclipsemonkey.emFileContex tMenu/org.eclipse.eclipsemonkey.action6':HandlerActivation(c ommandId=AUTOGEN:::org.eclipse.eclipsemonkey.emFileContextMe nu/org.eclipse.eclipsemonkey.action6,handler=ActionDelegateH andlerProxy(null,org.eclipse.eclipsemonkey.actions.PublishSc riptForEmail),expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574 ),sourcePriority=16384)HandlerActivation(commandId=AUTOGEN:: :org.eclipse.eclipsemonkey.emFileContextMenu/org.eclipse.ecl ipsemonkey.action6,handler=ActionDelegateHandlerProxy(null,o rg.eclipse.eclipsemonkey.actions.PublishScriptForEmail),expr ession=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@154b574),sourcePriority=16384)!ENTRY
> org.eclipse.osgi 2 0 2008-03-0518:28:10.541!MESSAGE While
> loadingclass" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re ",thread"Thread[main,6,main]"
> timed out waiting (5000ms) forthread"Thread[Worker-0,5,main]" to finish
> startingbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar[633]".To
> avoid deadlock, thread "Thread[main,6,main]" is
> proceedingbut" org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextSto re "
> may notbefully initialized.!STACK 0org.osgi.framework.BundleException:
> State changein progress
> forbundle"update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar"bythread
> "Worker-0" .atorg.eclipse.osgi.framework.internal.core.AbstractBundle.b eginStateChange(AbstractBundle.java:1141)atorg.eclipse.osgi. framework.internal.core.AbstractBundle.start(AbstractBundle. java:258)atorg.eclipse.osgi.framework.util.SecureAction$21.r un(SecureAction.java:406)at
> java.security.AccessController.doPrivileged(Native
> Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83)
> at java.lang.ClassLoader.loadClass(Unknown
> Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
> at
> org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129)
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
> atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296)
> atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389)
> atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3)
> atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219)
> atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> atjava.lang.reflect.Method.invoke(Unknown Source)
> atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508)
> atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)Cause dby:org.eclipse.osgi.framework.internal.core.AbstractBundle$ BundleStatusException
> ... 53
> moreRootexception:org.eclipse.osgi.framework.internal.core.A bstractBundle$BundleStatusExceptionatorg.eclipse.osgi.framew ork.internal.core.AbstractBundle.beginStateChange(AbstractBu ndle.java:1141)atorg.eclipse.osgi.framework.internal.core.Ab stractBundle.start(AbstractBundle.java:258)atorg.eclipse.osg i.framework.util.SecureAction$21.run(SecureAction.java:406)a t
> java.security.AccessController.doPrivileged(Native
> Method)atorg.eclipse.osgi.framework.util.SecureAction.start( SecureAction.java:404)atorg.eclipse.core.runtime.internal.ad aptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStart er.java:111)atorg.eclipse.osgi.baseadaptor.loader.ClasspathM anager.findLocalClass(ClasspathManager.java:417)atorg.eclips e.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClas s(DefaultClassLoader.java:189)atorg.eclipse.osgi.framework.i nternal.core.BundleLoader.findLocalClass(BundleLoader.java:3 40)atorg.eclipse.osgi.framework.internal.core.BundleLoader.f indClassInternal(BundleLoader.java:408)atorg.eclipse.osgi.fr amework.internal.core.BundleLoader.findClass(BundleLoader.ja va:369)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.findClass(BundleLoader.java:357)atorg.eclipse.osgi.intern al.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoad er.java:83)
> at java.lang.ClassLoader.loadClass(Unknown
> Source)atorg.eclipse.osgi.framework.internal.core.BundleLoad er.loadClass(BundleLoader.java:289)atorg.eclipse.osgi.framew ork.internal.core.BundleHost.loadClass(BundleHost.java:227)a torg.eclipse.osgi.framework.internal.core.AbstractBundle.loa dClass(AbstractBundle.java:1269)atorg.eclipse.core.internal. registry.osgi.RegistryStrategyOSGI.createExecutableExtension (RegistryStrategyOSGI.java:160)atorg.eclipse.core.internal.r egistry.ExtensionRegistry.createExecutableExtension(Extensio nRegistry.java:788)atorg.eclipse.core.internal.registry.Conf igurationElement.createExecutableExtension(ConfigurationElem ent.java:243)atorg.eclipse.core.internal.registry.Configurat ionElementHandle.createExecutableExtension(ConfigurationElem entHandle.java:51)atorg.eclipse.mylyn.context.core.ContextCo rePlugin$ContextStoreExtensionReader.readStore(ContextCorePl ugin.java:282)atorg.eclipse.mylyn.context.core.ContextCorePl ugin$ContextStoreExtensionReader.initExtensions(ContextCoreP lugin.java:271)atorg.eclipse.mylyn.context.core.ContextCoreP lugin.getContextStore(ContextCorePlugin.java:242)atorg.eclip se.mylyn.internal.context.core.InteractionContextManager.loa dActivityMetaContext(InteractionContextManager.java:138)ator g.eclipse.mylyn.internal.context.core.InteractionContextMana ger.getActivityMetaContext(InteractionContextManager.java:13 2)atorg.eclipse.mylyn.internal.context.core.InteractionConte xtManager.processActivityMetaContextEvent(InteractionContext Manager.java:177)atorg.eclipse.mylyn.internal.monitor.ui.She llLifecycleListener. <init> (ShellLifecycleListener.java:35)atorg.eclipse.mylyn.monitor. ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
> at
> org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)atorg.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Sy nchronizer.java:129)
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
> atorg.eclipse.swt.widgets.Display.readAndDispatch(Display.ja va:3296)
> atorg.eclipse.ui.internal.Workbench.runEventLoop(Workbench.j ava:2389)
> atorg.eclipse.ui.internal.Workbench.runUI(Workbench.java:235 3)
> atorg.eclipse.ui.internal.Workbench.access$4(Workbench.java: 2219)
> atorg.eclipse.ui.internal.Workbench$4.run(Workbench.java:466 )atorg.eclipse.core.databinding.observable.Realm.runWithDefa ult(Realm.java:289)atorg.eclipse.ui.internal.Workbench.creat eAndRunWorkbench(Workbench.java:461)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)atorg.eclipse.ui.internal.ide.application.IDEApplica tion.start(IDEApplication.java:106)atorg.eclipse.equinox.int ernal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)ato rg.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. runApplication(EclipseAppLauncher.java:106)atorg.eclipse.cor e.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseA ppLauncher.java:76)atorg.eclipse.core.runtime.adaptor.Eclips eStarter.run(EclipseStarter.java:363)atorg.eclipse.core.runt ime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> atsun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> atsun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> atjava.lang.reflect.Method.invoke(Unknown Source)
> atorg.eclipse.equinox.launcher.Main.invokeFramework(Main.jav a:508)
> atorg.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> atorg.eclipse.equinox.launcher.Main.run(Main.java:1173)"Christian W.
> Damus" <cdamus@ca.ibm.com> a écrit dans le message
> denews:fqmj1l$em8$1@build.eclipse.org...> Hi, zongheng,>> The error log
> that you quoted seems to indicate 100% success in installing> these new
> features. Odd. I don't understand the Update Manager.>> Note that
> multiple versions of the OCL SDK cannot coexist. If you install> 1.0.x
> and 1.1.x, then you will end up with only the 1.1.x version activein> your
> configuration.>> For features that are disabled, you should be able to
> select them in the> Manage Configuration Dialog and follow the "Status"
> link in the panel on> the right side. What does this report?>> Does
> launching eclipse again with the -clean argument help to clear up any> of
> these problems?>> HTH,>> Christian>>> zongheng wrote:>>> Finally, I
> managed to update from a MDT update mirror site, to no avail :>>>> as
> before :>>>> EMFT OCL SDK 1.0.1 is installed as "not configured properly"
> and withall>> 3 following>> features disabled :>> - EMFT OCL source>> -
> EMFT OCL 1.0.1>> - EMFT OCL documentation>>>> plus :>>>> OCL 2.0 Extender
> SDK 1.1.1 disabled with sub-features>> - OCL end-user feature 1.1.1
> disabled>> - OCL 2.0 Source 1.1.1 disabled>> other are enabled>>>> UML2
> Tools disabled : all sub-features disabled>>>> Error log follows
> :>>>> -----8<----->
Previous Topic:validate applied to umleditor
Next Topic:Adding new operations to the String primitive datatype
Goto Forum:
  


Current Time: Thu Jul 24 16:08:07 EDT 2014

Powered by FUDForum. Page generated in 0.01936 seconds