Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Cannot enter URL for new location
Cannot enter URL for new location [message #506665] Fri, 08 January 2010 15:31 Go to next message
Marc Schlegel is currently offline Marc SchlegelFriend
Messages: 92
Registered: July 2009
Member
Hello Everyone

I am using Eclipse 3.5 with subversive and the latest official SVNKit (1.3).
I have the weird problem that when I open the dialog for a new Location,
the URL field is completely disabled, so I cannot enter any repository?
Of course the dialog complains about a missing url.

Any ideas.

btw: I am running on OpenSuse 11.2 x64

Thanks in advance
Re: Cannot enter URL for new location [message #506858 is a reply to message #506665] Mon, 11 January 2010 07:47 Go to previous messageGo to next message
Yuriy Malchenko is currently offline Yuriy MalchenkoFriend
Messages: 7
Registered: July 2009
Junior Member
Hi!

I have 64-bit openSUSE 11.2 as well, and I'm having the exact same problem (although I use subclipse). The URL field is grayed out, either I choose to use pure java connector or JNI (I added "-Djava.library.path=/usr/lib64" to eclipse.ini, so it loads successfully). It happens with a fresh new unzipped eclipse (jee/php) and a new workspace (as well as with some existing ones).

Also, I have one existing workspace on which it works fine, I'm able to input an URL and create a repository location. But if I use that eclipse "instance" with another workspace (or the new one) - the field is grayed out again.


P.S.
I just faced another issue - both input fields in the Find dialog (ctrl+f) are disabled, too. So this might be not the subversion-related issue.

(Un)setting GDK_NATIVE_WINDOWS does not affect.

[Updated on: Mon, 11 January 2010 08:50]

Report message to a moderator

Re: Cannot enter URL for new location [message #506888 is a reply to message #506858] Mon, 11 January 2010 09:11 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello,

Please, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=295685

> Hi!
>
> I have openSUSE 11.2 as well and I'm having the exact same problem with
> subclipse. The URL field is grayed out, either I choose to use pure java
> connector or JNI (I added "-Djava.library.path=/usr/lib64" to eclipse.ini,
> so it loads successfuly). It happens with a fresh new unzipped eclipse
> (jee/php) and a new workspace (as well as with some existing ones).
>
> Also, I have one existing workspace on which it works fine, I'm able to
> input an URL and create a repository location. But if I use that eclipse
> "instance" with another workspace (or the new one) - the field is grayed
> out again.
Re: Cannot enter URL for new location [message #506920 is a reply to message #506665] Mon, 11 January 2010 11:06 Go to previous messageGo to next message
Yuriy Malchenko is currently offline Yuriy MalchenkoFriend
Messages: 7
Registered: July 2009
Junior Member
Igor, thanks a lot!

Although changing GTK theme doesn't seem to help.

p.s. Upgrading qtcurve to 0.69.2 fixed the issue.
( http://software.opensuse.org/ymp/KDE:Backports/openSUSE_11.2 /qtcurve-gtk2.ymp)

[Updated on: Mon, 11 January 2010 11:54]

Report message to a moderator

Re: Cannot enter URL for new location [message #507121 is a reply to message #506920] Tue, 12 January 2010 08:59 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello Yuriy,

Did you try a proposed workaround in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=295685, see comments 4 and 8?

> Igor, thanks a lot!
>
> Although changing GTK theme doesn't seem to help.
Re: Cannot enter URL for new location [message #507143 is a reply to message #507121] Tue, 12 January 2010 10:16 Go to previous messageGo to next message
Yuriy Malchenko is currently offline Yuriy MalchenkoFriend
Messages: 7
Registered: July 2009
Junior Member
Igor Burilo wrote on Tue, 12 January 2010 03:59
Hello Yuriy,

Did you try a proposed workaround in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=295685, see comments 4 and 8?



Well, it seems to be the case with that workspace I mentioned:
Quote:
I have one existing workspace on which it works fine, I'm able to input an URL and create a repository location


In this case history for the combo-box exists, so it does not get disabled.

But in general, I just upgraded to the newer qucurve for GTK2.

I'm guessing you could miss my update to the post:
Quote:
p.s. Upgrading qtcurve to 0.69.2 fixed the issue.


Now everything works fine Smile. Thanks again for pointing to bugzilla.
Re: Cannot enter URL for new location [message #507190 is a reply to message #507143] Tue, 12 January 2010 12:58 Go to previous message
Marc Schlegel is currently offline Marc SchlegelFriend
Messages: 92
Registered: July 2009
Member
Am 12.01.2010 11:16, schrieb Yuriy Malchenko:
> Igor Burilo wrote on Tue, 12 January 2010 03:59
>> p.s. Upgrading qtcurve to 0.69.2 fixed the issue.

Thanks for the responses. This fixed the problem.
I am more and more looking forward to a qt-port of SWT...
Previous Topic:SVN Console not activeated?
Next Topic:Missing example date in prefs?
Goto Forum:
  


Current Time: Sun Dec 21 22:23:57 GMT 2014

Powered by FUDForum. Page generated in 0.03076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software