Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » P2 dev » Problem with eclipse.ini and plugins installation
Problem with eclipse.ini and plugins installation [message #506478] Thu, 07 January 2010 11:30
Michal Niewrzal is currently offline Michal Niewrzal
Messages: 23
Registered: July 2009
Junior Member
Hi,
I have problem probably with p2:) In my product I've changed eclipse.ini into myfile.ini. I've changed also entry in config.ini. Everything works works fine without one element. When new plugin is installed something is creating new empty eclipse.ini file. When this empty file exist there is no way to install something and eclipse throw error:
An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.Install, operand=null --> [R]de.babe.eclipse.features.QuickREx_I18N.feature.jar 1.0.0, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.ac tions.InstallFeatureAction).
Error while loading manipulator.
Error while loading manipulator.

I noticed that file is created at the end of plugin installation process. When file is deleted installation mechanism works ok, but after any installation file eclipse.ini is always created. I'm using Eclipse 3.5.1.

I will be grateful for any help Smile
Previous Topic:p2.repo2runnable questions
Next Topic:how to remove plugin file after a succesful p2 update
Goto Forum:
  


Current Time: Tue Sep 02 07:57:39 EDT 2014

Powered by FUDForum. Page generated in 0.01620 seconds