Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » javax.persistence api 2.0 for maven
javax.persistence api 2.0 for maven [message #506448] Thu, 07 January 2010 09:50 Go to next message
Marc Schlegel is currently offline Marc Schlegel
Messages: 92
Registered: July 2009
Member
Hello Everyone

I am moving to JPA 2 using Eclipselink and with my RCP app this went
just fine. All I didn was droping the 2.2 release in the eclipse plugin
folder and changed the version in the MANIFESt.

Now I would like to use the same for a webapp as well, and to learn more
about Maven I am using this as a build-tool as well.

My problem now is, that I cannot get the JPA-API in version 2.0 for my
dependencies.

<dependency>
<groupid>javax.persistence</groupid>
<artifactid>persistence-api</artifactid>
<version>1.0</version>
</dependency>

This works, but when I change the version to 2.0 it cannot be resolved.
I think I need an updated API to make use of all the annotations and so
forth in my model-project.

Does anyone know how to achieve this?

By the way: And the eclipselink jars can also not be resolved (not 2.2.0
nor 2.1.2). Do I need to add a special repository? The posts I found
were quite old and the repository provided by eclipse.org is dead.

Thanks in advance
Marc
Re: javax.persistence api 2.0 for maven [message #506543 is a reply to message #506448] Thu, 07 January 2010 17:08 Go to previous messageGo to next message
beamso is currently offline beamso
Messages: 7
Registered: January 2010
Junior Member
I'm using (from the jboss repository) :
<dependency>
<groupId>org.hibernate.java-persistence</groupId>
<artifactId>jpa-api</artifactId>
<version>2.0-cr-1</version>
</dependency>

in the eclipse maven repository, there is :
<dependency>
<groupId>javax.persistence</groupId>
<artifactId>javax.persistence</artifactId>
<version>2.0-SNAPSHOT</version>
</dependency>

It's interesting that the non-osgi eclipselink jar doesn't reference the JPA v2 API in it's POM.
Re: javax.persistence api 2.0 for maven [message #506637 is a reply to message #506543] Fri, 08 January 2010 03:02 Go to previous messageGo to next message
Marc Schlegel is currently offline Marc Schlegel
Messages: 92
Registered: July 2009
Member
Am 07.01.2010 23:09, schrieb beamso:
> I'm using (from the jboss repository) :
> <dependency>
> <groupId>org.hibernate.java-persistence</groupId>
> <artifactId>jpa-api</artifactId>
> <version>2.0-cr-1</version>
> </dependency>
>
> in the eclipse maven repository, there is : <dependency>
> <groupId>javax.persistence</groupId>
> <artifactId>javax.persistence</artifactId>
> <version>2.0-SNAPSHOT</version>
> </dependency>
>
> It's interesting that the non-osgi eclipselink jar doesn't reference the
> JPA v2 API in it's POM.


Thanks, I used the hibernate ones (the second approach seemed not to
work). I hope there will be an official release in suns repo.

regards
Re: javax.persistence api 2.0 for maven [message #506914 is a reply to message #506637] Mon, 11 January 2010 00:36 Go to previous messageGo to next message
Ari Meyer is currently offline Ari Meyer
Messages: 136
Registered: July 2009
Senior Member
Here's mine, as an alternative:

<dependency>
<groupId>org.eclipse.persistence</groupId>
<artifactId>eclipselink</artifactId>
<version>2.0.0</version>
</dependency>

<dependency>
<groupId>org.eclipse.persistence</groupId>
<artifactId>javax.persistence</artifactId>
<version>2.0.0</version>
</dependency>



<repositories>
<repository>
<id>EclipseLink Repo</id>

<url>http://www.eclipse.org/downloads/download.php?r=1&amp;nf=1&amp;file=/rt/eclipselink/maven.repo</url>
</repository>
</repositories>


Best regards,
Ari

Marc Schlegel wrote:
> Am 07.01.2010 23:09, schrieb beamso:
>> I'm using (from the jboss repository) :
>> <dependency>
>> <groupId>org.hibernate.java-persistence</groupId>
>> <artifactId>jpa-api</artifactId>
>> <version>2.0-cr-1</version>
>> </dependency>
>>
>> in the eclipse maven repository, there is : <dependency>
>> <groupId>javax.persistence</groupId>
>> <artifactId>javax.persistence</artifactId>
>> <version>2.0-SNAPSHOT</version>
>> </dependency>
>>
>> It's interesting that the non-osgi eclipselink jar doesn't reference the
>> JPA v2 API in it's POM.
>
>
> Thanks, I used the hibernate ones (the second approach seemed not to
> work). I hope there will be an official release in suns repo.
>
> regards
Re: javax.persistence api 2.0 for maven [message #546609 is a reply to message #506448] Tue, 13 July 2010 10:27 Go to previous message
No real name is currently offline No real name
Messages: 5
Registered: July 2010
Junior Member
This url appears to be obsolete: http://www.eclipse.org/downloads/download.php?r=1&amp;nf=1&amp;file=/rt/eclipselink/maven.repo What is the best maven repository for eclipselink?
Previous Topic:oracle database trigger and INSERT problem
Next Topic:Rollback in transaction causes BlazeDS 3.x to invoke ClassDescriptor.getInheritancePolicy()
Goto Forum:
  


Current Time: Sat Jul 26 09:20:50 EDT 2014

Powered by FUDForum. Page generated in 0.01609 seconds