Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Incomplete EAR creation/deloyment
Incomplete EAR creation/deloyment [message #505422] Wed, 30 December 2009 08:41 Go to next message
No real name is currently offline No real name
Messages: 4
Registered: December 2009
Junior Member
Hi

I posted this on newcomers, but I got no answer and was told to post here. This is my original topic:

I was using Eclipse Ganymede (3.4.2) in a web project I'm developing. Due to some annoying errors (plugin stuff), I decided to reinstall Eclipse, so I got the latest version Galileo yesterday. I extracted it to other folder, and pointed it to the same workspace of the Ganymede version. Everything opened nice and clean, and I just installed again one missing plugins that I needed, nothing else, not even configuration changes.

My project EAR should contain two WARs and a JAR library, all of them are different projects in my workspace, part of the system I'm developing. What's going wrong is that my EAR deployments (directly to JBoss, just like I was doing with Ganymede) are always incomplete, as it always include just the packed file (JAR/WAR) of a project if it was changed since last deploy.

Example: if I update my JAR project and my first WAR project, only these files will be inside my deployed EAR, and the second WAR will be missing. Again updating the first WAR project and deploying will make this WAR as the only file inside the EAR (aside from META-INF folder and its contents). If I request an EAR deployment (Export > EAR File), it is always created correctly.

I changed absolutely no configuration from Galileo and used the very same workspace from Ganymede, so I don't know what is doing this. Should be some very silly detail, but Google couldn't help me, so I hope someone around can.

Thanks!
Re: Incomplete EAR creation/deloyment [message #505501 is a reply to message #505422] Thu, 31 December 2009 12:33 Go to previous messageGo to next message
Wolfgang Knauf is currently offline Wolfgang Knauf
Messages: 63
Registered: July 2009
Member
Hi,

this sounds a bit like this bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=283184
But this one should be fixed in 3.5.1.

Maybe someone from the developers can comment on this?

Best regards

Wolfgang
Re: Incomplete EAR creation/deloyment [message #505519 is a reply to message #505501] Thu, 31 December 2009 12:21 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 4
Registered: December 2009
Junior Member
Yes, it perfectly describes my situation, sounds like the same bug.

Isn't this fixed? Any fix soon?

Thanks!
Re: Incomplete EAR creation/deloyment [message #506592 is a reply to message #505519] Fri, 08 January 2010 09:08 Go to previous message
Wolfgang Knauf is currently offline Wolfgang Knauf
Messages: 63
Registered: July 2009
Member
Hi,

bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=283184 is fixed. I verified
that my error was gone in some maintenance build. Hopefully the fix was not lost
in the final release.

So, I would advice you to create a new bugreport with detailed description of
how to reproduce this. Point to 283184.

Before, you might also check that your workspace is not broken, as you upgraded
from 3.4.2. Create a new workspace and try to reproduce the error.

Best regards

Wolfgang
Previous Topic:Republish does not work.
Next Topic:Catalog URI not getting expanded in exported app
Goto Forum:
  


Current Time: Thu Oct 23 06:07:14 GMT 2014

Powered by FUDForum. Page generated in 0.02943 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software