Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP app has horrible remote performance
RCP app has horrible remote performance [message #504823] Tue, 22 December 2009 15:23 Go to next message
Millard Ellingsworth is currently offline Millard Ellingsworth
Messages: 14
Registered: July 2009
Junior Member
Typical situation -- want to run on *nix box, box has no display, use eXceed or Reflection X to redirect display to Windows box, run application. Resulting user interactions are beyond glacial in their response time -- horrible to the point of not being usable. Yet it's a pretty ordinary application -- we don't do any tricky stuff or any weird custom UI controls and the UI behaves fine in most situations.

The weird part is that it doesn't always happen. Sometimes it's fine. In any particular situation it is repeatable (and unavoidable), but in a seemingly similar arrangement of technology, it may or may not happen. So at Customer A, it is okay, at Customer B it is unusable and there is no obvious difference from a technology chain perspective.

Anyone see something like this? Any suggestions on how to tease out the actual cause or limit the pain for affected users?

Thanks...Millard
Re: RCP app has horrible remote performance [message #505054 is a reply to message #504823] Fri, 25 December 2009 14:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: n.n.nnn

On Tue, 22 Dec 2009 15:23:52 -0500, Millard Ellingsworth wrote:

> Typical situation -- want to run on *nix box, box has no display, use
> eXceed or Reflection X to redirect display to Windows box, run
> application. Resulting user interactions are beyond glacial in their
> response time -- horrible to the point of not being usable. Yet it's a
> pretty ordinary application -- we don't do any tricky stuff or any weird
> custom UI controls and the UI behaves fine in most situations.
>
> Anyone see something like this? Any suggestions on how to tease out the
> actual cause or limit the pain for affected users?
>
> Thanks...Millard

You could use vncserver and tailor ~/.vnc/xstartup to run just your
application, start it maximized and use the vncserver -geometry
option to control the app's size.
Re: RCP app has horrible remote performance [message #505342 is a reply to message #505054] Tue, 29 December 2009 07:53 Go to previous messageGo to next message
Millard Ellingsworth is currently offline Millard Ellingsworth
Messages: 14
Registered: July 2009
Junior Member
Good suggestion, and I don't have any control over what remoting utilities the customers choose to use and we're not likely to take a stance that they must use VNC in their data centers in order to accommodate our application. I need some strategies that work more generically.

Thanks...Millard
Re: RCP app has horrible remote performance [message #505883 is a reply to message #505342] Tue, 05 January 2010 08:06 Go to previous message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
Millard Ellingsworth wrote:
> Good suggestion, and I don't have any control over what remoting
> utilities the customers choose to use and we're not likely to take a
> stance that they must use VNC in their data centers in order to
> accommodate our application. I need some strategies that work more
> generically.
Did you try to profile your application?

Dani
>
> Thanks...Millard
Previous Topic:Feature-based product: What can I use insteaod of "Add Required Plug-ins" button
Next Topic:Keybinding problems when opening a text editor in a control
Goto Forum:
  


Current Time: Thu Jul 31 13:54:18 EDT 2014

Powered by FUDForum. Page generated in 0.01591 seconds