Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Trouble with headless build since Eclipse 3.5(Trouble with headless build after migrating from Eclipse 3.3 to Eclipse 3.5)
Trouble with headless build since Eclipse 3.5 [message #504156] Thu, 17 December 2009 08:54
Patrick Schmidt is currently offline Patrick Schmidt
Messages: 2
Registered: July 2009
Junior Member
To understand my problem, you probably need some background information, so please bear with me:

We have several Eclipse RCP products and are currently in the process of migrating them from Eclipse 3.3 to Eclipse 3.5. We have a continuous headless build for these products (i.e. the build is executed by a build server outside any running instance of Eclipse). Our products share quite a few plug-ins so we figured out a way to only build them once. The first step is a feature build containing all plug-ins. These plug-ins (in the form of Jars) are copied to a directory where they are available for the product builds that are executed next.

The "buildDirectory" property of the product build points to the source code directory of our plug-ins. The "pluginPath" property points to the previously built Jars of these plug-ins. In Eclipse 3.3 this worked very well. If the plug-in was found in pluginPath it wasn't built again. With Eclipse 3.5 all plug-ins are built again, although it seems they are built against the Jar files from pluginPath, and not against the source code in buildDirectory.

I'm not sure if these two properties were ever intended to be used this way, but it worked just fine. So my question basically is: Is there any other way to achieve the same effect in Eclipse 3.5?

Thanks in advance for any help.
Previous Topic:Import Preferences
Next Topic:Trouble with headless build since Eclipse 3.5
Goto Forum:
  


Current Time: Sun Aug 31 00:34:10 EDT 2014

Powered by FUDForum. Page generated in 0.24278 seconds