Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » SWT_AWT: OK under Java5, flakey under java 6
SWT_AWT: OK under Java5, flakey under java 6 [message #503976] Wed, 16 December 2009 16:11 Go to next message
Eclipse UserFriend
Originally posted by: yoduderoo.netscape.net

Hi,
I have a component running nicely in SWT_AWT under Java 5/Eclipse 3.5.
When I run under Java 6, behaves flakey. The SWT_AWT component no longer
receives mouse events and mouse-overs create flickering and spurious
actions.

Is there something I am missing about using Java 6 with SWT_AWT?

Thanks, y
Re: SWT_AWT: OK under Java5, flakey under java 6 [message #504017 is a reply to message #503976] Wed, 16 December 2009 20:08 Go to previous message
Eclipse UserFriend
Originally posted by: yoduderoo.netscape.net

I got it to work under Java 6 by setting a BorderLayout on the SWT_AWT
frame.

frame = SWT_AWT.new_Frame(composite);
frame.setVisible(true);
frame.setLayout(new java.awt.BorderLayout());


Don't know why that is, but it works !

-y

> Hi,
> I have a component running nicely in SWT_AWT under Java 5/Eclipse 3.5.
> When I run under Java 6, behaves flakey. The SWT_AWT component no longer
> receives mouse events and mouse-overs create flickering and spurious
> actions.
>
> Is there something I am missing about using Java 6 with SWT_AWT?
>
> Thanks, y
Previous Topic:CVS show history on Project
Next Topic:"Paste" action redefinition not complete.
Goto Forum:
  


Current Time: Thu Nov 27 14:35:10 GMT 2014

Powered by FUDForum. Page generated in 0.02368 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software