Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » P2 dev » P2 - No action found for: org.eclipse.equinox.p2.touchpoint.eclipse.addRepository.
P2 - No action found for: org.eclipse.equinox.p2.touchpoint.eclipse.addRepository. [message #503906] Wed, 16 December 2009 01:02 Go to next message
sommer  is currently offline sommer
Messages: 4
Registered: December 2009
Junior Member
Hello everybody,
We have a working update site for a rcp-product and we use eclipse3.4. I created the product with the org.eclipse.equinox.p2.director.
Now we want to upgrade to 3.5 and there starts the problem. If I use the same configuration with the change of some depending plugins I can create a running rcp product but I cannot add repositories to the available software site page because the add button is missing. Then I read of the possibility to use the p2.inf file. Now the rcp product shows the update site.
If I want to upgrade the rcp-product directly from the update site, because that is what I have to do with around 30 installations, the upgrade first seems to work. But then after everything is downloaded I get the following error while configuring the rcp-product bundle:

An error occurred while configuring the installed items
java.lang.IllegalArgumentException: No action found for: org.eclipse.equinox.p2.touchpoint.eclipse.addRepository.
at org.eclipse.equinox.internal.p2.engine.InstructionParser.loo kupAction(InstructionParser.java:66)
at org.eclipse.equinox.internal.p2.engine.InstructionParser.par seAction(InstructionParser.java:44)
at org.eclipse.equinox.internal.p2.engine.InstructionParser.par seActions(InstructionParser.java:34)
at org.eclipse.equinox.internal.provisional.p2.engine.Installab leUnitPhase.getActions(InstallableUnitPhase.java:161)
at org.eclipse.equinox.internal.provisional.p2.engine.phases.Co nfigure.getActions(Configure.java:34)
at org.eclipse.equinox.internal.provisional.p2.engine.Installab leUnitPhase.getActions(InstallableUnitPhase.java:117)
at org.eclipse.equinox.internal.provisional.p2.engine.Phase.mai nPerform(Phase.java:111)
at org.eclipse.equinox.internal.provisional.p2.engine.Phase.per form(Phase.java:79)
at org.eclipse.equinox.internal.provisional.p2.engine.Installab leUnitPhase.perform(InstallableUnitPhase.java:53)
at org.eclipse.equinox.internal.provisional.p2.engine.Phase.per form(Phase.java:46)
at org.eclipse.equinox.internal.provisional.p2.engine.PhaseSet. perform(PhaseSet.java:38)
at org.eclipse.equinox.internal.provisional.p2.engine.Engine.pe rform(Engine.java:53)
at org.eclipse.equinox.internal.provisional.p2.ui.operations.Pr ovisioningUtil.performProvisioningPlan(ProvisioningUtil.java :265)
at org.eclipse.equinox.internal.provisional.p2.ui.operations.Pr ofileModificationOperation.doExecute(ProfileModificationOper ation.java:58)
at org.eclipse.equinox.internal.provisional.p2.ui.operations.Pr ovisioningOperation.execute(ProvisioningOperation.java:40)
at org.eclipse.equinox.internal.provisional.p2.ui.ProvisioningO perationRunner$1.run(ProvisioningOperationRunner.java:94)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

In all other posts there is the hint to use the fully qualified name. But that is what I am doing.
Is there a problem because the addRepository-action didn't exist under 3.4? But I thought this should not make any problem configuring the new product depending on 3.5.
If I upgrade the 3.4-version to 3.5 without the p2.inf it works, but all Update-site setting are lost and cannot be added directly because of the missing add button.

I hope you understand my problem and can help me.
Hauke
Re: P2 - No action found for: org.eclipse.equinox.p2.touchpoint.eclipse.addRepository. [message #506526 is a reply to message #503906] Thu, 07 January 2010 16:01 Go to previous messageGo to next message
nauman khalil is currently offline nauman khalil
Messages: 5
Registered: January 2010
Junior Member
Hi sommer,

Kindly can you elaborate your problem.

According to my understanding the p2.inf only works in 3.5, so if you have added your repository through it, means your product is already in new version.

1. Then question is what you are trying to update?

Regarding missing add button in software update, in p2 you have to register your p2 policy which configures all these settings.
Re: P2 - No action found for: org.eclipse.equinox.p2.touchpoint.eclipse.addRepository. [message #508820 is a reply to message #506526] Wed, 20 January 2010 08:30 Go to previous message
sommer  is currently offline sommer
Messages: 4
Registered: December 2009
Junior Member
Hi,
the Problem exists while upgrading our Application from 3.4 to 3.5.
I hoped I could automatically save my repository Properties.
But now I did that manually.
In 3.4 the repository information could be found in configuration/.settings, in 3.5 it could be found in p2/org.eclipse.equinox.p2.engine. So I moved the settings manually(I know its dirty but it worked) and know my users can again update the software.

How can I register the "Add Button" in p2? I did not really find that anywhere.

Thanks
Hauke
Previous Topic:P2 RCP Update
Next Topic:P2 Push Mechanism
Goto Forum:
  


Current Time: Sun Apr 20 23:00:30 EDT 2014

Powered by FUDForum. Page generated in 0.12547 seconds