Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » 0.9.1 - Bug in Class Diagram Image Export
0.9.1 - Bug in Class Diagram Image Export [message #503402] Sat, 12 December 2009 14:27 Go to next message
Mark Mandel is currently offline Mark Mandel
Messages: 20
Registered: August 2009
Junior Member
There seems to be a bug in File > Save as Image File... whereby the exported image does not respect the font settings that are used to display the model

I've been having multiple issues trying to upload attachments to this forum, so hopefully this will work.

Attached (should be) a bug.zip file.

In screenshot.png, you can see the usual Eclipse view of a Class diagram (Sans 9 is the font).

In export.png, you can see an Image Export of the same diagram, but the font is much larger, and is now cropped in the display.

I am using Eclipse Galileo, SR1, 64bit on Ubuntu
Re: 0.9.1 - Bug in Class Diagram Image Export [message #503403 is a reply to message #503402] Sat, 12 December 2009 19:32 Go to previous messageGo to next message
Mark Mandel is currently offline Mark Mandel
Messages: 20
Registered: August 2009
Junior Member
Looks like my attachment didn't take.. I'll use imageshack instead.

Here is the screenshot
http://img94.imageshack.us/img94/2346/screenshotqe.png

Here is the export, where you can see the font is all messed up
http://img42.imageshack.us/img42/6752/export.png

I didn't mention is before, but this is the integration build of 0.9.1 available on the download site.
Re: 0.9.1 - Bug in Class Diagram Image Export [message #503448 is a reply to message #503403] Sun, 13 December 2009 23:22 Go to previous message
Vlad Varnica is currently offline Vlad Varnica
Messages: 546
Registered: July 2009
Location: Milton Keynes - UK
Senior Member
This should be a zoom or font size problem during the conversion to an image export.
Try to change your zoom and export your picture, or try to change the font of characters and it should work.
Previous Topic:'Arrange All' Layout Algorithm
Next Topic:Re: 0.9.1 - Bug in Class Diagram Image Export
Goto Forum:
  


Current Time: Tue Sep 02 15:10:26 EDT 2014

Powered by FUDForum. Page generated in 0.01648 seconds