Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Re: JSP editor problem
Re: JSP editor problem [message #503009] Thu, 10 December 2009 14:57 Go to next message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2327
Registered: July 2009
Senior Member
Copying this to the WTP group (eclipse.webtools for the newsgroup users).


On 12/4/09 5:23 PM, c.dexter.ward@gmail.com wrote:
> Hi,
>
> I am using Eclipse 3.3.2
>
> When I try to open a jsp file the jsp editor (open with -> JSP editor) I
> get a NoClassDefFoundError exception (see below).
>
> When I open it with the text editor, the same exception shows up anytime
> I try to save the file.
>
> I have re-installed WTP but it did not solve the problem.
> My project is a dynamic web project. Do I need to add the JavaServer
> Faces facet? Any other facet?
>
> Thanks in advance for any help.
> Charles
>
> ===== Exception =====
>
> java.lang.NoClassDefFoundError:
> org.eclipse.jst.jsp.core.internal.contentproperties.JSPFCont
> entProperties (initialization failure)
> at java.lang.J9VMInternals.initialize(J9VMInternals.java:140)
> at org.eclipse.jst.jsp.core.internal.document.PageDirectiveAdap
> terImpl.getDefaultContentType(PageDirectiveAdapterImpl.java: 379)
> at org.eclipse.jst.jsp.core.internal.document.PageDirectiveAdap
> terImpl.getContentType(PageDirectiveAdapterImpl.java:365)
> at org.eclipse.jst.jsp.core.internal.modelquery.JSPModelQueryIm
> pl.getEmbeddedModelQuery(JSPModelQueryImpl.java:116)
> at org.eclipse.jst.jsp.core.internal.modelquery.JSPModelQueryIm
> pl.getCMElementDeclaration(JSPModelQueryImpl.java:51)
> at org.eclipse.wst.xml.core.internal.document.ElementImpl.getDe
> claration(ElementImpl.java:325)
> at org.eclipse.wst.xml.core.internal.document.ElementImpl.isCon
> tainer(ElementImpl.java:783)
> at org.eclipse.wst.xml.core.internal.document.XMLModelParser.in
> sertStartTag(XMLModelParser.java:1413)
> at org.eclipse.wst.xml.core.internal.document.XMLModelParser.in
> sertStartTag(XMLModelParser.java:1506)
> at org.eclipse.wst.xml.core.internal.document.XMLModelParser.in
> sertStructuredDocumentRegion(XMLModelParser.java:1516)
> at org.eclipse.wst.xml.core.internal.document.XMLModelParser.re
> placeStructuredDocumentRegions(XMLModelParser.java:2356)
> at org.eclipse.wst.xml.core.internal.document.DOMModelImpl.inte
> rnalSetNewDocument(DOMModelImpl.java:595)
> at org.eclipse.wst.xml.core.internal.document.DOMModelImpl.setS
> tructuredDocument(DOMModelImpl.java:870)
> at org.eclipse.wst.sse.core.internal.model.AbstractModelLoader.
> createModel(AbstractModelLoader.java:127)
> at org.eclipse.wst.sse.core.internal.FileBufferModelManager.get
> Model(FileBufferModelManager.java:706)
> at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl._ge
> tModelFor(ModelManagerImpl.java:393)
> at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl.get
> ModelForEdit(ModelManagerImpl.java:1049)
> at org.eclipse.wst.sse.ui.StructuredTextEditor.doSetInput(Struc
> turedTextEditor.java:2115)
> at org.eclipse.ui.texteditor.AbstractTextEditor$19.run(Abstract
> TextEditor.java:3003)
> at org.eclipse.jface.operation.ModalContext.runInCurrentThread(
> ModalContext.java:369)
> at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:313)
> at org.eclipse.jface.window.ApplicationWindow$1.run(Application
> Window.java:758)
> at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:67)
> at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWi
> ndow.java:755)
> at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow. java:2451)
> at org.eclipse.ui.texteditor.AbstractTextEditor.internalInit(Ab
> stractTextEditor.java:3021)
> at org.eclipse.ui.texteditor.AbstractTextEditor.init(AbstractTe
> xtEditor.java:3048)
> at org.eclipse.wst.sse.ui.StructuredTextEditor.init(StructuredT
> extEditor.java:2617)
> at org.eclipse.ui.internal.EditorManager.createSite(EditorManag
> er.java:794)
> at org.eclipse.ui.internal.EditorReference.createPartHelper(Edi
> torReference.java:643)
> at org.eclipse.ui.internal.EditorReference.createPart(EditorRef
> erence.java:426)
> at org.eclipse.ui.internal.WorkbenchPartReference.getPart(Workb
> enchPartReference.java:592)
> at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:29 9)
> at org.eclipse.ui.internal.presentations.PresentablePart.setVis
> ible(PresentablePart.java:179)
> at org.eclipse.ui.internal.presentations.util.PresentablePartFo
> lder.select(PresentablePartFolder.java:268)
> at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrd
> er.select(LeftToRightTabOrder.java:65)
> at org.eclipse.ui.internal.presentations.util.TabbedStackPresen
> tation.selectPart(TabbedStackPresentation.java:400)
> at org.eclipse.ui.internal.PartStack.refreshPresentationSelecti
> on(PartStack.java:1256)
> at org.eclipse.ui.internal.PartStack.setSelection(PartStack.jav a:1209)
> at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:16 04)
> at org.eclipse.ui.internal.PartStack.add(PartStack.java:499)
> at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:103 )
> at org.eclipse.ui.internal.PartStack.add(PartStack.java:485)
>
>
>
>
>
Re: JSP editor problem [message #506831 is a reply to message #503009] Sun, 10 January 2010 16:00 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2314
Registered: July 2009
Senior Member
Eric Rizzo wrote:
> Copying this to the WTP group (eclipse.webtools for the newsgroup users).
> On 12/4/09 5:23 PM, c.dexter.ward@gmail.com wrote:
>> I am using Eclipse 3.3.2
>>
>> When I try to open a jsp file the jsp editor (open with -> JSP editor) I
>> get a NoClassDefFoundError exception (see below).
>>
>> When I open it with the text editor, the same exception shows up anytime
>> I try to save the file.
>>
>> I have re-installed WTP but it did not solve the problem.
>> My project is a dynamic web project. Do I need to add the JavaServer
>> Faces facet? Any other facet?
>>
>> Thanks in advance for any help.
>> Charles
>>
>> ===== Exception =====
>>
>> java.lang.NoClassDefFoundError:
>> org.eclipse.jst.jsp.core.internal.contentproperties.JSPFCont
>> entProperties (initialization failure)
>> at java.lang.J9VMInternals.initialize(J9VMInternals.java:140)
>> at org.eclipse.jst.jsp.core.internal.document.PageDirectiveAdap
>> terImpl.getDefaultContentType(PageDirectiveAdapterImpl.java: 379)

Despite the reinstall, you have a misconfigured installation. The
simplest solution is to download the "Eclipse IDE for Java EE
Developers " from http://eclipse.org/downloads/ as it contains a
proper combination of the most recent Eclipse and WTP releases.

--
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:org.jboss.tools.jst.web.xml
Next Topic:GWT Eclipse -> Problem
Goto Forum:
  


Current Time: Fri Oct 31 12:06:30 GMT 2014

Powered by FUDForum. Page generated in 0.12540 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software