Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » "Platform filter did not match" when running exported RCP product(problem resolving osgi bundle for exported RCP product)
"Platform filter did not match" when running exported RCP product [message #502336] Mon, 07 December 2009 18:09 Go to next message
Steve H is currently offline Steve H
Messages: 3
Registered: December 2009
Junior Member
Hi,

I'm having trouble getting my exported RCP product to run from the command line. The product was exported from the eclipse rcp export wizard (galileo, with delta pack), from a working run configuration (i.e. a run configuration from which I can successfully run the product inside the eclipse IDE). However, when I run the product from the command line, I get unresolved bundles. Using the osgi console & the diagnostic commands, I can see that 2 of my bundles were in the INSTALLED rather than the ACTIVE or LAZY states. The osgi console's "diag" command tells me that they were not resolved because "platform filter did not match". Here's some error info, followed by my osgi console output:

--------------------------------

!ENTRY org.eclipse.osgi 2 0 2009-12-07 09:17:28.001
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-12-07 09:17:28.001
!MESSAGE Bundle initial@reference :file:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0 .200.v20090520/ was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2009-12-07 09:17:28.001
!MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).

!ENTRY org.eclipse.osgi 2 0 2009-12-07 09:17:28.012
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-12-07 09:17:28.012
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520 [18] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2009-12-07 09:17:28.012
!MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-12-07 09:17:28.012
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.5.1.v3555a [26] was not resolved.
!SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2009-12-07 09:17:28.013
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))

(evince:4657): Gtk-WARNING **: Unsupported unit

(evince:4657): Gtk-WARNING **: Unsupported unit

(evince:4690): Gtk-WARNING **: Unsupported unit

(evince:4690): Gtk-WARNING **: Unsupported unit


osgi> ss

Framework is launched.

id State Bundle
0 ACTIVE org.eclipse.osgi_3.5.1.R35x_v20090827
1 RESOLVED TmcdbExplorerJars_1.0.0
2 RESOLVED TmcdbExplorerPlugin_1.0.0
3 ACTIVE com.ibm.icu_4.0.1.v20090822
4 RESOLVED javax.servlet_2.5.0.v200806031605
5 RESOLVED org.eclipse.core.commands_3.5.0.I20090525-2000
6 ACTIVE org.eclipse.core.contenttype_3.4.1.R35x_v20090826-0451
7 ACTIVE org.eclipse.core.databinding_1.2.0.M20090819-0800
8 RESOLVED org.eclipse.core.databinding.beans_1.2.0.I20090525-2000
9 ACTIVE org.eclipse.core.databinding.observable_1.2.0.M20090902-0800
10 ACTIVE org.eclipse.core.databinding.property_1.2.0.M20090819-0800
11 ACTIVE org.eclipse.core.expressions_3.4.100.v20090429-1800
12 ACTIVE org.eclipse.core.jobs_3.4.100.v20090429-1800
13 ACTIVE org.eclipse.core.runtime_3.5.0.v20090525
14 ACTIVE org.eclipse.core.runtime.compatibility.auth_3.2.100.v2009041 3
15 RESOLVED org.eclipse.core.runtime.compatibility.registry_3.2.200.v200 90429-1800
Master=20
16 ACTIVE org.eclipse.equinox.app_1.2.0.v20090520-1800
17 ACTIVE org.eclipse.equinox.common_3.5.1.R35x_v20090807-1100
18 INSTALLED org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520
19 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20090520-1800
20 ACTIVE org.eclipse.equinox.registry_3.4.100.v20090520-1800
Fragments=15
21 ACTIVE org.eclipse.help_3.4.1.v20090805_35x
22 ACTIVE org.eclipse.jface_3.5.1.M20090826-0800
23 RESOLVED org.eclipse.jface.databinding_1.3.1.M20090826-0800
24 RESOLVED org.eclipse.osgi.services_3.2.0.v20090520-1800
25 RESOLVED org.eclipse.swt_3.5.1.v3555a
26 INSTALLED org.eclipse.swt.gtk.linux.x86_3.5.1.v3555a
27 RESOLVED org.eclipse.ui_3.5.1.M20090902-1000
28 <<LAZY>> org.eclipse.ui.workbench_3.5.1.M20090826-0800a

osgi> diag 26
initial@reference :file:plugins/org.eclipse.swt.gtk.linux.x86_3.5.1.v3555a.jar / [26]
Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))

--------------------------------

The confusing thing is that I am running on linux, x86, gtk platform, so I don't understand why my "platform filter did not match". Any ideas why this could be happening? Or, suggestions on how to further debug/diagnose the problem? Any pointers will be greatly appreciated.

Thanks, Steve

Re: "Platform filter did not match" when running exported RCP product [message #502361 is a reply to message #502336] Mon, 07 December 2009 20:17 Go to previous messageGo to next message
Alessandro Caproni is currently offline Alessandro Caproni
Messages: 21
Registered: July 2009
Junior Member
Hi Steve,
when exporting you have to specify the platform to export to.
by reading your output it seems that something there went wrong.

It is not important which platform you use for developing but which platfor you select for the final product.

Hope it helps,
Ale


Alessandro Caproni
European Southern Observatory (http://www.eso.org)
Re: "Platform filter did not match" when running exported RCP product [message #502363 is a reply to message #502361] Mon, 07 December 2009 20:23 Go to previous message
Steve H is currently offline Steve H
Messages: 3
Registered: December 2009
Junior Member
Hi Alessandro,

Thanks for the suggestion. When I used the product export wizard, within the eclipse IDE, I selected the "export for multiple platforms" checkbox (which only appears when the delta pack is installed, of course) and then checked the linux/gtk checkbox as one of my exported platforms. So, I think I did what you are suggesting. Any other thoughts?

Thanks, Steve
Previous Topic:How to display the help icon in the preferences dialog
Next Topic:New Help with RCP Application Design
Goto Forum:
  


Current Time: Tue Sep 23 22:32:36 GMT 2014

Powered by FUDForum. Page generated in 0.01980 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software