Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Mylyn 3.0 is available
Mylyn 3.0 is available [message #50775] Thu, 26 June 2008 00:33 Go to next message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
We are very pleased to announce that Mylyn 3.0 is now available for
Eclipse 3.4 and 3.3. Please see the last section of the New &
Noteworthy for changes in update site structure.

http://eclipse.org/mylyn/new/

You can get Mylyn 3.0 from our update sites:

http://eclipse.org/mylyn/downloads/

Or as part of the Eclipse download packages:

http://eclipse.org/downloads/

The release story is at:

http://tasktop.com/blog/?p=32

Thanks, and stay in touch!

The Mylyn Team
Re: Mylyn 3.0 is available [message #50922 is a reply to message #50775] Fri, 27 June 2008 05:53 Go to previous messageGo to next message
Tom Lenz is currently offline Tom Lenz
Messages: 30
Registered: July 2009
Member
"Mik Kersten" <mik.kersten@tasktop.com> wrote in message
news:g3uo5m$b8t$1@build.eclipse.org...
> We are very pleased to announce that Mylyn 3.0 is now available for
> Eclipse 3.4 and 3.3.

Great job, thank you!

I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.

I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
Unzipped it.
In the available software tab of the Software Updates and Add-ons dialog I
select Collaboration Tools
Click install

Get these errors:
Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ant 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0,4. 0.0)
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java.ui/[3.0.0.v 20080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ant/[3.0.0.v 20080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/0.0.0
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.ide_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0,4. 0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java.ui/[3.0.0,4 .0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.pde.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java_feature.fea ture.group/[3.0.0.v20080619-1900,3.0.0.v20080619-1900]


I get similar results when I go to my previous eclipse installation and try
to update from Mylyn 2.3.0

Is there a work around?
Re: Mylyn 3.0 is available [message #50950 is a reply to message #50922] Fri, 27 June 2008 06:18 Go to previous messageGo to next message
Tom Lenz is currently offline Tom Lenz
Messages: 30
Registered: July 2009
Member
> I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.
>
> I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
> Unzipped it.
> In the available software tab of the Software Updates and Add-ons dialog I
> select Collaboration Tools
> Click install

Actually, in this description of what I did, left out some other plug
installs. If I start from a clean Ganymede install, the installation goes
perfectly.
Re: Mylyn 3.0 is available [message #51035 is a reply to message #50950] Fri, 27 June 2008 20:24 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
>> I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.
>>
>> I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
>> Unzipped it.
>> In the available software tab of the Software Updates and Add-ons dialog
>> I select Collaboration Tools
>> Click install
>
> Actually, in this description of what I did, left out some other plug
> installs. If I start from a clean Ganymede install, the installation goes
> perfectly.

Tom, do you have a sense which plug-ins caused the conflict? For most
integrations such as Subversive, Subclipse or Spring IDE updates have been
released that support Mylyn 3.0 but you may need to update those as well
when updating Mylyn.

Steffen
Re: Mylyn 3.0 is available [message #590432 is a reply to message #50775] Fri, 27 June 2008 05:53 Go to previous message
Tom Lenz is currently offline Tom Lenz
Messages: 30
Registered: July 2009
Member
"Mik Kersten" <mik.kersten@tasktop.com> wrote in message
news:g3uo5m$b8t$1@build.eclipse.org...
> We are very pleased to announce that Mylyn 3.0 is now available for
> Eclipse 3.4 and 3.3.

Great job, thank you!

I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.

I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
Unzipped it.
In the available software tab of the Software Updates and Add-ons dialog I
select Collaboration Tools
Click install

Get these errors:
Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)] can be satisfied.
Cannot find a solution where both Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.4.0,4.0.0)] and Match[requiredCapability:
osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)] can be satisfied.
Unsatisfied dependency: [org.eclipse.mylyn.ide.ant 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.ide.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.3.0,3.4.0)
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0,4. 0.0)
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java.ui/[3.0.0.v 20080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ant/[3.0.0.v 20080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.pde.ui/[3.3.0,3.4.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/0.0.0
Unsatisfied dependency: [org.eclipse.mylyn.pde.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.java.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.ide_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.java.ui 3.0.0.v20080619-1900]
requiredCapability: osgi.bundle/org.eclipse.mylyn.ide.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.ide.ui/[3.0.0,4. 0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java.ui/[3.0.0,4 .0.0)
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.pde.ui/[3.0.0.v2 0080619-1900,3.0.0.v20080619-1900]
Unsatisfied dependency: [org.eclipse.mylyn.pde_feature.feature.group
3.0.0.v20080619-1900] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.mylyn.java_feature.fea ture.group/[3.0.0.v20080619-1900,3.0.0.v20080619-1900]


I get similar results when I go to my previous eclipse installation and try
to update from Mylyn 2.3.0

Is there a work around?
Re: Mylyn 3.0 is available [message #590442 is a reply to message #50922] Fri, 27 June 2008 06:18 Go to previous message
Tom Lenz is currently offline Tom Lenz
Messages: 30
Registered: July 2009
Member
> I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.
>
> I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
> Unzipped it.
> In the available software tab of the Software Updates and Add-ons dialog I
> select Collaboration Tools
> Click install

Actually, in this description of what I did, left out some other plug
installs. If I start from a clean Ganymede install, the installation goes
perfectly.
Re: Mylyn 3.0 is available [message #590473 is a reply to message #50950] Fri, 27 June 2008 20:24 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
>> I'm having a bit of trouble getting Mylyn 3 installed into Ganymede.
>>
>> I downloaded this: eclipse-SDK-3.4-win32.zip (for my XP Pro rig)
>> Unzipped it.
>> In the available software tab of the Software Updates and Add-ons dialog
>> I select Collaboration Tools
>> Click install
>
> Actually, in this description of what I did, left out some other plug
> installs. If I start from a clean Ganymede install, the installation goes
> perfectly.

Tom, do you have a sense which plug-ins caused the conflict? For most
integrations such as Subversive, Subclipse or Spring IDE updates have been
released that support Mylyn 3.0 but you may need to update those as well
when updating Mylyn.

Steffen
Previous Topic:Integration with the History view
Next Topic:Printing tasks
Goto Forum:
  


Current Time: Sat Oct 25 16:14:35 GMT 2014

Powered by FUDForum. Page generated in 0.04532 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software