Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » GEF/Draw2D installation on Mac OS Snow Leopard
GEF/Draw2D installation on Mac OS Snow Leopard [message #501587] Wed, 02 December 2009 17:07 Go to next message
Eclipse User
Originally posted by: rjl.mm.com

I recently upgraded my Mac to Snow Leopard (10.6.1) and upgraded my
Eclipse to 3.5.1-x86_64 and got it to mostly work.

Unfortunately, I'm struggling with GEF. I downloaded it and unzipped it
in the 'dropins' folder and restarted Eclipse. (NOTE: the same problem
happens if I install via the software update/install facility w/in
Eclipse IDE).

When I view the Preferences | Plug-in Development | Target platform, I
see the GEF n Draw2D plugins there.

However, I now have problems with my code trying to find the SWT plugin,
but that didn't move....

I'm not seeing any errors in my workspace/.metadata/.log file.

Is this another Cocoa 64-bit issue? I can't seem to find any Mac 64-bit
build for GEF.....

Ideas?
Re: GEF/Draw2D installation on Mac OS Snow Leopard [message #501588 is a reply to message #501587] Wed, 02 December 2009 17:53 Go to previous message
Eclipse User
Originally posted by: rjl.mm.com

More info:

It seems org.eclipse.osgi is also adversely affected when I plop GEF
into my installation. Many of my (all?) plugins are reporting a problem
of 'org.eclipse.osgi' not found in the Dependency analysis.

when I whack GEF from my install and restart, I see 'org.eclipse.osgi'
is in the Target platform, but not there when GEF is installed. Grrr.

Russell Loucks wrote:
> I recently upgraded my Mac to Snow Leopard (10.6.1) and upgraded my
> Eclipse to 3.5.1-x86_64 and got it to mostly work.
>
> Unfortunately, I'm struggling with GEF. I downloaded it and unzipped it
> in the 'dropins' folder and restarted Eclipse. (NOTE: the same problem
> happens if I install via the software update/install facility w/in
> Eclipse IDE).
>
> When I view the Preferences | Plug-in Development | Target platform, I
> see the GEF n Draw2D plugins there.
>
> However, I now have problems with my code trying to find the SWT plugin,
> but that didn't move....
>
> I'm not seeing any errors in my workspace/.metadata/.log file.
>
> Is this another Cocoa 64-bit issue? I can't seem to find any Mac 64-bit
> build for GEF.....
>
> Ideas?
Previous Topic:Detecting interactive move
Next Topic:[draw2d] Dashed lines with antialiasing
Goto Forum:
  


Current Time: Fri Aug 01 20:36:31 EDT 2014

Powered by FUDForum. Page generated in 0.01803 seconds