Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Different Versions same Plug-In
Different Versions same Plug-In [message #500695] Fri, 27 November 2009 09:30 Go to next message
Dirk Hoffmann is currently offline Dirk Hoffmann
Messages: 163
Registered: July 2009
Senior Member
Hi,

we're developing a feature with lots of plug-ins some of which depend on
a set of third party plug-ins, namely EMF plug-ins.

We have to integrate with an RCP-based product which also uses EMF, lets
call it XIDE. Mixing our EMF plug-ins with theirs causes our feature or
their XIDE product to fail. Of course the plug-in loader is not able to
decide which version of the EMF plug-ins to load.

So then we specified the EMF-versions that we need in the MANIFEST.MF
files of our plug-ins with bundle-version=[...) clauses, but that's only
half of the solution. Actually the makers of the XIDE product should do
the same, so their XIDE's plug-in loader doesn't get confused by our EMF
plug-ins.

Unfortunately we cannot get them to add the bundle-version constraints
to their MANIFEST.MF files.

Does anybody have an idea how we can isolate the EMF plug-ins we need
from the rest of the plug-ins?

At the moment we think about renaming the EMF plug-ins required by our
feature. But maybe there is a better and cleaner way.

Thanks and Regards,
Dirk
Re: Different Versions same Plug-In [message #500735 is a reply to message #500695] Fri, 27 November 2009 15:02 Go to previous messageGo to next message
Francis Upton IV is currently offline Francis Upton IV
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
If your application is an RCP application, and you control the final packaging. In this case:

http://wiki.eclipse.org/Equinox_Transforms

will help you do just what you want (you can effectively change the MANIFEST.MF for them).


[Updated on: Fri, 27 November 2009 15:43]

Report message to a moderator

Re: Different Versions same Plug-In [message #501700 is a reply to message #500695] Thu, 03 December 2009 09:27 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Is their product feature based? if their product needs org.eclipse.emf 2.4.0 and your plugins/features have a lower bound of org.eclipse.emf 2.5.0, for example, you could not install in their product. Does their product pick a very specific (lower) version of EMF?

If their plugins don't specify any EMF bundle versions then they are probably fine, since no version number will get the installed version, and a single version number is treated as a lower bound. The only way their plugins could have a problem is if they specified a version range like "(2.4.0,2.5.0]" when your bundles need 2.5.0 or higher.

PW


Re: Different Versions same Plug-In [message #511834 is a reply to message #500695] Wed, 03 February 2010 02:38 Go to previous message
Dirk Hoffmann is currently offline Dirk Hoffmann
Messages: 163
Registered: July 2009
Senior Member
Thanks for the answers,

it turned out that EMF is a so called "singleton" feature so only one
version of it can be installed in a product.

We gave up our idea to bring in another version of EMF and made our
feature work with the version of EMF present in the product for which we
develop. Unfortunately we are to support multiple versions of that
product with different EMF versions. We decided to join with only one
and created our own RCP-based product for the other cases.

Dirk Hoffmann schrieb:
> Hi,
>
> we're developing a feature with lots of plug-ins some of which depend on
> a set of third party plug-ins, namely EMF plug-ins.
>
> We have to integrate with an RCP-based product which also uses EMF, lets
> call it XIDE. Mixing our EMF plug-ins with theirs causes our feature or
> their XIDE product to fail. Of course the plug-in loader is not able to
> decide which version of the EMF plug-ins to load.
>
> So then we specified the EMF-versions that we need in the MANIFEST.MF
> files of our plug-ins with bundle-version=[...) clauses, but that's only
> half of the solution. Actually the makers of the XIDE product should do
> the same, so their XIDE's plug-in loader doesn't get confused by our EMF
> plug-ins.
>
> Unfortunately we cannot get them to add the bundle-version constraints
> to their MANIFEST.MF files.
>
> Does anybody have an idea how we can isolate the EMF plug-ins we need
> from the rest of the plug-ins?
>
> At the moment we think about renaming the EMF plug-ins required by our
> feature. But maybe there is a better and cleaner way.
>
> Thanks and Regards,
> Dirk
Previous Topic:how to implement IF/ENDIF matching in TextEditor extension
Next Topic:License Management
Goto Forum:
  


Current Time: Thu Jul 24 06:43:09 EDT 2014

Powered by FUDForum. Page generated in 0.05041 seconds