Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » E4 64bit cocoa version?
icon5.gif  E4 64bit cocoa version? [message #500391] Wed, 25 November 2009 16:21 Go to next message
Stephan Zehrer is currently offline Stephan Zehrer
Messages: 42
Registered: July 2009
Member
During startup of the E4 demos I got always the following error on Mac OS 10.6.2

java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM

Is this cause of missing 64 SWT lib?

[Updated on: Wed, 25 November 2009 16:22]

Report message to a moderator

Re: E4 64bit cocoa version? [message #500431 is a reply to message #500391] Thu, 26 November 2009 02:24 Go to previous messageGo to next message
Prakash G.R. is currently offline Prakash G.R.
Messages: 621
Registered: July 2009
Senior Member
Stephan Zehrer wrote:
> java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on
> 64-bit JVM

I guess its 1.6 JRE on the 10.6. Try using the 1.5 JRE

- Prakash

Platform UI Team, IBM
http://blog.eclipse-tips.com
Re: E4 64bit cocoa version? [message #500579 is a reply to message #500431] Thu, 26 November 2009 15:11 Go to previous messageGo to next message
Stephan Zehrer is currently offline Stephan Zehrer
Messages: 42
Registered: July 2009
Member
Prakash G.R. wrote on Thu, 26 November 2009 02:24
Stephan Zehrer wrote:
>> java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on
>> 64-bit JVM

> I guess its 1.6 JRE on the 10.6. Try using the 1.5 JRE


Yes this is the solution. The gag is Snow Leopard does not have a 1.5 JVM installed any more ... it took some time to realize this Smile

THX

Stephan
Re: E4 64bit cocoa version? [message #500673 is a reply to message #500579] Fri, 27 November 2009 08:14 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

See also https://bugs.eclipse.org/bugs/show_bug.cgi?id=293288

PW


Re: E4 64bit cocoa version? [message #565290 is a reply to message #500431] Thu, 26 November 2009 15:11 Go to previous messageGo to next message
Stephan Zehrer is currently offline Stephan Zehrer
Messages: 42
Registered: July 2009
Member
Prakash G.R. wrote on Thu, 26 November 2009 02:24
> Stephan Zehrer wrote:
> >> java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on
> >> 64-bit JVM
>
> > I guess its 1.6 JRE on the 10.6. Try using the 1.5 JRE

Yes this is the solution. The gag is Snow Leopard does not have a 1.5 JVM installed any more ... it took some time to realize this :)

THX

Stephan
Re: E4 64bit cocoa version? [message #565319 is a reply to message #565290] Fri, 27 November 2009 08:14 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

See also https://bugs.eclipse.org/bugs/show_bug.cgi?id=293288

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions


Previous Topic:XWT + TableTreeViewer
Next Topic:Modeled workbench changes
Goto Forum:
  


Current Time: Fri Aug 01 01:49:05 EDT 2014

Powered by FUDForum. Page generated in 0.02018 seconds