Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » P2 dev » How to find IU(org.eclipse.equinox.executable_root) when headless building.
How to find IU(org.eclipse.equinox.executable_root) when headless building. [message #500122] Wed, 25 November 2009 05:04
Hiroki Kondo is currently offline Hiroki Kondo
Messages: 35
Registered: July 2009
Member
Hi,

I'd like to build my RCP using p2 technology.
So I added delta-pack to target environment and added to set p2 setting to build.properties like p2.gathering=true.

But I got the build log message bellow.(Is it error message?)
How to find IU about org.eclipse.equinox.executable?(I know this feature is included delta-pack.)

My build environment is
customized build script generated by plugin builder.
Ubuntu Linux 9.10.

-- start build log --
[java] customAssembly:
[java]
[java] generate.p2.metadata:
[java] Unable to find: Installable Unit [ id=org.eclipse.equinox.executable_root.gtk.linux.x86 ]
[java] Unable to find: Installable Unit [ id=org.eclipse.equinox.executable_root.carbon.macosx.x86 ]
[java] Unable to find: Installable Unit [ id=org.eclipse.equinox.executable_root.win32.win32.x86 ]
[java] [delete] Deleting directory /tmp/org.kompiro.jamcircle.builder/tmp/p2.branding
[java] [copy] Copying 1 file to /tmp/org.kompiro.jamcircle.builder/features/org.eclipse.pde. build.container.feature/product
[java] [eclipse.idReplacer] Could not find com.ibm.icu
[java] [eclipse.idReplacer] Could not find org.apache.bsf
[java] [eclipse.idReplacer] Could not find org.apache.commons.lang
[java] [eclipse.idReplacer] Could not find org.apache.commons.logging
[java] [eclipse.idReplacer] Could not find org.eclipse.compare.core
[java] [eclipse.idReplacer] Could not find org.eclipse.core.net
[java] [eclipse.idReplacer] Could not find org.eclipse.core.runtime
[java] [eclipse.idReplacer] Could not find org.eclipse.core.runtime.compatibility
[java] [eclipse.idReplacer] Could not find org.eclipse.core.runtime.compatibility.auth
[java] [eclipse.idReplacer] Could not find org.eclipse.core.variables
[java] [eclipse.idReplacer] Could not find org.eclipse.draw2d
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.app
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.common
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.preferences
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.registry
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.security
[java] [eclipse.idReplacer] Could not find org.eclipse.equinox.security.ui
[java] [eclipse.idReplacer] Could not find org.eclipse.gef
[java] [eclipse.idReplacer] Could not find org.eclipse.help
[java] [eclipse.idReplacer] Could not find org.eclipse.jface
[java] [eclipse.idReplacer] Could not find org.eclipse.jface.databinding
[java] [eclipse.idReplacer] Could not find org.eclipse.jface.text
[java] [eclipse.idReplacer] Could not find org.eclipse.osgi
[java] [eclipse.idReplacer] Could not find org.eclipse.swt
[java] [eclipse.idReplacer] Could not find org.eclipse.text
[java] [eclipse.idReplacer] Could not find org.eclipse.ui
[java] [eclipse.idReplacer] Could not find org.eclipse.ui.console
[java] [eclipse.idReplacer] Could not find org.eclipse.ui.forms
[java] [eclipse.idReplacer] Could not find org.eclipse.ui.workbench
[java] [eclipse.idReplacer] Could not find org.eclipse.ui.workbench.texteditor
[java] [eclipse.idReplacer] Could not find org.jivesoftware.smack
[java] [eclipse.idReplacer] Could not find org.jruby
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.debug
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.kanban.core
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.kanban.ui
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.rcp
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.scripting.core
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.scripting.ui
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.storage.core
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.storage.ui
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.xmpp.core
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.xmpp.kanban.ui
[java] [eclipse.idReplacer] Could not find org.kompiro.jamcircle.xmpp.ui
[java] [eclipse.idReplacer] Could not find org.mozilla.javascript
[java] [eclipse.idReplacer] Could not find org.sf.feeling.swt.win32.extension
[java] [p2.mirror] Problems resolving provisioning plan.
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.ui.cocoa [1.0.0.I20090525-2000].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.win32.win32.x86_64 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.wpf.win32.x86 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.linux.s390 [3.5.0.v3550b].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.linux.s390x [3.5.0.v3550b].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.solaris.sparc [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.solaris.x86 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.linux.ppc [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.gtk.linux.x86_64 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.cocoa.macosx [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.cocoa.macosx [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.cocoa.macosx.x86_64 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.motif.aix.ppc [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.motif.hpux.PA_RISC [3.5.0.HEAD].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.motif.hpux.ia64_32 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.motif.linux.x86 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.motif.solaris.sparc [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.swt.photon.qnx.x86 [3.5.1.v3555a].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.solaris.sparc [1.0.201.R35x_v20090720].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.solaris.x86 [1.0.201.R35x_v20090720].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.cocoa.macosx [1.0.1.R35x_v20090707].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.cocoa.macosx [1.0.1.R35x_v20090707].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.cocoa.macosx.x86_64 [1.0.1.R35x_v20090707].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.linux.ppc [1.0.200.v20090519].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.linux.s390 [1.0.100.v20090426-1530].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.linux.s390x [1.0.100.v20090426-1530].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.motif.linux.x86 [1.0.200.v20090520].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.gtk.linux.x86_64 [1.0.200.v20090519].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.motif.aix.ppc [1.0.200.v20090519].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.motif.hpux.ia64_32 [1.0.100.v20090519].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.motif.hpux.PA_RISC [1.0.100.v20090306-1900].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.wpf.win32.x86 [1.0.200.v20090519].
[java] [p2.mirror] Unable to satisfy dependency from org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 to org.eclipse.equinox.launcher.win32.win32.x86_64 [1.0.200.v20090519].
[java] [p2.mirror] Messages while mirroring artifact descriptors.

Regards,
Previous Topic:P2 and Categories definition
Next Topic:Update plugin from site
Goto Forum:
  


Current Time: Sat Sep 20 18:23:31 GMT 2014

Powered by FUDForum. Page generated in 0.01711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software