Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Can't get rid of jre in exported product(It is always generated no matter what I try)
icon5.gif  Can't get rid of jre in exported product [message #499044] Thu, 19 November 2009 16:04 Go to next message
Vitaly  is currently offline Vitaly Friend
Messages: 3
Registered: November 2009
Junior Member
I picked up a project that was developed by other team. The project is currently configured to bundle it's own copy of jre on export.

For some reason, I cannot disable this. (Un)setting checkbox in .product->Launching->Execution environment has no effect. (Also tried to delete the whole <vm> element in xml view of the .product file).

There is no reference to jre dir in any of the build.properties files.

No jre copy is found among my source plugins.

Checked that on another computer - same result.

No matter what I try, the exported product always contains the jre.

What other options are there to make PDE/UI bundle the jre on export?

P.S. It may be irrelevant, but I would like to explain the reason why I need this. I suspect that 'incorrectly' bundled jre may have something to do with the following p2 update bug I am experiencing:
http://www.eclipse.org/forums/index.php?t=msg&goto=49617 7&S=e14482b786045430bf71478da018b772#msg_496177
Re: Can't get rid of jre in exported product [message #499641 is a reply to message #499044] Mon, 23 November 2009 15:30 Go to previous message
Vitaly  is currently offline Vitaly Friend
Messages: 3
Registered: November 2009
Junior Member
Seems that the root of the problem is in the org.eclipse.rcp feature I added to my product configuration.

I tried to create a simple test product configuration (based on feature) from the RCP mail example. If org.eclipse.rcp feature is included in my own feature, then JRE is bundled together with exported product; and conversely, if I just list required plugins in my feature, then there is no JRE.

So I assume RCP feature somehow makes PDE/Export bundle JRE together with the product.

I am using Eclipse Galileo SR1. I didn't notice anything like that in Ganymede or older versions.

Does anyone know if that is expected behavior?
Previous Topic:Load a class of a fragment dynamically from a String
Next Topic:RCP Jetty..absolute path for htmls
Goto Forum:
  


Current Time: Wed Nov 26 08:04:19 GMT 2014

Powered by FUDForum. Page generated in 0.02524 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software