Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Data Soruce Explorer, No tables, only Schemas visible(Problem to see tables using JDBC Driver for MS SQL Server 2008)
Data Soruce Explorer, No tables, only Schemas visible [message #498812] Wed, 18 November 2009 17:15 Go to next message
mr. burns is currently offline mr. burnsFriend
Messages: 402
Registered: July 2009
Senior Member
Hi all,

I tried whole day to get a connection from Eclispe to MS SQL Server 2008 using DTP, but without success.

My Eclispe version:
3.5.1
Build id: M20090917-0800

My DTP version:
Version: 1.7.0.v200908280400-7J8i2BWwQJOaz-Gi2C5seJM2FX2f
Build id: 1.7.1.v20090904-0500

Microsoft SQL Server 2008 on Windows Server 2003 R2, Standard x64 Edition

Java JRE 1.6

I set up connection under Data Source Explorer, using Generic JDBC and also another one using SQL Server.
I used sqljdbc4.jar.

The ping to my database server succeeded.
In Data Source Explorer I can see also the databases. But if I click the + sign to open a certain database I only see a folder called Schemas, but no tables, no views, etc..

I looked up internet to find a solution, but no success.

What I am doing wrong?

Thanks for any help!


[Updated on: Thu, 19 November 2009 07:27]

Report message to a moderator

Re: Data Soruce Explorer, No tables, only Schemas visible [message #499664 is a reply to message #498812] Mon, 23 November 2009 16:15 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
Hi Mr. Burns...

There are some issues with SQL Server support in Galileo at the moment.
Sounds like you're fighting this one:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=287587

And there's another one as well...
https://bugs.eclipse.org/bugs/show_bug.cgi?id=284104

The resources we've had working on MSSQL haven't had a chance to resolve
this in the 1.7.x maintenance stream yet, but I'm still hopeful it will
get resolved.

Our issue right now is a lack of bodies helping out on Enablement
support. We love people who provide patches to fix issues. :)

Sorry I don't have better news than that at the moment.

--Fitz

mr. burns wrote:
> Hi all,
>
> I tried whole day to get a connection from Eclispe to MS SQL Server 2008
> using DTP, but without success.
>
> My Eclispe version:
> 3.5.1
> Build id: M20090917-0800
>
> My DTP version:
> Version: 1.7.0.v200908280400-7J8i2BWwQJOaz-Gi2C5seJM2FX2f
> Build id: 1.7.1.v20090904-0500
>
> Microsoft SQL Server 2008 on Windows Server 2003 R2, Standard x64 Edition
>
>
> I set up connection under Data Source Explorer, using Generic JDBC and
> also another one using SQL Server.
> I used sqljdbc4.jar.
>
> The ping to my database server succeeded.
> In Data Source Explorer I can see also the databases. But if I click the
> + sign to open a certain database I only see a folder called Schemas,
> but no tables, no views, etc..
>
> I looked up internet to find a solution, but no success.
>
> What I am doing wrong?
>
> Thanks for any help!
>
>
>
Re: Data Soruce Explorer, No tables, only Schemas visible [message #509662 is a reply to message #499664] Sun, 24 January 2010 13:27 Go to previous messageGo to next message
SGP  is currently offline SGP Friend
Messages: 2
Registered: January 2010
Junior Member
Is this also true of MySQL? I have the exact same behavior when trying to connect to a MySQL database. Both the Eclipse and MySQL are running on the same Ubuntu 9.10 system. I have set GDK_NATIVE_WINDOWS=true as suggested elsewhere on the forums to get past problems with Ubuntu 9.10.

The issue seems to be GUI related. I can run queries from the SQL scrapbook and get results, so it is able to access the database tables, but will not show them in the GUI.

The GUI related issues extend elsewhere:
1) I cannot see any tables in the SQL Query builder as well.
2) I cannot run anything from the SQL Query builder either, though the exact same statement runs fine from the SQL Scrapbook.
3) If I try to generate entities from database using seam, I do not see any tables in the wizard either.

Thanks,
SGP
Cool
Re: Data Soruce Explorer, No tables, only Schemas visible [message #510185 is a reply to message #509662] Tue, 26 January 2010 16:00 Go to previous message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
There are a number of existing bugzilla entries for MySQL at this point.
Unfortunately, we don't have anyone with MySQL knowledge who can look
into them at this point. We welcome any help in this area.

Here are the current bugs:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=279721
https://bugs.eclipse.org/bugs/show_bug.cgi?id=279726

SGP wrote:
> Is this also true of MySQL? I have the exact same behavior when trying
> to connect to a MySQL database. Both the Eclipse and MySQL are running
> on the same Ubuntu 9.10 system. I have set GDK_NATIVE_WINDOWS=true as
> suggested elsewhere on the forums to get past problems with Ubuntu 9.10.
>
> The issue seems to be GUI related. I can run queries from the SQL
> scrapbook and get results, so it is able to access the database tables,
> but will not show them in the GUI.
>
> The GUI related issues extend elsewhere:
> 1) I cannot see any tables in the SQL Query builder as well.
> 2) I cannot run anything from the SQL Query builder either, though the
> exact same statement runs fine from the SQL Scrapbook.
> 3) If I try to generate entities from database using seam, I do not see
> any tables in the wizard either.
>
> Thanks,
> SGP
> 8)
Re: Data Soruce Explorer, No tables, only Schemas visible [message #597070 is a reply to message #499664] Sun, 24 January 2010 13:27 Go to previous message
SGP  is currently offline SGP Friend
Messages: 2
Registered: January 2010
Junior Member
Is this also true of MySQL? I have the exact same behavior when trying to connect to a MySQL database. Both the Eclipse and MySQL are running on the same Ubuntu 9.10 system. I have set GDK_NATIVE_WINDOWS=true as suggested elsewhere on the forums to get past problems with Ubuntu 9.10.

The issue seems to be GUI related. I can run queries from the SQL scrapbook and get results, so it is able to access the database tables, but will not show them in the GUI.

The GUI related issues extend elsewhere:
1) I cannot see any tables in the SQL Query builder as well.
2) I cannot run anything from the SQL Query builder either, though the exact same statement runs fine from the SQL Scrapbook.
3) If I try to generate entities from database using seam, I do not see any tables in the wizard either.

Thanks,
SGP
8)
Re: Data Soruce Explorer, No tables, only Schemas visible [message #597112 is a reply to message #597070] Tue, 26 January 2010 16:00 Go to previous message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 495
Registered: July 2009
Senior Member
There are a number of existing bugzilla entries for MySQL at this point.
Unfortunately, we don't have anyone with MySQL knowledge who can look
into them at this point. We welcome any help in this area.

Here are the current bugs:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=279721
https://bugs.eclipse.org/bugs/show_bug.cgi?id=279726

SGP wrote:
> Is this also true of MySQL? I have the exact same behavior when trying
> to connect to a MySQL database. Both the Eclipse and MySQL are running
> on the same Ubuntu 9.10 system. I have set GDK_NATIVE_WINDOWS=true as
> suggested elsewhere on the forums to get past problems with Ubuntu 9.10.
>
> The issue seems to be GUI related. I can run queries from the SQL
> scrapbook and get results, so it is able to access the database tables,
> but will not show them in the GUI.
>
> The GUI related issues extend elsewhere:
> 1) I cannot see any tables in the SQL Query builder as well.
> 2) I cannot run anything from the SQL Query builder either, though the
> exact same statement runs fine from the SQL Scrapbook.
> 3) If I try to generate entities from database using seam, I do not see
> any tables in the wizard either.
>
> Thanks,
> SGP
> 8)
Previous Topic:OUTPUT parameters represented as INOUT for SQL Stored Procedures.
Next Topic:Instead of Trigger Error
Goto Forum:
  


Current Time: Sat Dec 20 19:33:53 GMT 2014

Powered by FUDForum. Page generated in 0.05647 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software