Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Firefox error -8048 accessing bugs.eclipse.org
Firefox error -8048 accessing bugs.eclipse.org [message #50509] Fri, 16 November 2007 08:55 Go to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Hello!
I often get error -8048 (cannot estabilish an encrypted connection)
using Firefox 2 to access bugs.eclipse.org. The meaning of this erro
code is:
"Invalid OCSP signing certificate in OCSP response."
(as stated at:
http://www.mozilla.org/projects/security/pki/nss/ref/ssl/ssl err.html)

For instance, in this moment I cannot access
https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474 using Firefox (I
had to use Opera).

Does anyone has the same problem?

Cheers,
Mauro.
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50537 is a reply to message #50509] Fri, 16 November 2007 10:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Mauro,

It works fine for me on Windows XP. It's probably good to send a note
to webmaster at eclipse dot org if this problem persists. Specify the
exact version of Firefox and the OS you are on if you do send a note.


Mauro Molinari wrote:
> Hello!
> I often get error -8048 (cannot estabilish an encrypted connection)
> using Firefox 2 to access bugs.eclipse.org. The meaning of this erro
> code is:
> "Invalid OCSP signing certificate in OCSP response."
> (as stated at:
> http://www.mozilla.org/projects/security/pki/nss/ref/ssl/ssl err.html)
>
> For instance, in this moment I cannot access
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474 using Firefox (I
> had to use Opera).
>
> Does anyone has the same problem?
>
> Cheers,
> Mauro.
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50565 is a reply to message #50537] Fri, 16 November 2007 13:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Ed Merks ha scritto:
> Mauro,
>
> It works fine for me on Windows XP. It's probably good to send a note
> to webmaster at eclipse dot org if this problem persists. Specify the
> exact version of Firefox and the OS you are on if you do send a note.

Ok Ed, I'll do as you say.

Thank you!
Mauro.
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50681 is a reply to message #50509] Fri, 23 November 2007 14:44 Go to previous messageGo to next message
Eclipse Webmaster is currently offline Eclipse Webmaster
Messages: 455105
Registered: July 2009
Senior Member
Mauro,

You're the only one to report an error of this kind, so I'm inclined to
think there's something strange with your Firefox browser. Would you
have any specific settings in your Security preferences, or perhaps a
proxy server that could be configured a specific way (or simply out of
date)?

Denis



Mauro Molinari wrote:
> Hello!
> I often get error -8048 (cannot estabilish an encrypted connection)
> using Firefox 2 to access bugs.eclipse.org. The meaning of this erro
> code is:
> "Invalid OCSP signing certificate in OCSP response."
> (as stated at:
> http://www.mozilla.org/projects/security/pki/nss/ref/ssl/ssl err.html)
>
> For instance, in this moment I cannot access
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=201474 using Firefox (I
> had to use Opera).
>
> Does anyone has the same problem?
>
> Cheers,
> Mauro.

--

Eclipse WebMaster - webmaster@eclipse.org
Questions? Consult the WebMaster FAQ at
http://wiki.eclipse.org/index.php/Webmaster_FAQ
View my status at http://wiki.eclipse.org/index.php/WebMaster
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50709 is a reply to message #50681] Mon, 26 November 2007 09:19 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Denis Roy ha scritto:
> Mauro,
>
> You're the only one to report an error of this kind, so I'm inclined to
> think there's something strange with your Firefox browser. Would you
> have any specific settings in your Security preferences, or perhaps a
> proxy server that could be configured a specific way (or simply out of
> date)?
>
> Denis

Hi Denis,
I have default options for Firefox 2. It has been for some days that I
can't access bugs.eclipse.org anymore with it: it had happened rarely
before, and I simply needed to try again to get it to work. But now, it
never works.

To make bugs.eclipse.org work again with my Firefox 2, I have to do the
following:
(I'm transalting from Italian, so in English the item names might be
quite different)
Tools | Settings... | Advanced | Ciphering (last tab) | Verify | Don't
use OCSP to verify certificates.

In this way it works.
Otherwise, if I leave the default "Use OCSP to verify just those
certificates that specify an OCSP service address", it does not.

Please note that I'm not experiencing any problems with other sites
using SSL with Firefox 2 and that I'm using a direct connection to
Internet (no proxy)...

Cheers
Mauro.
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50737 is a reply to message #50709] Mon, 26 November 2007 14:24 Go to previous messageGo to next message
Eclipse Webmaster is currently offline Eclipse Webmaster
Messages: 455105
Registered: July 2009
Senior Member
Mauro Molinari wrote:
> Denis Roy ha scritto:
>> Mauro,
>>
>> You're the only one to report an error of this kind, so I'm inclined
>> to think there's something strange with your Firefox browser. Would
>> you have any specific settings in your Security preferences, or
>> perhaps a proxy server that could be configured a specific way (or
>> simply out of date)?
>>
>> Denis
>
> Hi Denis,
> I have default options for Firefox 2. It has been for some days that I
> can't access bugs.eclipse.org anymore with it: it had happened rarely
> before, and I simply needed to try again to get it to work. But now, it
> never works.
>
> To make bugs.eclipse.org work again with my Firefox 2, I have to do the
> following:
> (I'm transalting from Italian, so in English the item names might be
> quite different)
> Tools | Settings... | Advanced | Ciphering (last tab) | Verify | Don't
> use OCSP to verify certificates.
>
> In this way it works.
> Otherwise, if I leave the default "Use OCSP to verify just those
> certificates that specify an OCSP service address", it does not.
>
> Please note that I'm not experiencing any problems with other sites
> using SSL with Firefox 2 and that I'm using a direct connection to
> Internet (no proxy)...
>
> Cheers
> Mauro.

Mauro,

Indeed, I get the same error if I enable OCSP verification on Firefox
(any version). I checked our certificate, and it does specify an OCSP
URI (which points to our certificate provider). I've opened a support
issue with them for this.

On a side note, I checked all my Firefox installations, and my default
is Don't Use OCSP. Because Firefox 2 is the #1 browser for
bugs.eclipse.org, I'm guessing that the global default is Don't Use OCSP.

I also checked a dozen https sites out there, and none of them specify
an OCSP URI. I think you can simply set the verification option to 'Do
not verify' and you won't lose much. As I said, I don't think OCSP is
the default value for Firefox, as I would have heard about this a long
time ago.

I'll casually follow up with our certificate provider about this.

D.


--

Eclipse WebMaster - webmaster@eclipse.org
Questions? Consult the WebMaster FAQ at
http://wiki.eclipse.org/index.php/Webmaster_FAQ
View my status at http://wiki.eclipse.org/index.php/WebMaster
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50765 is a reply to message #50737] Tue, 27 November 2007 14:04 Go to previous messageGo to next message
Eclipse Webmaster is currently offline Eclipse Webmaster
Messages: 455105
Registered: July 2009
Senior Member
Denis Roy wrote:
> I'll casually follow up with our certificate provider about this.
>

Good news. Digicert has fixed the problem with their OCSP service, so
you can leave the verification option enabled and access Eclipse's https
sites. Here's what they had to say:

Earlier versions of Firefox had seemingly random problems with OCSP
responses (for DigiCert sites, as well as other CAs), so earlier this
month when I noticed this in my own Firefox browser, I didn't pay as
much attention to it as I should have. I've made a small change to the
way we send our OCSP responses which has resolved the problem in my
testing.


Thanks for reporting this.

Denis


--

Eclipse WebMaster - webmaster@eclipse.org
Questions? Consult the WebMaster FAQ at
http://wiki.eclipse.org/index.php/Webmaster_FAQ
View my status at http://wiki.eclipse.org/index.php/WebMaster
Re: Firefox error -8048 accessing bugs.eclipse.org [message #50793 is a reply to message #50765] Tue, 27 November 2007 17:01 Go to previous message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Denis Roy ha scritto:
> Thanks for reporting this.

Thanks to you Denis, I'm glad to have been of help to solve this.

And yes, I may have changed in some way my Firefox2 default settings by
enabling OCSP verification, although I don't remember when and how... :-P

Cheers,
Mauro.
Previous Topic:eRCP & Mylyn Webinars
Next Topic:Eclipse DemoCamps Dec. 3-9
Goto Forum:
  


Current Time: Wed Sep 17 11:32:49 GMT 2014

Powered by FUDForum. Page generated in 0.02564 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software