Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Possible bug(Possible bug when importing netbeans j2me projects)
Possible bug [message #497597] Fri, 13 November 2009 09:36
Victor Badulescu is currently offline Victor Badulescu
Messages: 4
Registered: November 2009
Junior Member
Hi,
I'm using the latest eclipse distribution with the MTJ plugin installed (eclipse 3.5 + MTJ Version: 1.0.1.v200909181641-7W7D7EFFt6Zb-appdsJXo Build id: 200909181641
).
When i try to create a j2me project in my workspace by importing an existing Netbeans project (Import -> J2ME - > Netbeans Project)
i bet some build errors.
The project get crated, it si shown as an j2me project with the j2me class path variable which points to the jars in the SUN WTK SDK .
The error I'm getting is that the static field TRUE or FALSE of the Boolen class could not be resolved["Boolean.FALSE cannot be resolved"].
This class that contains the static fields is in the cldc_1.1.jar in the SDK , and it is added to the project class path , but somehow it is ignored and the Boolean class from the cldc_1.0 jar has precedence over it.
This only happens when using the import feature , it doesn't happen when creating a new j2me project for eclipse .
The netbeans project was created using netbeans 6.7 and had compliance leveelsset to cldc 1.1 and midp 2.1.
Can anyone help with this issue ?
Previous Topic:Cannot debug my application
Next Topic:Possible bug
Goto Forum:
  


Current Time: Tue Sep 16 11:45:08 GMT 2014

Powered by FUDForum. Page generated in 0.04692 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software