Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » JPA 2.0 on Java EE 5??(Use CriteriaQuery on a Java EE AS. (Glassfish 2.1))
JPA 2.0 on Java EE 5?? [message #496601] Tue, 10 November 2009 11:39 Go to next message
Elvis Ratzlaff is currently offline Elvis Ratzlaff
Messages: 2
Registered: July 2009
Junior Member
Hi
This is my first Post Razz
Sorry for my english.. I am from Paraguay Smile

I want to code a program who use CriteriaQuery but stil use Java EE like JSF 1.2.
Not a .war.
Has some one make this work?

Tanks.
Re: JPA 2.0 on Java EE 5?? [message #499415 is a reply to message #496601] Sun, 22 November 2009 01:23 Go to previous messageGo to next message
Serge  is currently offline Serge
Messages: 76
Registered: July 2009
Member
Elvis Ratzlaff пишет:
> Hi This is my first Post :p Sorry for my english.. I am from Paraguay :)
>
> I want to code a program who use CriteriaQuery but stil use Java EE like
> JSF 1.2.
> Not a .war.
> Has some one make this work?
>
> Tanks.

I tried before but servers are often have some verification (and may be
integration) code and force "1.0" version for persistence.xml
Re: JPA 2.0 on Java EE 5?? [message #499696 is a reply to message #496601] Mon, 23 November 2009 13:27 Go to previous message
James Sutherland is currently offline James Sutherland
Messages: 1939
Registered: July 2009
Location: Ottawa, Canada
Senior Member

EclipseLink inclues the new JPA 2.0 classes inside its jar, so most JPA 2.0 features will just work. Unless you replace your server's persistence.jar, you will still have the old JPA 1.0 interfaces, so you will need to cast your EntityManager.getDelegate() to the EclipseLink impl to call some methods.

If you replace the persistence.jar, then most servers will just work.

Which server are you using, and what issue are you having?


James : Wiki : Book : Blog : Twitter
Previous Topic:2.0.0 release plans?
Next Topic:M15 milestone
Goto Forum:
  


Current Time: Sat Apr 19 13:18:09 EDT 2014

Powered by FUDForum. Page generated in 0.01993 seconds