Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Mylyn 2.0RC3 is now available
Mylyn 2.0RC3 is now available [message #4407] Sat, 23 June 2007 15:15 Go to next message
Eclipse User
Originally posted by: beatmik.acm.org

Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.

The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
involvement of the backport and the Eclipse Packaging Project's recent
inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php) we
had kept our focus on entirely on the Eclipse 3.3 distribution. We hope
to have the Eclipse 3.2 release available early next week. If we do not
do make it available by Tuesday we will likely delay the 3.2-based
release to happen shortly after the Europa release in order to ensure
there is enough time for feedback.

Mik
Re: Mylyn 2.0RC3 is now available [message #4477 is a reply to message #4407] Sat, 23 June 2007 15:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: mphippard.collab.net

On 6/23/07 3:15 PM, in article f5jrgf$iqr$1@build.eclipse.org, "Mik Kersten"
<beatmik@acm.org> wrote:

> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>
> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
> involvement of the backport and the Eclipse Packaging Project's recent
> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php) we
> had kept our focus on entirely on the Eclipse 3.3 distribution. We hope
> to have the Eclipse 3.2 release available early next week. If we do not
> do make it available by Tuesday we will likely delay the 3.2-based
> release to happen shortly after the Europa release in order to ensure
> there is enough time for feedback.

I totally understand how hard this 3.2 backport is and how pressed for time
you are, but not having 3.2 support makes things hard for people that
use/extend Mylyn. Many of these plug-ins do not have Eclipse 3.3-specific
features so we do our builds in 3.2 to target both. Not having Mylyn in 3.2
makes this difficult. As an example, I planned to release our updated
Subclipse integration this weekend, but I am not sure what I will do now. I
have no intention of posting an Eclipse 3.3 and 3.2 version when I have no
real reason to do so.

Mark
Re: Mylyn 2.0RC3 is now available [message #4546 is a reply to message #4477] Mon, 25 June 2007 13:09 Go to previous messageGo to next message
Eclipse User
Originally posted by: beatmik.acm.org

Thanks for voicing your concern Mark, that makes perfect sense and you
may not be the only one feeling this frustration. We will do what we
can to get the 3.2 build out before end-of-day (midnight PST).

Mik

Mark Phippard wrote:
> I totally understand how hard this 3.2 backport is and how pressed for time
> you are, but not having 3.2 support makes things hard for people that
> use/extend Mylyn. Many of these plug-ins do not have Eclipse 3.3-specific
> features so we do our builds in 3.2 to target both. Not having Mylyn in 3.2
> makes this difficult. As an example, I planned to release our updated
> Subclipse integration this weekend, but I am not sure what I will do now. I
> have no intention of posting an Eclipse 3.3 and 3.2 version when I have no
> real reason to do so.
>
> Mark
Re: Mylyn 2.0RC3 is now available [message #4616 is a reply to message #4407] Tue, 26 June 2007 14:25 Go to previous messageGo to next message
Eclipse User
Originally posted by: beatmik.acm.org

Mylyn 2.0RC4 is now available for Eclipse 3.3 and the 3.2 backport is
underway.

Mik

Mik Kersten wrote:
> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>
> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
> involvement of the backport and the Eclipse Packaging Project's recent
> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php) we
> had kept our focus on entirely on the Eclipse 3.3 distribution. We hope
> to have the Eclipse 3.2 release available early next week. If we do not
> do make it available by Tuesday we will likely delay the 3.2-based
> release to happen shortly after the Europa release in order to ensure
> there is enough time for feedback.
>
> Mik
Re: Mylyn 2.0RC3 is now available [message #4685 is a reply to message #4616] Wed, 27 June 2007 07:33 Go to previous messageGo to next message
Eclipse User
Originally posted by: beatmik.acm.org

Both Eclipse 3.2 and 3.3 builds (2.0.0.v20070627-0100) are now uploading
and will be available in ~30min (please do not attempt to install
beforehand). Update sites are:

download.eclipse.org/tools/mylyn/update/e3.2

download.eclipse.org/tools/mylyn/update/e3.3

Mik

Mik Kersten wrote:
> Mylyn 2.0RC4 is now available for Eclipse 3.3 and the 3.2 backport is
> underway.
>
> Mik
>
> Mik Kersten wrote:
>> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>>
>> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
>> involvement of the backport and the Eclipse Packaging Project's recent
>> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php)
>> we had kept our focus on entirely on the Eclipse 3.3 distribution. We
>> hope to have the Eclipse 3.2 release available early next week. If we
>> do not do make it available by Tuesday we will likely delay the
>> 3.2-based release to happen shortly after the Europa release in order
>> to ensure there is enough time for feedback.
>>
>> Mik
Re: Mylyn 2.0RC3 is now available [message #4754 is a reply to message #4685] Wed, 27 June 2007 11:13 Go to previous messageGo to next message
Eclipse User
Originally posted by: lhasadad.gmail.google.com

Mik Kersten wrote:
> Both Eclipse 3.2 and 3.3 builds (2.0.0.v20070627-0100) are now uploading
> and will be available in ~30min (please do not attempt to install
> beforehand). Update sites are:
>
> download.eclipse.org/tools/mylyn/update/e3.2
>
> download.eclipse.org/tools/mylyn/update/e3.3
>
> Mik
>
>
Can we try now?
Re: Mylyn 2.0RC3 is now available [message #4823 is a reply to message #4754] Wed, 27 June 2007 14:52 Go to previous messageGo to next message
Eclipse User
Originally posted by: beatmik.acm.org

Bill Trautman wrote:
> Can we try now?

Yes, please do :)
Re: Mylyn 2.0RC3 is now available [message #4893 is a reply to message #4823] Thu, 28 June 2007 07:33 Go to previous messageGo to next message
Eclipse User
Originally posted by: adam.giemza.gmx.de

Mik Kersten schrieb:
> Bill Trautman wrote:
>> Can we try now?
>
> Yes, please do :)

Done! And I really like it :) But I have a question. I still use it with
Eclipse 3.2 and discovered something new while installing.

There are three bridges under Integration: IDE, SDK, Java Development.
What is this? I can not remember any bridges in the Milestone Builds.
Could someone clarify this for me? What do I need as a Eclipse User?

Greetings and many thanks for that great tool :)
Adam
Re: Mylyn 2.0RC3 is now available [message #4959 is a reply to message #4893] Thu, 28 June 2007 21:09 Go to previous messageGo to next message
Eclipse User
Originally posted by: beatmik.acm.org

Hi Adam,

I'm about to clarify this on the Download page. Bridges connect the
resources that you work with (e.g. Java code) to the task context model.
Previously we lumped them all into a single "Focused UI" feature.
However, the EPP (eclipse.org/eep) packaging and Europa required subsets
of Mylyn that are specific to Java, plug-in, and plain IDE development.

If you would like what you had before just select all the bridges. And
thanks for the kind words!

Mik

Adam Giemza wrote:
> Mik Kersten schrieb:
>> Bill Trautman wrote:
>>> Can we try now?
>>
>> Yes, please do :)
>
> Done! And I really like it :) But I have a question. I still use it with
> Eclipse 3.2 and discovered something new while installing.
>
> There are three bridges under Integration: IDE, SDK, Java Development.
> What is this? I can not remember any bridges in the Milestone Builds.
> Could someone clarify this for me? What do I need as a Eclipse User?
>
> Greetings and many thanks for that great tool :)
> Adam
Re: Mylyn 2.0RC3 is now available [message #5026 is a reply to message #4959] Fri, 29 June 2007 02:35 Go to previous message
Eclipse User
Originally posted by: adam.giemza.gmx.de

Hello Mik,

thanks for the clarification. Yesterday I have introduced Mylyn to the
"developer team" of the research group at the University of Duisburg-Essen in
Germany. They have also been very impressed and I hope that at least the bug
tracker will used more frequently through the nice integration :)

Keep on doing this very good job!
Adam
Re: Mylyn 2.0RC3 is now available [message #568380 is a reply to message #4407] Sat, 23 June 2007 15:51 Go to previous message
Mark Phippard is currently offline Mark Phippard
Messages: 129
Registered: July 2009
Senior Member
On 6/23/07 3:15 PM, in article f5jrgf$iqr$1@build.eclipse.org, "Mik Kersten"
<beatmik@acm.org> wrote:

> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>
> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
> involvement of the backport and the Eclipse Packaging Project's recent
> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php) we
> had kept our focus on entirely on the Eclipse 3.3 distribution. We hope
> to have the Eclipse 3.2 release available early next week. If we do not
> do make it available by Tuesday we will likely delay the 3.2-based
> release to happen shortly after the Europa release in order to ensure
> there is enough time for feedback.

I totally understand how hard this 3.2 backport is and how pressed for time
you are, but not having 3.2 support makes things hard for people that
use/extend Mylyn. Many of these plug-ins do not have Eclipse 3.3-specific
features so we do our builds in 3.2 to target both. Not having Mylyn in 3.2
makes this difficult. As an example, I planned to release our updated
Subclipse integration this weekend, but I am not sure what I will do now. I
have no intention of posting an Eclipse 3.3 and 3.2 version when I have no
real reason to do so.

Mark
Re: Mylyn 2.0RC3 is now available [message #568463 is a reply to message #4477] Mon, 25 June 2007 13:09 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Thanks for voicing your concern Mark, that makes perfect sense and you
may not be the only one feeling this frustration. We will do what we
can to get the 3.2 build out before end-of-day (midnight PST).

Mik

Mark Phippard wrote:
> I totally understand how hard this 3.2 backport is and how pressed for time
> you are, but not having 3.2 support makes things hard for people that
> use/extend Mylyn. Many of these plug-ins do not have Eclipse 3.3-specific
> features so we do our builds in 3.2 to target both. Not having Mylyn in 3.2
> makes this difficult. As an example, I planned to release our updated
> Subclipse integration this weekend, but I am not sure what I will do now. I
> have no intention of posting an Eclipse 3.3 and 3.2 version when I have no
> real reason to do so.
>
> Mark
Re: Mylyn 2.0RC3 is now available [message #568507 is a reply to message #4407] Tue, 26 June 2007 14:25 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Mylyn 2.0RC4 is now available for Eclipse 3.3 and the 3.2 backport is
underway.

Mik

Mik Kersten wrote:
> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>
> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
> involvement of the backport and the Eclipse Packaging Project's recent
> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php) we
> had kept our focus on entirely on the Eclipse 3.3 distribution. We hope
> to have the Eclipse 3.2 release available early next week. If we do not
> do make it available by Tuesday we will likely delay the 3.2-based
> release to happen shortly after the Europa release in order to ensure
> there is enough time for feedback.
>
> Mik
Re: Mylyn 2.0RC3 is now available [message #568563 is a reply to message #4616] Wed, 27 June 2007 07:33 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Both Eclipse 3.2 and 3.3 builds (2.0.0.v20070627-0100) are now uploading
and will be available in ~30min (please do not attempt to install
beforehand). Update sites are:

download.eclipse.org/tools/mylyn/update/e3.2

download.eclipse.org/tools/mylyn/update/e3.3

Mik

Mik Kersten wrote:
> Mylyn 2.0RC4 is now available for Eclipse 3.3 and the 3.2 backport is
> underway.
>
> Mik
>
> Mik Kersten wrote:
>> Mylyn 2.0RC3 (2.0.0.v20070623-1130) is uploading now.
>>
>> The 2.0RC3 build is still only available for Eclipse 3.3. Due to the
>> involvement of the backport and the Eclipse Packaging Project's recent
>> inclusion of Mylyn (http://www.eclipse.org/downloads/indexProto.php)
>> we had kept our focus on entirely on the Eclipse 3.3 distribution. We
>> hope to have the Eclipse 3.2 release available early next week. If we
>> do not do make it available by Tuesday we will likely delay the
>> 3.2-based release to happen shortly after the Europa release in order
>> to ensure there is enough time for feedback.
>>
>> Mik
Re: Mylyn 2.0RC3 is now available [message #568627 is a reply to message #4685] Wed, 27 June 2007 11:13 Go to previous message
Bill Trautman is currently offline Bill Trautman
Messages: 4
Registered: July 2009
Junior Member
Mik Kersten wrote:
> Both Eclipse 3.2 and 3.3 builds (2.0.0.v20070627-0100) are now uploading
> and will be available in ~30min (please do not attempt to install
> beforehand). Update sites are:
>
> download.eclipse.org/tools/mylyn/update/e3.2
>
> download.eclipse.org/tools/mylyn/update/e3.3
>
> Mik
>
>
Can we try now?
Re: Mylyn 2.0RC3 is now available [message #568698 is a reply to message #4754] Wed, 27 June 2007 14:52 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Bill Trautman wrote:
> Can we try now?

Yes, please do :)
Re: Mylyn 2.0RC3 is now available [message #568776 is a reply to message #4823] Thu, 28 June 2007 07:33 Go to previous message
Eclipse User
Originally posted by: adam.giemza.gmx.de

Mik Kersten schrieb:
> Bill Trautman wrote:
>> Can we try now?
>
> Yes, please do :)

Done! And I really like it :) But I have a question. I still use it with
Eclipse 3.2 and discovered something new while installing.

There are three bridges under Integration: IDE, SDK, Java Development.
What is this? I can not remember any bridges in the Milestone Builds.
Could someone clarify this for me? What do I need as a Eclipse User?

Greetings and many thanks for that great tool :)
Adam
Re: Mylyn 2.0RC3 is now available [message #568804 is a reply to message #4893] Thu, 28 June 2007 21:09 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Hi Adam,

I'm about to clarify this on the Download page. Bridges connect the
resources that you work with (e.g. Java code) to the task context model.
Previously we lumped them all into a single "Focused UI" feature.
However, the EPP (eclipse.org/eep) packaging and Europa required subsets
of Mylyn that are specific to Java, plug-in, and plain IDE development.

If you would like what you had before just select all the bridges. And
thanks for the kind words!

Mik

Adam Giemza wrote:
> Mik Kersten schrieb:
>> Bill Trautman wrote:
>>> Can we try now?
>>
>> Yes, please do :)
>
> Done! And I really like it :) But I have a question. I still use it with
> Eclipse 3.2 and discovered something new while installing.
>
> There are three bridges under Integration: IDE, SDK, Java Development.
> What is this? I can not remember any bridges in the Milestone Builds.
> Could someone clarify this for me? What do I need as a Eclipse User?
>
> Greetings and many thanks for that great tool :)
> Adam
Re: Mylyn 2.0RC3 is now available [message #568838 is a reply to message #4959] Fri, 29 June 2007 02:35 Go to previous message
Eclipse User
Originally posted by: adam.giemza.gmx.de

Hello Mik,

thanks for the clarification. Yesterday I have introduced Mylyn to the
"developer team" of the research group at the University of Duisburg-Essen in
Germany. They have also been very impressed and I hope that at least the bug
tracker will used more frequently through the nice integration :)

Keep on doing this very good job!
Adam
Previous Topic:Mylyn 2.0RC3 is now available
Next Topic:Mylyn iCal connector
Goto Forum:
  


Current Time: Thu Aug 28 05:20:34 EDT 2014

Powered by FUDForum. Page generated in 0.02767 seconds