Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » ATF » What mozilla version is used?
What mozilla version is used? [message #495962] Fri, 06 November 2009 14:15 Go to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
Hi,

I just installed the ATF 0.3.0.v200911011917. I am wondering exactly which version of Mozilla is used in this ATF?

Thanks!

Sunny
Re: What mozilla version is used? [message #496029 is a reply to message #495962] Sat, 07 November 2009 06:05 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
ATF uses this Mozilla version which you have installed :-)
If you installed Eclipse XULRunner plug-ins, you can check their version
in Help->About Eclipse and locate XULRunner feature.
Most probably it is XULRunner 1.9.1, that afaik corresponds to Firefox 3.5.1

I'd be happy to go ahead with all latest XULRunner versions as soon as
they appear and it may actually become possible when we get fixed this
bug: https://bugzilla.mozilla.org/show_bug.cgi?id=522443

cheers

Jacek


Sunny wrote:
> Hi,
>
> I just installed the ATF 0.3.0.v200911011917. I am wondering exactly
> which version of Mozilla is used in this ATF?
>
> Thanks!
>
> Sunny
Re: What mozilla version is used? [message #496065 is a reply to message #496029] Sat, 07 November 2009 14:45 Go to previous messageGo to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
Hi Jacek,

Yes my Eclipse Help->About shows it has:

Plug-in Name: Mozilla XulRunner, Version: 1.9.1.0_v20090825-0940.

So Eclipse ATF is using Firefox 3.5.1?

In order for ATF to use a different version of Firefox, do I have to install a different version of Mozilla XulRunner? Or, can I simply tell ATF to use another Firefox without considering XulRunner?

Thanks a lot.

Sunny

Re: What mozilla version is used? [message #496087 is a reply to message #496065] Sun, 08 November 2009 07:22 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
ATF is using it's own XULRunner in that plug-ins, independently from
Firefox or any other XUL-based application that you might have on your
system.
There's work in progress to make ATF able to use system-wide XULRunner,
e.g. from Firefox, Thunderbird, or anything else but we're not there yet.

Sunny wrote:
> Hi Jacek,
>
> Yes my Eclipse Help->About shows it has:
>
> Plug-in Name: Mozilla XulRunner, Version: 1.9.1.0_v20090825-0940.
>
> So Eclipse ATF is using Firefox 3.5.1?
>
> In order for ATF to use a different version of Firefox, do I have to
> install a different version of Mozilla XulRunner? Or, can I simply
> tell ATF to use another Firefox without considering XulRunner?
>
> Thanks a lot.
>
> Sunny
>
>
Re: What mozilla version is used? [message #496116 is a reply to message #495962] Sun, 08 November 2009 13:00 Go to previous messageGo to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
I see your point, thanks!

Hope ATF is able to choose other browsers/versions soon Smile .
Re: What mozilla version is used? [message #496178 is a reply to message #496116] Mon, 09 November 2009 04:47 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
would you like to open an enhancement request for that? Go there:
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=ATF
(funny, but nobody has actually requested that yet....)

Or maybe there's somebody willing to implement that? Google Chrome
integration maybe could be based on experiences from Eclipse Blinki
project, or Chrome Web Inspector.
but I'd be even more interested to see IE support...

Sunny wrote:
> I see your point, thanks!
>
> Hope ATF is able to choose other browsers/versions soon :) .
Re: What mozilla version is used? [message #496215 is a reply to message #496178] Mon, 09 November 2009 06:39 Go to previous messageGo to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
Done with the enhancement request.
Re: What mozilla version is used? [message #561869 is a reply to message #495962] Sat, 07 November 2009 06:05 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
ATF uses this Mozilla version which you have installed :-)
If you installed Eclipse XULRunner plug-ins, you can check their version
in Help->About Eclipse and locate XULRunner feature.
Most probably it is XULRunner 1.9.1, that afaik corresponds to Firefox 3.5.1

I'd be happy to go ahead with all latest XULRunner versions as soon as
they appear and it may actually become possible when we get fixed this
bug: https://bugzilla.mozilla.org/show_bug.cgi?id=522443

cheers

Jacek


Sunny wrote:
> Hi,
>
> I just installed the ATF 0.3.0.v200911011917. I am wondering exactly
> which version of Mozilla is used in this ATF?
>
> Thanks!
>
> Sunny
Re: What mozilla version is used? [message #561932 is a reply to message #496029] Sat, 07 November 2009 14:45 Go to previous messageGo to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
Hi Jacek,

Yes my Eclipse Help->About shows it has:

Plug-in Name: Mozilla XulRunner, Version: 1.9.1.0_v20090825-0940.

So Eclipse ATF is using Firefox 3.5.1?

In order for ATF to use a different version of Firefox, do I have to install a different version of Mozilla XulRunner? Or, can I simply tell ATF to use another Firefox without considering XulRunner?

Thanks a lot.

Sunny
Re: What mozilla version is used? [message #561954 is a reply to message #561932] Sun, 08 November 2009 07:22 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
ATF is using it's own XULRunner in that plug-ins, independently from
Firefox or any other XUL-based application that you might have on your
system.
There's work in progress to make ATF able to use system-wide XULRunner,
e.g. from Firefox, Thunderbird, or anything else but we're not there yet.

Sunny wrote:
> Hi Jacek,
>
> Yes my Eclipse Help->About shows it has:
>
> Plug-in Name: Mozilla XulRunner, Version: 1.9.1.0_v20090825-0940.
>
> So Eclipse ATF is using Firefox 3.5.1?
>
> In order for ATF to use a different version of Firefox, do I have to
> install a different version of Mozilla XulRunner? Or, can I simply
> tell ATF to use another Firefox without considering XulRunner?
>
> Thanks a lot.
>
> Sunny
>
>
Re: What mozilla version is used? [message #561973 is a reply to message #495962] Sun, 08 November 2009 13:00 Go to previous messageGo to next message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
I see your point, thanks!

Hope ATF is able to choose other browsers/versions soon :) .
Re: What mozilla version is used? [message #561995 is a reply to message #561973] Mon, 09 November 2009 04:47 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
would you like to open an enhancement request for that? Go there:
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=ATF
(funny, but nobody has actually requested that yet....)

Or maybe there's somebody willing to implement that? Google Chrome
integration maybe could be based on experiences from Eclipse Blinki
project, or Chrome Web Inspector.
but I'd be even more interested to see IE support...

Sunny wrote:
> I see your point, thanks!
>
> Hope ATF is able to choose other browsers/versions soon :) .
Re: What mozilla version is used? [message #562009 is a reply to message #496178] Mon, 09 November 2009 06:39 Go to previous message
Sunny  is currently offline Sunny
Messages: 17
Registered: November 2009
Junior Member
Done with the enhancement request.
Previous Topic:Great
Next Topic:ATF plug-ins installation. Problems
Goto Forum:
  


Current Time: Wed Aug 20 08:50:45 EDT 2014

Powered by FUDForum. Page generated in 0.01881 seconds