Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 (Trying to run HelloWorld)
Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #495676] Thu, 05 November 2009 18:00 Go to next message
Richard Catlin is currently offline Richard Catlin
Messages: 50
Registered: July 2009
Member
I am getting the following error when trying to run the RAP HelloWorld.

http://127.0.0.1:3475/rap?startup=hello
HTTP ERROR 404
Problem accessing /rap. Reason:
ProxyServlet: /rap
Powered by Jetty://

I have tried all variations. Manual and Automatic installs. I have even run it on a fresh Windows and Solaris OS install.

Is anyone else having this problem?

Thanks for any help.
Regards,
Richard Catlin
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #495683 is a reply to message #495676] Thu, 05 November 2009 18:17 Go to previous messageGo to next message
Richard Catlin is currently offline Richard Catlin
Messages: 50
Registered: July 2009
Member
Additionally, I have tried both 1.2 and 1.3 releases.

Here is the console exceptions:
osgi> !SESSION 2009-11-05 09:51:41.828 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_16
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -dev file:D:/eclipse_workspace/eclipse-sizing-rap/.metadata/.plug ins/org.eclipse.pde.core/Rap1/dev.properties -os win32 -ws win32 -arch x86 -console -consolelog

!ENTRY org.eclipse.rap.ui.workbench 4 0 2009-11-05 09:51:42.875
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.help; bundle-version=" was not resolved.
!SUBENTRY 2 org.eclipse.rap.ui.workbench 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.help_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-05 09:51:43.078
!MESSAGE Bundle Rap1_1.0.0.qualifier was not resolved.
!SUBENTRY 2 Rap1 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-05 09:51:43.078
!MESSAGE Bundle org.eclipse.rap.demo_1.3.0.20090929-1121 was not resolved.
!SUBENTRY 2 org.eclipse.rap.demo 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui_0.0.0.
!SUBENTRY 2 org.eclipse.rap.demo 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui.views_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-05 09:51:43.078
!MESSAGE Bundle org.eclipse.rap.ui_1.3.0.20090929-1121 was not resolved.
!SUBENTRY 2 org.eclipse.rap.ui 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui.workbench_[1.2.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-05 09:51:43.078
!MESSAGE Bundle org.eclipse.rap.demo.databinding_1.3.0.20090929-1121 was not resolved.
!SUBENTRY 2 org.eclipse.rap.demo.databinding 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-11-05 09:51:43.078
!MESSAGE Bundle org.eclipse.rap.ui.views_1.3.0.20090929-1121 [32] was not resolved.
!SUBENTRY 2 org.eclipse.rap.ui.views 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.rap.ui_[1.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.ui.views 2 0 2009-11-05 09:51:43.078
!MESSAGE Missing required bundle org.eclipse.help_[3.2.0,4.0.0).
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #495684 is a reply to message #495683] Thu, 05 November 2009 18:21 Go to previous messageGo to next message
Richard Catlin is currently offline Richard Catlin
Messages: 50
Registered: July 2009
Member
ENTRY Rap1 4 0 2009-11-05 09:51:42.875
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:554)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:461)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:246)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:442)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.rap.demo 4 0 2009-11-05 09:51:42.875
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:554)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:461)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:246)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:442)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.rap.ui 4 0 2009-11-05 09:51:42.890
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui.workbench; bundle-version="[1.2.0,2.0.0)"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:554)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:461)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:246)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:442)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.rap.demo.databinding 4 0 2009-11-05 09:51:42.890
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:554)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:461)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:246)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:442)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)

!ENTRY org.eclipse.rap.ui.views 4 0 2009-11-05 09:51:42.890
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui; bundle-version="[1.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolverError(AbstractBundle.java:1313)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getR esolutionFailureException(AbstractBundle.java:1297)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:319)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:370)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1068)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:554)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:461)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:246)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:442)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:227)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:337)
2009-11-05 09:51:42.921:org.mortbay.log:INFO: Logging to STDERRorg.mortbay.log via org.mortbay.log.Slf4jLog
2009-11-05 09:51:42.968::INFO: jetty-6.1.x
2009-11-05 09:51:43.031::INFO: Started SelectChannelConnector@0.0.0.0:3475
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #495714 is a reply to message #495676] Thu, 05 November 2009 20:01 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris Aniszczyk
Messages: 674
Registered: July 2009
Senior Member
Richard Catlin wrote:
> I am getting the following error when trying to run the RAP HelloWorld.
>
> http://127.0.0.1:3475/rap?startup=hello
> HTTP ERROR 404
> Problem accessing /rap. Reason: ProxyServlet: /rap
> Powered by Jetty://
>
> I have tried all variations. Manual and Automatic installs. I have
> even run it on a fresh Windows and Solaris OS install.
>
> Is anyone else having this problem?

Have you looked at the Getting Started guide?
http://www.eclipse.org/rap/gettingstarted.php

It looks like your bundle that hosts the RAP application may not be
started? Are you pointing to the RAP target platform?

You can track me down on Skype if you need help.

Cheers,

Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #495890 is a reply to message #495676] Fri, 06 November 2009 14:22 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1291
Registered: July 2009
Senior Member

Hi Richard,

sometimes the application is not yet started when the launcher opens the
browser. In this case, reloading the page (F5 in the browser) helps. Is
this what you are seeing?

Regards, Ralf

Richard Catlin wrote:
> I am getting the following error when trying to run the RAP HelloWorld.
>
> http://127.0.0.1:3475/rap?startup=hello
> HTTP ERROR 404
> Problem accessing /rap. Reason: ProxyServlet: /rap
> Powered by Jetty://
>
> I have tried all variations. Manual and Automatic installs. I have
> even run it on a fresh Windows and Solaris OS install.
>
> Is anyone else having this problem?
>
> Thanks for any help.
> Regards,
> Richard Catlin
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #651438 is a reply to message #495676] Sun, 30 January 2011 21:34 Go to previous messageGo to next message
mku  is currently offline mku
Messages: 7
Registered: January 2011
Junior Member
Hello ,
I have the same problem now:
HTTP ERROR 404
Problem accessing /rap. Reason:

ProxyServlet: /rap

Do you know already , what to do with it?
Thanks
Michal Kuchar, Prague
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #804122 is a reply to message #495676] Wed, 22 February 2012 08:22 Go to previous messageGo to next message
Etele Berszány is currently offline Etele Berszány
Messages: 2
Registered: February 2012
Junior Member
Same problem here... even followed some installation instructions tried it on Windows 7, Ubuntu Linux 11.10... I just can't start the simple HelloWorld application.
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #804127 is a reply to message #495676] Wed, 22 February 2012 08:22 Go to previous messageGo to next message
Etele Berszány is currently offline Etele Berszány
Messages: 2
Registered: February 2012
Junior Member
Same problem here... even followed some installation instructions tried it on Windows 7, Ubuntu Linux 11.10... I just can't start the simple HelloWorld application.
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #804157 is a reply to message #804127] Wed, 22 February 2012 09:08 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
Hi,
if you run your application from the IDE that's open the browser
automatically, probably you run into this bug:
282756: [Tooling] Browser is opened too early
https://bugs.eclipse.org/bugs/show_bug.cgi?id=282756
The solution is to press the refresh button on the browser.
HTH,
Ivan

On 2/22/2012 10:22 AM, Etele Berszány wrote:
> Same problem here... even followed some installation instructions
> tried it on Windows 7, Ubuntu Linux 11.10... I just can't start the
> simple HelloWorld application.

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Problem accessing /rap. Reason: ProxyServlet: /rap HTTP ERROR 404 [message #892259 is a reply to message #495676] Wed, 27 June 2012 14:11 Go to previous message
carlos miranda is currently offline carlos miranda
Messages: 1
Registered: June 2012
Junior Member
Hi, I had the same problem and resolved it by
downloading the rap target runtime from
the eclipse site.
Because at some point my rap target version was too recent for
my eclipse version.
Hope it helps.
Previous Topic:View title don't hide by using Fancy Theme
Next Topic:ResourceServlet throws "java.lang.IllegalArgumentException: URI is not hierarchical" on JB
Goto Forum:
  


Current Time: Sat Oct 25 16:53:53 GMT 2014

Powered by FUDForum. Page generated in 0.03054 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software