Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » SWTBot test run configuration type actually needed?
SWTBot test run configuration type actually needed? [message #495464] Wed, 04 November 2009 19:13 Go to next message
Ralf Ebert is currently offline Ralf Ebert
Messages: 72
Registered: July 2009
Member
Hi,

I found that SWTBot test cases for RCP applications can be executed fine using
the PDE JUnit Plug-in Test. Is the special SWTBot test run configuration type
actually needed for this use case? / what is the additional value of that
configuration type compared to the plug-in test?

Greetings,
Ralf


-- http://www.ralfebert.de/blog/eclipsercp/
Re: SWTBot test run configuration type actually needed? [message #495692 is a reply to message #495464] Thu, 05 November 2009 14:03 Go to previous message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
Tests need to run on a non-ui thread[1], hence a different launcher.
Starting 3.5 PDE provides a launcher configuration for this, but I'm
keeping it around for legacy and supporting older versions.


[1] -http://wiki.eclipse.org/SWTBot/FAQ#Why_do_tests_run_on_a_no n-UI_thread.3F

-- Ketan

Ralf Ebert wrote:
> Hi,
>
> I found that SWTBot test cases for RCP applications can be executed fine
> using the PDE JUnit Plug-in Test. Is the special SWTBot test run
> configuration type actually needed for this use case? / what is the
> additional value of that configuration type compared to the plug-in test?
>
> Greetings,
> Ralf
>
>
> -- http://www.ralfebert.de/blog/eclipsercp/
Previous Topic:Text Fields by ID
Next Topic:Testing and Eclipse RCP Application
Goto Forum:
  


Current Time: Wed Apr 16 18:50:54 EDT 2014

Powered by FUDForum. Page generated in 0.03289 seconds