Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » [mylyn-3.0.5] cannot securely connect to my Trac repository
[mylyn-3.0.5] cannot securely connect to my Trac repository [message #495429] Wed, 04 November 2009 15:05 Go to next message
Adrian Herscu is currently offline Adrian Herscu
Messages: 4
Registered: July 2009
Junior Member
Hi all,

I am using Eclipse 3.2.2 M20080221-1800 with Mylyn 3.0.5.v20090218-1800-e33

My Trac repository is available at: https://trac.wirexn.net:443/sandbox

When trying to validate settings I am getting:
No Trac repository found at url: I/O error while communicating with HTTP
server: Received fatal alert: bad_record_mac

It used to work with no problem some time ago :(

I can enter the Web front-end both with a plain-connection and with an
SSL connection by using a Web browser.

Also, I can enter the XMLRPC front-end by using Mylyn but only with a
plain-connection.

Please help,
Adrian.
Re: [mylyn-3.0.5] cannot securely connect to my Trac repository [message #495837 is a reply to message #495429] Fri, 06 November 2009 06:07 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
Adrian, please take a look at this bug and comment there if the suggested
work-around fixes the problem for you:

207175: error "Received fatal alert: bad_record_mac" when using https with
SSLv3
https://bugs.eclipse.org/bugs/show_bug.cgi?id=207175

Steffen


Adrian Herscu wrote:

> Hi all,
>
> I am using Eclipse 3.2.2 M20080221-1800 with Mylyn
> 3.0.5.v20090218-1800-e33
>
> My Trac repository is available at: https://trac.wirexn.net:443/sandbox
>
> When trying to validate settings I am getting:
> No Trac repository found at url: I/O error while communicating with HTTP
> server: Received fatal alert: bad_record_mac
>
> It used to work with no problem some time ago :(
>
> I can enter the Web front-end both with a plain-connection and with an
> SSL connection by using a Web browser.
>
> Also, I can enter the XMLRPC front-end by using Mylyn but only with a
> plain-connection.
>
> Please help,
> Adrian.

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Re: [mylyn-3.0.5] cannot securely connect to my Trac repository [message #599975 is a reply to message #495429] Fri, 06 November 2009 06:07 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
Adrian, please take a look at this bug and comment there if the suggested
work-around fixes the problem for you:

207175: error "Received fatal alert: bad_record_mac" when using https with
SSLv3
https://bugs.eclipse.org/bugs/show_bug.cgi?id=207175

Steffen


Adrian Herscu wrote:

> Hi all,
>
> I am using Eclipse 3.2.2 M20080221-1800 with Mylyn
> 3.0.5.v20090218-1800-e33
>
> My Trac repository is available at: https://trac.wirexn.net:443/sandbox
>
> When trying to validate settings I am getting:
> No Trac repository found at url: I/O error while communicating with HTTP
> server: Received fatal alert: bad_record_mac
>
> It used to work with no problem some time ago :(
>
> I can enter the Web front-end both with a plain-connection and with an
> SSL connection by using a Web browser.
>
> Also, I can enter the XMLRPC front-end by using Mylyn but only with a
> plain-connection.
>
> Please help,
> Adrian.

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Previous Topic:Access trac's wiki pages via ant
Next Topic:Page load error
Goto Forum:
  


Current Time: Sat Aug 30 10:31:47 EDT 2014

Powered by FUDForum. Page generated in 0.06471 seconds