Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » javascript debugger
javascript debugger [message #494838] Mon, 02 November 2009 21:28 Go to next message
Gary Horen is currently offline Gary Horen
Messages: 19
Registered: July 2009
Junior Member
How do I use the Rhino Debugger that I installed into Helios M3 from
http://download.eclipse.org/e4/downloads/drops/S-1.0M1-20091 0131430/repository?

I checked out the projects described at the top of this page:
http://wiki.eclipse.org/E4/JavaScript#JavaScript_Rhino_Debug ging_Support.
Then I ran JSFrameworkTest.java as a plugin unit test (both run as and debug
as). The junit tests all run. But I'm trying to fire a breakpoint on some
JavaScript code. Putting breakpoints on the following lines in script.js in
that project results in no breaks, nor does inserting a debugger; statement
into the code.

return "JavaScript";
return new JavaAdapter(Packages....

I can see there is a JavaScript debug launcher configuration page, but I
don't know how to fill in the Connect tab (what would the port be?), and any
of the other tabs, and I don't know how to launch a plugin junit test in a
way that would pick any of that up. What am I missing?

Thanks
-Gary
Re: javascript debugger [message #495097 is a reply to message #494838] Tue, 03 November 2009 18:18 Go to previous messageGo to next message
Simon Kaegi is currently offline Simon Kaegi
Messages: 381
Registered: July 2009
Senior Member
re: What am I missing?

Unfortunately you're missing the documentation as we're still doing a lot of work on the debugger. In HEAD things are changing in both the launch ui and our approach to connecting to the debugger as we're currently working on integrating other JS runtimes.

I will take a bit of time and update the Wiki later this week with some getting started instructions. I'll also come back to this thread to provide a link.

-Simon
Re: javascript debugger [message #564290 is a reply to message #494838] Tue, 03 November 2009 18:18 Go to previous message
Simon Kaegi is currently offline Simon Kaegi
Messages: 381
Registered: July 2009
Senior Member
re: What am I missing?

Unfortunately you're missing the documentation as we're still doing a lot of work on the debugger. In HEAD things are changing in both the launch ui and our approach to connecting to the debugger as we're currently working on integrating other JS runtimes.

I will take a bit of time and update the Wiki later this week with some getting started instructions. I'll also come back to this thread to provide a link.

-Simon
Previous Topic:XWT Designer
Next Topic:site manifest editor (web ui)
Goto Forum:
  


Current Time: Thu Oct 23 02:38:35 GMT 2014

Powered by FUDForum. Page generated in 0.03007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software