Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Text Fields by ID
Text Fields by ID [message #494827] Mon, 02 November 2009 20:00 Go to next message
Mr. Gaffo is currently offline Mr. GaffoFriend
Messages: 9
Registered: October 2009
Junior Member
Can anyone help me figure out why this isn't working:

http://github.com/gaffo/swtbotexamples/blob/master/junit/com /uberu/TextWithIdTest.java

Thanks!
Re: Text Fields by ID [message #494832 is a reply to message #494827] Mon, 02 November 2009 20:53 Go to previous messageGo to next message
Jay Norwood is currently offline Jay NorwoodFriend
Messages: 112
Registered: July 2009
Senior Member
Looks like one bug is that you call this twice:
textField1.setData
Re: Text Fields by ID [message #494837 is a reply to message #494827] Mon, 02 November 2009 21:07 Go to previous messageGo to next message
Pascal G is currently offline Pascal GFriend
Messages: 157
Registered: July 2009
Senior Member
Mr. Gaffo wrote:
> Can anyone help me figure out why this isn't working:
>
> http://github.com/gaffo/swtbotexamples/blob/master/junit/com /uberu/TextWithIdTest.java
>
>
> Thanks!

line 96 should be textField2.setData, instead of textField1.setData
--
Pascal GĂ©linas | Software Developer
*Nu Echo Inc.*
http://www.nuecho.com/ | http://blog.nuecho.com/

*Because performance matters.*
Re: Text Fields by ID [message #495016 is a reply to message #494827] Tue, 03 November 2009 14:46 Go to previous messageGo to next message
Mr. Gaffo is currently offline Mr. GaffoFriend
Messages: 9
Registered: October 2009
Junior Member
DOH! That seems to work. Thanks folks.
Re: Text Fields by ID [message #495687 is a reply to message #494827] Thu, 05 November 2009 18:38 Go to previous message
Kay-Uwe Graw is currently offline Kay-Uwe GrawFriend
Messages: 24
Registered: July 2009
Junior Member
One comment to the test code. In order to avoid a dependency of your application code to any swtbot plugin by using org.eclipse.swtbot.swt.finder.utils.SWTBotPreferences.DEFAUL T_KEY, you should define your own ID_KEY and set this value in the SWTBotPreferences instead.

Kay
Previous Topic:Testing exported RCP fails with StackOverflow
Next Topic:SWTBot test run configuration type actually needed?
Goto Forum:
  


Current Time: Wed Dec 17 23:16:32 GMT 2014

Powered by FUDForum. Page generated in 0.02169 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software