Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » Problem with generating entity from table
Problem with generating entity from table [message #494662] Mon, 02 November 2009 01:48 Go to next message
Ludovic  is currently offline Ludovic
Messages: 7
Registered: November 2009
Junior Member
Hello,

I am creating a project in galileo, with dali 2.2. I also use EclipseLink and Glassfish as a server. The project is jpa enabled, with a pesistence.xml file. I use the wizard to generate the entities from tables.

I may see the tables of my schema in the wizard. In fact everything goes fine up to the finish.

The only thing is that no code is generated and I can't find any message of why it failed.

Any help would be appreciated. If it's not the right place to ask, don't hesitate to tell me.

thanks

Ludovic

Re: Problem with generating entity from table [message #495668 is a reply to message #494662] Thu, 05 November 2009 17:25 Go to previous messageGo to next message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
Please open the Error Log view and report any errors that might have been logged on the Finish. I'm guessing that there is something being sent to the log that might help us diagnose the problem.

Thanks,
Neil
Re: Problem with generating entity from table [message #495783 is a reply to message #495668] Fri, 06 November 2009 03:50 Go to previous messageGo to next message
Ludovic  is currently offline Ludovic
Messages: 7
Registered: November 2009
Junior Member
yes there is this exception:
Quote:
org.eclipse.core.runtime.CoreException: Unable to find JPA entities generation templates in pluginorg.eclipse.jpt.gen
at org.eclipse.jpt.gen.internal2.PackageGenerator2.generateClas s(PackageGenerator2.java:202)
at org.eclipse.jpt.gen.internal2.PackageGenerator2.generateInte rnal(PackageGenerator2.java:112)
at org.eclipse.jpt.gen.internal2.PackageGenerator2.doGenerate(P ackageGenerator2.java:92)
at org.eclipse.jpt.gen.internal2.PackageGenerator2.generate(Pac kageGenerator2.java:73)
at org.eclipse.jpt.ui.internal.wizards.gen.GenerateEntitiesFrom SchemaWizard$GenerateEntitiesJob.runInWorkspace(GenerateEnti tiesFromSchemaWizard.java:254)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run (InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: java.lang.NoSuchMethodError: org.apache.log4j.Logger.debug(Ljava/lang/Object;Ljava/lang/T hrowable;)V
at org.apache.velocity.runtime.log.Log4JLogChute.log(Log4JLogCh ute.java:183)
at org.apache.velocity.runtime.log.HoldingLogChute.transferTo(H oldingLogChute.java:115)
at org.apache.velocity.runtime.log.LogManager.updateLog(LogMana ger.java:216)
at org.apache.velocity.runtime.RuntimeInstance.initializeLog(Ru ntimeInstance.java:728)
at org.apache.velocity.runtime.RuntimeInstance.init(RuntimeInst ance.java:240)
at org.apache.velocity.runtime.RuntimeInstance.init(RuntimeInst ance.java:534)
at org.apache.velocity.app.VelocityEngine.init(VelocityEngine.j ava:144)
at org.eclipse.jpt.gen.internal2.PackageGenerator2.generateClas s(PackageGenerator2.java:188)
... 6 more


it seems that the log4j jar is missing. Is it at the plugin level?

thanks

Ludovic
Re: Problem with generating entity from table [message #496582 is a reply to message #495783] Tue, 10 November 2009 15:59 Go to previous messageGo to next message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
The log4j jar should be in your installation's plugin directory. It sounds like a possible installation problem if it isn't there, or cannot be loaded. How did you install Dali?

Neil
Re: Problem with generating entity from table [message #496705 is a reply to message #496582] Wed, 11 November 2009 04:45 Go to previous messageGo to next message
Ludovic  is currently offline Ludovic
Messages: 7
Registered: November 2009
Junior Member
Neil,

Thanks for your answer.
I installed from the yoxos free download. (Java EE profile + a couple of other plug-ins).

I just checked in the plug-ins detail of my eclipse installation and I can see the Apache Jakarta log4j plugin (plugin id = org.apache.log4j).

I still have the same error.

thanks

Ludovic
Re: Problem with generating entity from table [message #497128 is a reply to message #496705] Thu, 12 November 2009 14:51 Go to previous messageGo to next message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
If you have time, give the base Java EE package a try and see if you have the same problem.

http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/galileo/SR1/eclipse-jee-galileo-SR1 -win32.zip

Thanks,
Neil
Re: Problem with generating entity from table [message #497388 is a reply to message #494662] Fri, 13 November 2009 04:51 Go to previous messageGo to next message
Ludovic  is currently offline Ludovic
Messages: 7
Registered: November 2009
Junior Member
Yes I tried, it's working fine with the eclipse distribution.

Something is wrong with the yoxos one. Weird because I just dowloaded the default JEE package from them, so it should work the same as the eclipse one.

thx

Ludovic
Re: Problem with generating entity from table [message #617674 is a reply to message #495783] Tue, 10 November 2009 15:59 Go to previous messageGo to next message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
The log4j jar should be in your installation's plugin directory. It sounds like a possible installation problem if it isn't there, or cannot be loaded. How did you install Dali?

Neil
Re: Problem with generating entity from table [message #617676 is a reply to message #617674] Wed, 11 November 2009 04:45 Go to previous messageGo to next message
Ludovic  is currently offline Ludovic
Messages: 7
Registered: November 2009
Junior Member
Neil,

Thanks for your answer.
I installed from the yoxos free download. (Java EE profile + a couple of other plug-ins).

I just checked in the plug-ins detail of my eclipse installation and I can see the Apache Jakarta log4j plugin (plugin id = org.apache.log4j).

I still have the same error.

thanks

Ludovic
Re: Problem with generating entity from table [message #617678 is a reply to message #617676] Thu, 12 November 2009 14:51 Go to previous message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
If you have time, give the base Java EE package a try and see if you have the same problem.

http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/galileo/SR1/eclipse-jee-galileo-SR1 -win32.zip

Thanks,
Neil
Previous Topic:Problem with generating entity from table
Next Topic:Customize Composite Key Names
Goto Forum:
  


Current Time: Sat Oct 25 03:40:50 GMT 2014

Powered by FUDForum. Page generated in 0.05157 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software