Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Can not add an eclipse console into RCP app
Can not add an eclipse console into RCP app [message #494013] Wed, 28 October 2009 19:04 Go to next message
asier  is currently offline asier
Messages: 4
Registered: July 2009
Junior Member
Hi,

I have problems when I want to add a console to my RCP application. I have tried two ways:

1. Add the dependencie org.eclipse.ui.console. Is it deprectaed? Because I can not execute my product correctly if I add this dependencie and therefore I can use the ConsoleView.

2. I have tried the solution that appears in tthis link: http://dev.eclipse.org/blogs/wayne/2006/10/19/displaying-the -console-in-your-rcp-application/ and the solution that gives in one of the acorona too. But I have problems with threads that the system generate when I use a timer for example.

I use Eclipse RCP 3.4.

Can you give me an advice on how to add or simulate a console in my RCP application to show all the system.out.println that I use in it?

Thanks in advance,

Asier.

Re: Can not add an eclipse console into RCP app [message #494099 is a reply to message #494013] Thu, 29 October 2009 08:44 Go to previous messageGo to next message
asier  is currently offline asier
Messages: 4
Registered: July 2009
Junior Member
Hi again,

I have discovered in the log that in the first option I have a problem with the bundle. The log is this one:
Quote:
!SESSION 2009-10-29 09:41:18.170 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_16
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
Framework arguments: -product SP.productB
Command-line arguments: -product SP.productB -data D:\Users\antaios\eclipseWorkspaces\O3SPws\SP -dev file:D:/Users/antaios/eclipseWorkspaces/O3SPws/.metadata/.pl ugins/org.eclipse.pde.core/SP.Product/dev.properties -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.app 0 0 2009-10-29 09:41:18.843
!MESSAGE Product SP.productB could not be found.

!ENTRY org.eclipse.osgi 4 0 2009-10-29 09:41:18.859
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:236)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

!ENTRY org.eclipse.osgi 2 0 2009-10-29 09:41:18.869
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-10-29 09:41:18.870
!MESSAGE Bundle initial@reference:file:../../../Users/antaios/eclipseWorkspaces/O3SPws/SP/ was not resolved.
!SUBENTRY 2 SP 2 0 2009-10-29 09:41:18.870
!MESSAGE Missing required bundle org.eclipse.ui.console_3.3.1.

!ENTRY org.eclipse.osgi 2 0 2009-10-29 09:41:18.874
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-10-29 09:41:18.874
!MESSAGE Bundle initial@reference:file:../../../Users/antaios/eclipseWorkspaces/O3SPws/SP/ [46] was not resolved.
!SUBENTRY 2 SP 2 0 2009-10-29 09:41:18.874
!MESSAGE Missing required bundle org.eclipse.ui.console_3.3.1.


can you help me, please?

Asier.
Re: Can not add an eclipse console into RCP app [message #494145 is a reply to message #494099] Thu, 29 October 2009 11:33 Go to previous message
asier  is currently offline asier
Messages: 4
Registered: July 2009
Junior Member
Finally I found the solution. I had forgotten to push "add required plug-ins" button of my product.
Previous Topic:Manipulate strength and color of table/tree viewer grid?
Next Topic:Developer/isv documentation in target platform
Goto Forum:
  


Current Time: Wed Oct 01 12:17:16 GMT 2014

Powered by FUDForum. Page generated in 0.11137 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software